Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Pages: 1 ... 33 34 [35] 36 37 ... 74

Author Topic: [0.97a] Realistic Combat 2.0.4  (Read 280736 times)

Liral

  • Admiral
  • *****
  • Posts: 718
  • Realistic Combat Mod Author
    • View Profile
Re: [0.95.1a] Realistic Combat 1.20.4
« Reply #510 on: September 22, 2022, 03:22:18 PM »

Quote
Wait, it no longer shows fighter damage!? D:  Please list reproduction steps.

No reproduction steps, just since the patch where you fixed that it didnt show any hull and barely any armor damage, it stopped showing LPCs under the ships damage charts.
Previously it had them there just like other weapons installed on the ship.

Uh-oh...

Quote
had another spooky nullpoooooooooooooooooointer crash x)
Edit: happened when i told my ship to eliminate in test combat, and it went for the enemy. It was about to get pretty close when game crashed.

Code
15198277 [Thread-3] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
at calculation.Lead$WeaponGroupDerivedStats.<init>(Lead.java:53)
at calculation.Lead$WeaponGroupDerivedStats.<init>(Lead.java:10)
at calculation.Lead.getLead(Lead.java:126)
at listeners.ThreeDimensionalTargeting.getWeaponBaseRangeMultMod(ThreeDimensionalTargeting.java:152)
at com.fs.starfarer.api.combat.listeners.CombatListenerUtil.getWeaponBaseRangeMultMod(CombatListenerUtil.java:143)
at com.fs.starfarer.api.util.Misc.getAdjustedBaseRange(Misc.java:5901)
at com.fs.starfarer.combat.entities.ship.o0OO.getAdjustedBaseRange(Unknown Source)
at com.fs.starfarer.combat.entities.ship.A.if.getRange(Unknown Source)
at com.fs.starfarer.combat.ai.ooOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.o00000(Unknown Source)
at com.fs.starfarer.combat.ai.ooOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.o00000(Unknown Source)
at com.fs.starfarer.combat.ai.ooOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.รถ00000(Unknown Source)
at com.fs.starfarer.combat.ai.ooOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.o00000(Unknown Source)
at com.fs.starfarer.combat.ai.BasicShipAI.advance(Unknown Source)
at com.fs.starfarer.combat.CombatEngine.advanceInner(Unknown Source)
at com.fs.starfarer.combat.CombatEngine.advance(Unknown Source)
at com.fs.starfarer.combat.CombatState.traverse(Unknown Source)
at com.fs.state.AppDriver.begin(Unknown Source)
at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
at java.lang.Thread.run(Thread.java:748)

Fixed!

Liral

  • Admiral
  • *****
  • Posts: 718
  • Realistic Combat Mod Author
    • View Profile
Re: [0.95.1a] Realistic Combat 1.20.4
« Reply #511 on: September 22, 2022, 03:22:48 PM »

Hotfix 1.20.5 is out!  Fixed a null-pointer error and, I hope, the problem of weapons not firing.  Changed the tooltip descriptions of damage to ones relevant to Realistic Combat: armor penetration and hull and compartment damage.
« Last Edit: September 22, 2022, 03:27:04 PM by Liral »
Logged

xZarif

  • Ensign
  • *
  • Posts: 19
    • View Profile
Re: [0.95.1a] Realistic Combat 1.20.5
« Reply #512 on: September 22, 2022, 04:14:26 PM »

Great work on that rapid fire bug, working like a charm for the past few days. I do have something different to report, but related to another mod, Detailed Combat Results. Most results work as expected, but carrier results are not showing fighter/bombers in their results. See example: https://imgur.com/a/mAc4dIg
This happens in fights I know for sure that the wings are dealing plenty of damage. Nick XR, the author of DCR, figures it's a matter of certain damages not being reported. https://fractalsoftworks.com/forum/index.php?topic=11551.msg377093#msg377093
I appreciate you going the extra length to make this mod compatible with another great mod. Thanks!
Logged

Liral

  • Admiral
  • *****
  • Posts: 718
  • Realistic Combat Mod Author
    • View Profile
Re: [0.95.1a] Realistic Combat 1.20.6
« Reply #513 on: September 22, 2022, 08:01:00 PM »

Hotfix 1.20.6 is out! Fixed not reporting fighter weapon damage to DCR, tweaked projectile indicator sizes, and, by putting in the indicator config lines that should have been in Indicators.json already, fixed a hitherto unreported bug that would, because they weren't there yet, cause problems if you ever turned off the default indicator settings toggle because the indicator settings loader would hunt for lines that weren't there.

Slomes

  • Ensign
  • *
  • Posts: 22
    • View Profile
Re: [0.95.1a] Realistic Combat 1.20.6
« Reply #514 on: September 22, 2022, 08:30:46 PM »

Thanks for the DCR fix!
Sadly it seems (on 1.20.5) weapons not firing properly still persists. had a Hyperion with two rapidfire pulsers and it was just flying around most of the fight with shields up and 0 flux unless it got hardfocused, and ocassionally shooting single shots with one or both, if at all, instead of machinegunning both.
Edit: Beams work fine tho. Its just projectiles it seems. Trying different setups in test combat netted similar results.
« Last Edit: September 22, 2022, 08:37:05 PM by Slomes »
Logged

Liral

  • Admiral
  • *****
  • Posts: 718
  • Realistic Combat Mod Author
    • View Profile
Re: [0.95.1a] Realistic Combat 1.20.6
« Reply #515 on: September 22, 2022, 08:50:09 PM »

Thanks for the DCR fix!

Welcome!

Quote
Sadly it seems (on 1.20.5) weapons not firing properly still persists. had a Hyperion with two rapidfire pulsers and it was just flying around most of the fight with shields up and 0 flux unless it got hardfocused, and ocassionally shooting single shots with one or both, if at all, instead of machinegunning both.

Edit: Beams work fine tho. Its just projectiles it seems. Trying different setups in test combat netted similar results.

 ???  :o  :-[  :(  :'(  >:(  :-\

Here we go again...

Liral

  • Admiral
  • *****
  • Posts: 718
  • Realistic Combat Mod Author
    • View Profile
Re: [0.95.1a] Realistic Combat 1.20.7
« Reply #516 on: September 22, 2022, 10:32:18 PM »

Hotfix 1.20.7 is out! Fixed weapons not firing by limiting non-launcher projectile weapon locking to the selected weapon group, if it is not autofiring and the autopilot is off, of the player ship.
« Last Edit: September 22, 2022, 10:42:10 PM by Liral »
Logged

gentulf

  • Ensign
  • *
  • Posts: 42
    • View Profile
Re: [0.95.1a] Realistic Combat 1.20.7
« Reply #517 on: September 23, 2022, 03:23:22 AM »

Hopefully Liral won't have to hire a whole dev team for this project  ;D
Logged

ThiccChungus

  • Ensign
  • *
  • Posts: 9
    • View Profile
Re: [0.95.1a] Realistic Combat 1.19.0
« Reply #518 on: September 23, 2022, 02:38:31 PM »



I'll add a fighter non-launcher muzzle velocity factor in the next release.

updates on this?
Logged

rarewhalerw

  • Ensign
  • *
  • Posts: 21
    • View Profile
Re: [0.95.1a] Realistic Combat 1.20.7
« Reply #519 on: September 23, 2022, 10:10:38 PM »

Hotfix 1.20.7 is out! Fixed weapons not firing by limiting non-launcher projectile weapon locking to the selected weapon group, if it is not autofiring and the autopilot is off, of the player ship.
help my weapons are not firing beam weapons are fine but some medium and large ballistic or non-beam energy weapon dont fire
Logged

G00D80T

  • Ensign
  • *
  • Posts: 3
    • View Profile
Re: [0.95.1a] Realistic Combat 1.20.7
« Reply #520 on: September 24, 2022, 12:24:36 AM »

How can i fix it?
ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Key [aiType] has invalid value [BURN_DRIVE_TOGGLE] in [{"loopSound":"system_burn_drive_loop","engineGlowWidthMult":"3","clampTurnRateAfter":"true","aiType":"BURN_DRIVE_TOGGLE","statsScript":"shipsystems.scripts.BurnDriveStats","alwaysAccelerate":"true","aiHints":{"activeSpeedIncrease":"100","burstMovementPotential":"0","averageSpeedIncrease":"100"},"flameoutOnImpactChance":"0.5","type":"ENGINE_MOD","outOfUsesSound":"engine_disabled","id":"burndrive","useSound":"system_burn_drive_activate","deactivateSound":"system_burn_drive_deactivate","clampMaxSpeedAfter":"true","engineGlowLengthMult":"2.5","engineGlowGlowMult":"2"}]
java.lang.RuntimeException: Key [aiType] has invalid value [BURN_DRIVE_TOGGLE] in [{"loopSound":"system_burn_drive_loop","engineGlowWidthMult":"3","clampTurnRateAfter":"true","aiType":"BURN_DRIVE_TOGGLE","statsScript":"shipsystems.scripts.BurnDriveStats","alwaysAccelerate":"true","aiHints":{"activeSpeedIncrease":"100","burstMovementPotential":"0","averageSpeedIncrease":"100"},"flameoutOnImpactChance":"0.5","type":"ENGINE_MOD","outOfUsesSound":"engine_disabled","id":"burndrive","useSound":"system_burn_drive_activate","deactivateSound":"system_burn_drive_deactivate","clampMaxSpeedAfter":"true","engineGlowLengthMult":"2.5","engineGlowGlowMult":"2"}]
ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Key [aiType] has invalid value [BURN_DRIVE_TOGGLE] in [{"loopSound":"system_burn_drive_loop","engineGlowWidthMult":"3","clampTurnRateAfter":"true","aiType":"BURN_DRIVE_TOGGLE","statsScript":"shipsystems.scripts.BurnDriveStats","alwaysAccelerate":"true","aiHints":{"activeSpeedIncrease":"100","burstMovementPotential":"0","averageSpeedIncrease":"100"},"flameoutOnImpactChance":"0.5","type":"ENGINE_MOD","outOfUsesSound":"engine_disabled","id":"burndrive","useSound":"system_burn_drive_activate","deactivateSound":"system_burn_drive_deactivate","clampMaxSpeedAfter":"true","engineGlowLengthMult":"2.5","engineGlowGlowMult":"2"}]
java.lang.RuntimeException: Key [aiType] has invalid value [BURN_DRIVE_TOGGLE] in [{"loopSound":"system_burn_drive_loop","engineGlowWidthMult":"3","clampTurnRateAfter":"true","aiType":"BURN_DRIVE_TOGGLE","statsScript":"shipsystems.scripts.BurnDriveStats","alwaysAccelerate":"true","aiHints":{"activeSpeedIncrease":"100","burstMovementPotential":"0","averageSpeedIncrease":"100"},"flameoutOnImpactChance":"0.5","type":"ENGINE_MOD","outOfUsesSound":"engine_disabled","id":"burndrive","useSound":"system_burn_drive_activate","deactivateSound":"system_burn_drive_deactivate","clampMaxSpeedAfter":"true","engineGlowLengthMult":"2.5","engineGlowGlowMult":"2"}]
Logged

Liral

  • Admiral
  • *****
  • Posts: 718
  • Realistic Combat Mod Author
    • View Profile
Re: [0.95.1a] Realistic Combat 1.20.7
« Reply #521 on: September 24, 2022, 05:04:56 AM »

help my weapons are not firing beam weapons are fine but some medium and large ballistic or non-beam energy weapon dont fire

Oh no.  What are the reproduction steps?

P.S. Punctuation, please. :P

How can i fix it?
ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Key [aiType] has invalid value [BURN_DRIVE_TOGGLE] in [{"loopSound":"system_burn_drive_loop","engineGlowWidthMult":"3","clampTurnRateAfter":"true","aiType":"BURN_DRIVE_TOGGLE","statsScript":"shipsystems.scripts.BurnDriveStats","alwaysAccelerate":"true","aiHints":{"activeSpeedIncrease":"100","burstMovementPotential":"0","averageSpeedIncrease":"100"},"flameoutOnImpactChance":"0.5","type":"ENGINE_MOD","outOfUsesSound":"engine_disabled","id":"burndrive","useSound":"system_burn_drive_activate","deactivateSound":"system_burn_drive_deactivate","clampMaxSpeedAfter":"true","engineGlowLengthMult":"2.5","engineGlowGlowMult":"2"}]
java.lang.RuntimeException: Key [aiType] has invalid value [BURN_DRIVE_TOGGLE] in [{"loopSound":"system_burn_drive_loop","engineGlowWidthMult":"3","clampTurnRateAfter":"true","aiType":"BURN_DRIVE_TOGGLE","statsScript":"shipsystems.scripts.BurnDriveStats","alwaysAccelerate":"true","aiHints":{"activeSpeedIncrease":"100","burstMovementPotential":"0","averageSpeedIncrease":"100"},"flameoutOnImpactChance":"0.5","type":"ENGINE_MOD","outOfUsesSound":"engine_disabled","id":"burndrive","useSound":"system_burn_drive_activate","deactivateSound":"system_burn_drive_deactivate","clampMaxSpeedAfter":"true","engineGlowLengthMult":"2.5","engineGlowGlowMult":"2"}]
ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Key [aiType] has invalid value [BURN_DRIVE_TOGGLE] in [{"loopSound":"system_burn_drive_loop","engineGlowWidthMult":"3","clampTurnRateAfter":"true","aiType":"BURN_DRIVE_TOGGLE","statsScript":"shipsystems.scripts.BurnDriveStats","alwaysAccelerate":"true","aiHints":{"activeSpeedIncrease":"100","burstMovementPotential":"0","averageSpeedIncrease":"100"},"flameoutOnImpactChance":"0.5","type":"ENGINE_MOD","outOfUsesSound":"engine_disabled","id":"burndrive","useSound":"system_burn_drive_activate","deactivateSound":"system_burn_drive_deactivate","clampMaxSpeedAfter":"true","engineGlowLengthMult":"2.5","engineGlowGlowMult":"2"}]
java.lang.RuntimeException: Key [aiType] has invalid value [BURN_DRIVE_TOGGLE] in [{"loopSound":"system_burn_drive_loop","engineGlowWidthMult":"3","clampTurnRateAfter":"true","aiType":"BURN_DRIVE_TOGGLE","statsScript":"shipsystems.scripts.BurnDriveStats","alwaysAccelerate":"true","aiHints":{"activeSpeedIncrease":"100","burstMovementPotential":"0","averageSpeedIncrease":"100"},"flameoutOnImpactChance":"0.5","type":"ENGINE_MOD","outOfUsesSound":"engine_disabled","id":"burndrive","useSound":"system_burn_drive_activate","deactivateSound":"system_burn_drive_deactivate","clampMaxSpeedAfter":"true","engineGlowLengthMult":"2.5","engineGlowGlowMult":"2"}]


What are the steps to reproduce the bug?
« Last Edit: September 24, 2022, 05:07:10 AM by Liral »
Logged

TheStaplergun

  • Ensign
  • *
  • Posts: 2
    • View Profile
Re: [0.95.1a] Realistic Combat 1.20.4
« Reply #522 on: September 24, 2022, 08:06:45 AM »

The mod appears to be making my ships be permanently stuck in retreat. I'm not exactly sure what is going on, but as soon as a battle commences, they all immediately go into retreat (The T key).

My keyboard is working fine, and issuing the full retreat command (The E key by default) does override it, but trying to hit search and destroy or any other form of command gets immediately overridden by the retreat. My commanded ship will continue to fly forward, but upon issuing it an order through the command UI, the ship immediately starts retreating as if the T key is pressed. I can even hold down keys and it doesn't work.

That sounds like you are low on Combat readiness?

I've gone into fights with lower combat readiness and they don't retreat until I order them to. I've never experienced it, and upon uninstalling the mod, the same exact fight (I quicksaved beforehand) didn't have the ships retreating. They worked perfectly fine after.
Logged

spazza

  • Ensign
  • *
  • Posts: 20
    • View Profile
Re: [0.95.1a] Realistic Combat 1.20.7
« Reply #523 on: September 24, 2022, 10:45:01 AM »

i had disabled the mod and decided to try it again after reading some fixes but my assault chainguns still wont fire while my pulse lasers and mining blasters are autofiring fine still
Logged

Liral

  • Admiral
  • *****
  • Posts: 718
  • Realistic Combat Mod Author
    • View Profile
Re: [0.95.1a] Realistic Combat 1.20.7
« Reply #524 on: September 24, 2022, 12:29:51 PM »

i had disabled the mod and decided to try it again after reading some fixes but my assault chainguns still wont fire while my pulse lasers and mining blasters are autofiring fine still

Does this happen to all assault chainguns, all the time, or just in certain situations?
Pages: 1 ... 33 34 [35] 36 37 ... 74