Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: A Tale of Two Tech Levels (05/28/21)

Author Topic: java.lang.IncompatibleClassChangeError when attempting to join a battle  (Read 1632 times)

drdragoon

  • Ensign
  • *
  • Posts: 8
    • View Profile

Code
java.lang.IncompatibleClassChangeError: Expecting non-static method data.scripts.campaign.missions.SSP_FactionCommissionMissionEvent.addFactionNameTokens(Ljava/util/Map;Ljava/lang/String;Lcom/fs/starfarer/api/campaign/FactionAPI;)V
at data.scripts.campaign.missions.SSP_FactionCommissionMissionEvent.getTokenReplacements(SSP_FactionCommissionMissionEvent.java:255)
at com.fs.starfarer.api.impl.campaign.events.BaseEventPlugin.addTokensToList(BaseEventPlugin.java:384)
at data.scripts.campaign.missions.SSP_FactionCommissionMissionEvent.getHighlights(SSP_FactionCommissionMissionEvent.java:230)
at com.fs.starfarer.campaign.CampaignEngine.reportEventStage(Unknown Source)
at data.scripts.campaign.missions.SSP_FactionCommissionMissionEvent.reportBattleOccurred(SSP_FactionCommissionMissionEvent.java:333)
at com.fs.starfarer.campaign.CampaignEngine.reportBattleOccurred(Unknown Source)
at com.fs.starfarer.api.impl.campaign.FleetEncounterContext.applyAfterBattleEffectsIfThereWasABattle(FleetEncounterContext.java:668)
at com.fs.starfarer.api.impl.campaign.FleetInteractionDialogPluginImpl$3.coreUIDismissed(FleetInteractionDialogPluginImpl.java:1159)
at com.fs.starfarer.ui.newui.T$2.coreUIDismissed(Unknown Source)
at com.fs.starfarer.ui.newui.J.dismiss(Unknown Source)
at com.fs.starfarer.coreui.publicsuper.actionPerformed(Unknown Source)
at com.fs.starfarer.ui.interfacesuper.o00000(Unknown Source)
at com.fs.starfarer.ui.H.processInput(Unknown Source)
at com.fs.starfarer.ui.U.super(Unknown Source)
at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
at com.fs.state.AppDriver.begin(Unknown Source)
at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

I receive this error when attempting to join a large battle that is ongoing between Pirates, Independent, and Tri-Tachyon.

Running mods:

Dynasector 1.0.2
Combat Chatter 1.4
Common Radar 2.2
Console Commands 2.7
Interstellar Imperium 1.12.0
LazyLib 2.1
Ship/Weapon Pack 1.0.2
Starsector AI Overhaul Alpha 1
ZZ Audio Plus 1.0.1
ZZ GraphicsLib 1.0.1
Logged

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2693
    • View Profile
    • Sc2Mafia
    • Email

I have absolutely no *** idea.  That crash is impossible with the mod list you gave.  I suspect you messed up your starsector folder somehow.
Logged

Histidine

  • Admiral
  • *****
  • Posts: 3242
    • View Profile
    • Bitbucket profile
    • Email

Wrong Starsector version?
Logged