Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Pages: 1 ... 15 16 [17] 18 19

Author Topic: [0.96a]Epta Consortium - 2.1.0 - NO LONGER IN DEVELOPMENT  (Read 201172 times)

Algoul

  • Lieutenant
  • **
  • Posts: 99
    • View Profile
Re: [0.95.1a]Epta Consortium - 1.5.2d
« Reply #240 on: January 22, 2023, 08:57:22 AM »

Thank you for you work and i have question: 1.6.SO4 from discord and 1.5.2, are these versions impossible to run together as one mod?
Logged

Rav0n

  • Commander
  • ***
  • Posts: 170
  • Discord: rav0n_vii - talk to me here!
    • View Profile
Re: [0.95.1a]Epta Consortium - 1.5.2d
« Reply #241 on: January 23, 2023, 09:52:11 AM »

Thank you for you work and i have question: 1.6.SO4 from discord and 1.5.2, are these versions impossible to run together as one mod?

Hey hey, how are u? And well, 1.5.2d is the most stable version. While the 1.6.SO4, is the unstable one, but with more features, such the super dreadnought ship colony from epta. Unfortunately I can't mix the 2 in one, due to how different they are, and the fact that the version 2.0.0 is comming. Thx for playing the mod^^
Logged

TimeDiver

  • Captain
  • ****
  • Posts: 354
    • View Profile
Re: [0.95.1a]Epta Consortium - 1.5.2d
« Reply #242 on: January 23, 2023, 10:00:04 AM »

Unfortunately I can't mix the 2 in one, due to how different they are, and the fact that the version 2.0.0 is comming. Thx for playing the mod^^
I have to ask; will v2.0.0 be compatible with current saves? Or will it require a new campaign/start?

With the new releases (v3.2x) of Industrial Evolution, I'm already considering a new start, but still.
Logged

Rav0n

  • Commander
  • ***
  • Posts: 170
  • Discord: rav0n_vii - talk to me here!
    • View Profile
Re: [0.95.1a]Epta Consortium - 1.5.2d
« Reply #243 on: January 23, 2023, 02:00:27 PM »

Unfortunately I can't mix the 2 in one, due to how different they are, and the fact that the version 2.0.0 is comming. Thx for playing the mod^^
I have to ask; will v2.0.0 be compatible with current saves? Or will it require a new campaign/start?

With the new releases (v3.2x) of Industrial Evolution, I'm already considering a new start, but still.

Epta is being redone, so, there is no way to make the 2.0.0 compatible with older versions, but don't worry, I have sure that will be worth it!
Logged

Malhavoc

  • Ensign
  • *
  • Posts: 11
  • Muscle Wizard
    • View Profile
Re: [0.95.1a]Epta Consortium - 1.5.2d
« Reply #244 on: January 30, 2023, 05:21:08 PM »

So I completed the mission to unlock the new ship, but I found that if I start/load a game, then return to the main menu and try to start another game, the number of unlocked super ships goes up by one, and starting/loading a game causes a "Copies of campaign data in memory: #" error with a memory leak warning. Returning to the menu causes the ship number to go up again, and the "campaign data in memory" also goes up by one.

I'm hoping the upcoming version will address things, but I just wanted to let you know of the issue in the meantime. The game is still playable, it just requires restarting the game if you exit to the main menu at all.
Logged
I CAST FIST!

BreenBB

  • Commander
  • ***
  • Posts: 150
    • View Profile
Re: [0.95.1a]Epta Consortium - 1.5.2d
« Reply #245 on: January 31, 2023, 05:05:27 AM »

Interesting how progress on yours mod? I saw new Aeolus sprite, how much stuff you plan to redo?

Also another thing, I really lhow Epta markets work, like they use moving trade bases and super dreadnought instead of just sitting on planets, but there is one big issue, these features are not present in random sector in Nex, they just have average planets like rest of factions, and no trade bases and super dreadnought, so pretty much chunk of mod content is missing, like unique markets and such. Also I like what your super ship and weapon market seems much less restricted than Prism Freeport, mod makers tend to close alot of stuff from Prism so it simply loss its purpose of market with rare stuff, I hope they will stay that way.

Also another QoL feature suggestions about markets, I'd like to have some sort of ability to spot Epta super dreadnought system, or if player found it, unhide it from a map, and give unique names for trade bases, so player know which unique store it will have.
Logged

Rav0n

  • Commander
  • ***
  • Posts: 170
  • Discord: rav0n_vii - talk to me here!
    • View Profile
Re: [0.95.1a]Epta Consortium - 1.5.2d
« Reply #246 on: February 02, 2023, 05:41:54 AM »

So I completed the mission to unlock the new ship, but I found that if I start/load a game, then return to the main menu and try to start another game, the number of unlocked super ships goes up by one, and starting/loading a game causes a "Copies of campaign data in memory: #" error with a memory leak warning. Returning to the menu causes the ship number to go up again, and the "campaign data in memory" also goes up by one.

I'm hoping the upcoming version will address things, but I just wanted to let you know of the issue in the meantime. The game is still playable, it just requires restarting the game if you exit to the main menu at all.

Heyo, going well? About that bug, this is an issue that happens with ships unlockable via missions, though its deceptive because it doesnt actually create campaign copies, so dw, game wise will not prejudice your pc. Thx for the feedback^^
Logged

Rav0n

  • Commander
  • ***
  • Posts: 170
  • Discord: rav0n_vii - talk to me here!
    • View Profile
Re: [0.95.1a]Epta Consortium - 1.5.2d
« Reply #247 on: February 02, 2023, 05:48:08 AM »

Interesting how progress on yours mod? I saw new Aeolus sprite, how much stuff you plan to redo?

Also another thing, I really lhow Epta markets work, like they use moving trade bases and super dreadnought instead of just sitting on planets, but there is one big issue, these features are not present in random sector in Nex, they just have average planets like rest of factions, and no trade bases and super dreadnought, so pretty much chunk of mod content is missing, like unique markets and such. Also I like what your super ship and weapon market seems much less restricted than Prism Freeport, mod makers tend to close alot of stuff from Prism so it simply loss its purpose of market with rare stuff, I hope they will stay that way.

Also another QoL feature suggestions about markets, I'd like to have some sort of ability to spot Epta super dreadnought system, or if player found it, unhide it from a map, and give unique names for trade bases, so player know which unique store it will have.

Hiyo, how are u? Well, everything in epta is being remade, it will have a new face after 2.0.0, trust me, everything is growing to better hehe. About the random sector, not much can be made, since it randomize everything to the standards, so even other modded factions will loss their uniquiness. About the markets, epta have the best for the best my friend, my though is to keep like that, until now, no regrets. About Proelefsi and the tradestations, gonna take care about it. Thx for the feedback^^
Logged

Raxos149

  • Ensign
  • *
  • Posts: 25
    • View Profile
Re: [0.95.1a]Epta Consortium - 1.5.2d
« Reply #248 on: February 02, 2023, 07:20:34 PM »

Quick question, what does "oversized missile ordinance" do?
Logged

Rav0n

  • Commander
  • ***
  • Posts: 170
  • Discord: rav0n_vii - talk to me here!
    • View Profile
Re: [0.95.1a]Epta Consortium - 1.5.2d
« Reply #249 on: February 10, 2023, 02:21:24 PM »

Quick question, what does "oversized missile ordinance" do?

Heyo, well, it makes your ship have literally no missile ammo, needing Expanded missile racks to actually ammo. Next update it description will explain that better.
Logged

Raxos149

  • Ensign
  • *
  • Posts: 25
    • View Profile
Re: [0.95.1a]Epta Consortium - 1.5.2d
« Reply #250 on: February 14, 2023, 05:09:12 PM »

Quick question, what does "oversized missile ordinance" do?

Heyo, well, it makes your ship have literally no missile ammo, needing Expanded missile racks to actually ammo. Next update it description will explain that better.

Uhhh... could you explain that better?

Are you saying that it is a mod that needs expanded missile racks in order to activate an additional function?? With that function being ridiculous amounts of ammo for missile weapons?
Logged

Rav0n

  • Commander
  • ***
  • Posts: 170
  • Discord: rav0n_vii - talk to me here!
    • View Profile
Re: [0.95.1a]Epta Consortium - 1.5.2d
« Reply #251 on: February 15, 2023, 03:09:13 AM »

Quick question, what does "oversized missile ordinance" do?

Heyo, well, it makes your ship have literally no missile ammo, needing Expanded missile racks to actually ammo. Next update it description will explain that better.

Uhhh... could you explain that better?

Are you saying that it is a mod that needs expanded missile racks in order to activate an additional function?? With that function being ridiculous amounts of ammo for missile weapons?

Ok, this hullmod takes out your missile ammo, which means, if you put a hurricane on this ship, it will not fire, bcs it not have ammo. But, if you install expanded missile racks, you will get ammo to actually fire that hurricane, got it?
Logged

Ruin21

  • Ensign
  • *
  • Posts: 7
    • View Profile
Re: [0.95.1a]Epta Consortium - 1.5.2d
« Reply #252 on: February 16, 2023, 10:19:37 AM »

I found a CTD bug with one of this mod's ships.
Game version: 0.95.1a-RC6
Mods used:
  • Console Commands v. 2021.12.25
  • Epta Consortium v. 1.5.2d
  • LazyLib v. 2.7b
  • MagicLib v. 0.45.2
  • Nexerelin v. 0.10.6c
  • WhichMod v. 1.2.1

When I build the Mibitsu Hobi Fighter ship hull given by the Takeshido Blueprint Package, I get a CTD at the end of month tick, when the ship would be properly built.
Log info for crash:
527405 [Thread-3] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
   at data.hullmods.FluxDistributor.applyEffectsBeforeShipCreation(FluxDistributor.java:22)
   at com.fs.starfarer.campaign.fleet.FleetMember.updateStats(Unknown Source)
   at com.fs.starfarer.campaign.fleet.FleetData.syncIfNeeded(Unknown Source)
   at com.fs.starfarer.api.impl.campaign.fleets.DefaultFleetInflater.inflate(DefaultFleetInflater.java:499)
   at com.fs.starfarer.campaign.fleet.CampaignFleet.inflateIfNeeded(Unknown Source)
   at com.fs.starfarer.api.impl.campaign.CoreScript.doCustomProduction(CoreScript.java:952)
   at com.fs.starfarer.api.impl.campaign.CoreScript.reportEconomyMonthEnd(CoreScript.java:1100)
   at com.fs.starfarer.campaign.CampaignEngine.reportEconomyMonthEnd(Unknown Source)
   at com.fs.starfarer.campaign.econ.reach.ReachEconomyStepper.doEndOfMonthStuff(Unknown Source)
   at com.fs.starfarer.campaign.econ.reach.ReachEconomyStepper.nextFrame(Unknown Source)
   at com.fs.starfarer.campaign.econ.Economy.advance(Unknown Source)
   at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
   at com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
   at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

If you need more info, let me know, and thanks for the great mod!
Logged

Rav0n

  • Commander
  • ***
  • Posts: 170
  • Discord: rav0n_vii - talk to me here!
    • View Profile
Re: [0.95.1a]Epta Consortium - 1.5.2d
« Reply #253 on: February 16, 2023, 02:11:47 PM »

I found a CTD bug with one of this mod's ships.
Game version: 0.95.1a-RC6
Mods used:
  • Console Commands v. 2021.12.25
  • Epta Consortium v. 1.5.2d
  • LazyLib v. 2.7b
  • MagicLib v. 0.45.2
  • Nexerelin v. 0.10.6c
  • WhichMod v. 1.2.1

When I build the Mibitsu Hobi Fighter ship hull given by the Takeshido Blueprint Package, I get a CTD at the end of month tick, when the ship would be properly built.
Log info for crash:
527405 [Thread-3] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
   at data.hullmods.FluxDistributor.applyEffectsBeforeShipCreation(FluxDistributor.java:22)
   at com.fs.starfarer.campaign.fleet.FleetMember.updateStats(Unknown Source)
   at com.fs.starfarer.campaign.fleet.FleetData.syncIfNeeded(Unknown Source)
   at com.fs.starfarer.api.impl.campaign.fleets.DefaultFleetInflater.inflate(DefaultFleetInflater.java:499)
   at com.fs.starfarer.campaign.fleet.CampaignFleet.inflateIfNeeded(Unknown Source)
   at com.fs.starfarer.api.impl.campaign.CoreScript.doCustomProduction(CoreScript.java:952)
   at com.fs.starfarer.api.impl.campaign.CoreScript.reportEconomyMonthEnd(CoreScript.java:1100)
   at com.fs.starfarer.campaign.CampaignEngine.reportEconomyMonthEnd(Unknown Source)
   at com.fs.starfarer.campaign.econ.reach.ReachEconomyStepper.doEndOfMonthStuff(Unknown Source)
   at com.fs.starfarer.campaign.econ.reach.ReachEconomyStepper.nextFrame(Unknown Source)
   at com.fs.starfarer.campaign.econ.Economy.advance(Unknown Source)
   at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
   at com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
   at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

If you need more info, let me know, and thanks for the great mod!

Hmm, this fighter ship should not appear without armaa, its a strikecraft, so needs armaa to function, or else literally should be ignored, will be fixed in the next version, thx for reporting, and also I that thank ya for playing the mod ^^
« Last Edit: February 16, 2023, 02:15:02 PM by xSevenG7x »
Logged

Raxos149

  • Ensign
  • *
  • Posts: 25
    • View Profile
Re: [0.95.1a]Epta Consortium - 1.5.2d
« Reply #254 on: February 16, 2023, 04:39:45 PM »

Quick question, what does "oversized missile ordinance" do?

Heyo, well, it makes your ship have literally no missile ammo, needing Expanded missile racks to actually ammo. Next update it description will explain that better.

Uhhh... could you explain that better?

Are you saying that it is a mod that needs expanded missile racks in order to activate an additional function?? With that function being ridiculous amounts of ammo for missile weapons?

Ok, this hullmod takes out your missile ammo, which means, if you put a hurricane on this ship, it will not fire, bcs it not have ammo. But, if you install expanded missile racks, you will get ammo to actually fire that hurricane, got it?

Sweet. Thank you for explaining that.

With that being said, what is the benefit of the mod if it actually takes away your missile complement? Do you get even more missiles for your ship if you install expanded missile racks after the oversized missile ordinance mod is installed? I am hoping to understand why one would wish to use it.
Logged
Pages: 1 ... 15 16 [17] 18 19