Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.97a is out! (02/02/24)

Pages: 1 ... 4 5 [6] 7 8

Author Topic: [0.96a] Nes's SAW 1.9h  (Read 154230 times)

Nes

  • Lieutenant
  • **
  • Posts: 59
    • View Profile
Re: [0.96a] Nes's SAW 1.9gg
« Reply #75 on: June 06, 2023, 06:29:48 AM »

The mod won't enable, it says it requires Magic Lib 1.0.
Update MagicLib.
Logged

Vundaex

  • Commander
  • ***
  • Posts: 115
    • View Profile
Re: [0.96a] Nes's SAW 1.9gg
« Reply #76 on: June 06, 2023, 04:15:27 PM »

The mod won't enable, it says it requires Magic Lib 1.0.
Update MagicLib.

I have the latest version.
Logged

Vundaex

  • Commander
  • ***
  • Posts: 115
    • View Profile
Re: [0.96a] Nes's SAW 1.9gg
« Reply #77 on: June 07, 2023, 02:49:58 PM »

The game keeps automatically disabling your addon because it calls an older version of Magiclib.
Logged

Nes

  • Lieutenant
  • **
  • Posts: 59
    • View Profile
Re: [0.96a] Nes's SAW 1.9gg
« Reply #78 on: June 09, 2023, 10:34:11 PM »

Not the mod problem. Seek issues on your end.
Logged

Killsode

  • Captain
  • ****
  • Posts: 398
    • View Profile
Re: [0.96a] Nes's SAW 1.9gg
« Reply #79 on: June 09, 2023, 10:58:02 PM »

The game keeps automatically disabling your addon because it calls an older version of Magiclib.

Either there is an update for magiclib you need to grab, or you need to adjust the mod_info.json to removing a bugging dependency.
A better option you should first try is deleting and reinstalling your Magiclib and Nes's Saw first.
Logged

Vundaex

  • Commander
  • ***
  • Posts: 115
    • View Profile
Re: [0.96a] Nes's SAW 1.9gg
« Reply #80 on: June 10, 2023, 06:54:14 AM »

The game keeps automatically disabling your addon because it calls an older version of Magiclib.

Either there is an update for magiclib you need to grab, or you need to adjust the mod_info.json to removing a bugging dependency.
A better option you should first try is deleting and reinstalling your Magiclib and Nes's Saw first.

I already did that multiple times. Looks like it comes from the mod manager disabling this specific mod because of the magiclib issue.
Logged

Killsode

  • Captain
  • ****
  • Posts: 398
    • View Profile
Re: [0.96a] Nes's SAW 1.9gg
« Reply #81 on: June 10, 2023, 01:28:09 PM »

The game keeps automatically disabling your addon because it calls an older version of Magiclib.

Either there is an update for magiclib you need to grab, or you need to adjust the mod_info.json to removing a bugging dependency.
A better option you should first try is deleting and reinstalling your Magiclib and Nes's Saw first.

I already did that multiple times. Looks like it comes from the mod manager disabling this specific mod because of the magiclib issue.

Try clearing the dependencies in Nes's mod_info.json then
Logged

Nes

  • Lieutenant
  • **
  • Posts: 59
    • View Profile
Re: [0.96a] Nes's SAW 1.9ggg
« Reply #82 on: June 12, 2023, 01:46:04 PM »

Removed version dependency now that we are past initial MagicLib 0.96 release.

Anyhow, update 1.9ggg
A bunch of liveries for Carnelian, Hampter, and Hermitaur, meaning the whole roster now features the customization mechanic, yay to that!

Save compatible.
Logged

Nes

  • Lieutenant
  • **
  • Posts: 59
    • View Profile
Re: [0.96a] Nes's SAW 1.9ggg
« Reply #83 on: June 13, 2023, 06:22:52 AM »

Quick hotfix for some missing portraits.
Logged

Nes

  • Lieutenant
  • **
  • Posts: 59
    • View Profile
Re: [0.96a] Nes's SAW 1.9gggg
« Reply #84 on: July 04, 2023, 12:25:41 AM »

1.9gggg
WARNING: might not be save compatible with previous versions

just a quick update as per latest forum policies
-removed one portrait

Logged

tantananan

  • Ensign
  • *
  • Posts: 48
    • View Profile
Re: [0.96a] Nes's SAW 1.9gggg
« Reply #85 on: July 04, 2023, 09:48:47 PM »

version checker is showing 1.10gggg, but the update is 1.9gggg
Logged

Nes

  • Lieutenant
  • **
  • Posts: 59
    • View Profile
Re: [0.96a] Nes's SAW 1.9gggg
« Reply #86 on: July 04, 2023, 10:40:11 PM »

fixed version file
Logged

tantananan

  • Ensign
  • *
  • Posts: 48
    • View Profile
Re: [0.96a] Nes's SAW 1.9gggg
« Reply #87 on: July 07, 2023, 05:31:03 AM »

The Fluorspar is so much fun!
Logged

Nes

  • Lieutenant
  • **
  • Posts: 59
    • View Profile
Re: [0.96a] Nes's SAW 1.9ggggg
« Reply #88 on: July 27, 2023, 02:33:19 PM »

1.9ggggg
should be save compatible

quick update mainly to fix an elusive memory leak
« Last Edit: July 27, 2023, 02:37:21 PM by Nes »
Logged

Nes

  • Lieutenant
  • **
  • Posts: 59
    • View Profile
Re: [0.96a] Nes's SAW 1.9gggggg
« Reply #89 on: August 02, 2023, 02:09:31 PM »

1.9gggggg
another quick update that adds a listener to keep "system" tag weapons from showing up in the cargo hold, as well as improves Hermitaur qol

should be save compatible
Logged
Pages: 1 ... 4 5 [6] 7 8