Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95.1a is out! (12/10/21); Blog post: Hyperspace Topography (10/12/22)

Author Topic: Game won't load a ship I made.  (Read 2017 times)

manictiger

  • Ensign
  • *
  • Posts: 18
    • View Profile
Game won't load a ship I made.
« on: January 13, 2019, 02:52:23 PM »

I followed this tutorial:
http://starsector.wikia.com/wiki/Intro_to_Modding

And it won't load the ship into the game.  The ship I want in the game is 184 x 528 pixels, a little larger than an Odyssey, smaller than some Diablo Avionics capital ships.

Here's the following error:
Spoiler
98948 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Error loading [graphics/ships/altaica_dreadnought1b] resource, not found in [C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Altaican Empire,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Artefact,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Celestial Mount Circle,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Common Radar,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Console Commands,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Dassault-Mikoyan Engineering,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\DIABLEAVIONICS,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Extratential Lanestate Union,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\JP_RC,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Kadur Remnant,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\LazyLib,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Leading Pip,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Legacy of Arkgneisis,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\MagicLib,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Mayasuran Navy,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Neutrino corp,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\ORA,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Rebalanced Pilums,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\SCY,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Shadowyards,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\SkilledUp,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\SpeedUp,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Stop Gap Measure,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\sylphon,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Tyrador Safeguard Coalition,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\GraphicsLib,../starfarer.res/res,CLASSPATH]
java.lang.RuntimeException: Error loading [graphics/ships/altaica_dreadnought1b] resource, not found in [C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Altaican Empire,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Artefact,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Celestial Mount Circle,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Common Radar,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Console Commands,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Dassault-Mikoyan Engineering,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\DIABLEAVIONICS,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Extratential Lanestate Union,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\JP_RC,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Kadur Remnant,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\LazyLib,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Leading Pip,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Legacy of Arkgneisis,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\MagicLib,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Mayasuran Navy,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Neutrino corp,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\ORA,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Rebalanced Pilums,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\SCY,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Shadowyards,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\SkilledUp,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\SpeedUp,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Stop Gap Measure,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\sylphon,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\Tyrador Safeguard Coalition,C:\Program Files\Starsector.v0.9a-RC10\starsector-core\..\mods\GraphicsLib,../starfarer.res/res,CLASSPATH]
   at com.fs.util.ooOO.Ó00000(Unknown Source)
   at com.fs.util.ooOO.Ô00000(Unknown Source)
   at com.fs.graphics.TextureLoader.Ô00000(Unknown Source)
   at com.fs.graphics.TextureLoader.o00000(Unknown Source)
   at com.fs.graphics.TextureLoader.o00000(Unknown Source)
   at com.fs.graphics.TextureLoader.o00000(Unknown Source)
   at com.fs.graphics.OooO.o00000(Unknown Source)
   at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

[close]
« Last Edit: January 13, 2019, 02:58:39 PM by manictiger »
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 20988
    • View Profile
Re: Game won't load a ship I made.
« Reply #1 on: January 13, 2019, 03:03:46 PM »

java.lang.RuntimeException: Error loading [graphics/ships/altaica_dreadnought1b] resource

Sounds like you might've forgot a .png file extension for the sprite in your .ship file?
Logged

manictiger

  • Ensign
  • *
  • Posts: 18
    • View Profile
Re: Game won't load a ship I made.
« Reply #2 on: January 13, 2019, 03:27:22 PM »

java.lang.RuntimeException: Error loading [graphics/ships/altaica_dreadnought1b] resource

Sounds like you might've forgot a .png file extension for the sprite in your .ship file?

Thanks.  I was looking in the .csv file for the problem when it was the .ship file.  That solved it.
Logged