Fractal Softworks Forum

Please login or register.

Login with username, password and session length

Author Topic: Crash on start if sound enabled.  (Read 2346 times)

Lochal

  • Ensign
  • *
  • Posts: 1
    • View Profile
Crash on start if sound enabled.
« on: February 16, 2018, 10:06:47 PM »

Get a error message at startup:
Starsector 0.8.la-RC8

Error in sound initialization proceeding with sound disabled

org.lwjgl.openal.AL10.nalDistanceModel(i)V

Once I hit ok another error message appears

Starsector 0.8.la-RC8

Fatal: org.lwjgl.openal.AL10.nalDistanceModel(i)V
Check Starsector log for more info.

ok on this ends the application.
I do not see a starsector log anywhere and it will startup if I disable sound on the load menu. even on successful startup I do not see a log.

Note this is Windows 10 not Linux
Microsoft Windows 10 Pro
Version: 10.0.16299 build 16299

I did try updating openal with no success same error.
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 24069
    • View Profile
Re: Crash on start if sound enabled.
« Reply #1 on: February 16, 2018, 10:09:45 PM »

Hi - sorry about the trouble!

Per this thread:
http://fractalsoftworks.com/forum/index.php?topic=12734.0

If updating OpenAL didn't help, then running the game as administrator might - at least, it appears to have resolved this issue for several people.
Logged

Achataeon

  • Commander
  • ***
  • Posts: 169
  • ~stare~
    • View Profile
Re: Crash on start if sound enabled.
« Reply #2 on: March 07, 2018, 04:27:01 PM »

Relevant info:

Running the game with the sounds enabled, but with no device to play it on (i.e. you have no connected speakers, headphones or whatnot) will crash the game on startup 100% of the time.
Make sure you have your headphones, speakers, or whatever connected before you start the game with sound enabled. Otherwise, tick that sound option to off.
Logged
"On average, a human has one breast and one testicle"
- Vsauce, Michael here

herom51

  • Ensign
  • *
  • Posts: 1
    • View Profile
Re: Crash on start if sound enabled.
« Reply #3 on: June 14, 2020, 08:16:49 PM »

Okay, so I did two things before resetting my computer. My game launches without this crash message now, so ONE of them must have worked. I don't know which, hopefully someone can narrow it down in the near future. For now, here's the two things I did.
1: Install 64 / 32 bit Java (the highest your computer can handle) Manually https://www.java.com/en/download/manual.jsp
2: Install the Realtek audio driver https://www.realtek.com/en/component/zoo/category/pc-audio-codecs-high-definition-audio-codecs-software
(Be warned the download length for this will take 3 hours. God know's why since it's less than a gigabyte, but oh well.)

3: Uninstall the game (and all installer files associated with it just to be safe), restart your computer, then re install. Your issue should be solved. Be sure to keep your mods saved in a separate folder unless you're okay with manually downloading them again.
Logged