Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: A Tale of Two Tech Levels (05/28/21)

Pages: 1 2 [3] 4 5 ... 28

Author Topic: [Important!] Modded System Requirements  (Read 326359 times)

Frelus

  • Ensign
  • *
  • Posts: 6
    • View Profile
    • Email
Re: Can't Load Saves? Use 64-bit Java! (Instructions Inside)
« Reply #30 on: December 09, 2014, 10:44:30 AM »

Hey, look, I learned something new.  
x64 is 64 bit and x86 is 32 bit.  
I thought that the higher number should be the higher bitnumber and it was just strangely named, but now I know that x64 really is 64 bit and x86 is just strangely named.  
Well, at least I learned something.
Ninja: Works fine now, too.
Logged

apoch1999

  • Ensign
  • *
  • Posts: 2
    • View Profile
    • Email
Re: Can't Load Saves? Use 64-bit Java! (Instructions Inside)
« Reply #31 on: December 11, 2014, 09:26:38 PM »

heres what mine looks like and it just closes out when you run it.

start "C:\Program Files\Java\jre7\bin" java.exe -Djava.library.path=native\windows -Xms6g -Xmx6g -Dcom.fs.starfarer.settings.paths.logs=. -Dcom.fs.starfarer.settings.paths.saves=../saves -Dcom.fs.starfarer.settings.paths.screenshots=../screenshots -Dcom.fs.starfarer.settings.paths.mods=../mods -classpath janino.jar;commons-compiler.jar;commons-compiler-jdk.jar;starfarer.res.jar;starfarer.api.jar;starfarer_obf.jar;jogg-0.0.7.jar;jorbis-0.0.15.jar;json.jar;lwjgl.jar;lwjgl_util_applet.jar;jinput.jar;lwjgl_test.jar;log4j-1.2.9.jar;lwjgl_util.jar;fs.sound_obf.jar;fs.common_obf.jar;xstream-1.4.2.jar com.fs.starfarer.StarfarerLauncher
Logged

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2693
    • View Profile
    • Sc2Mafia
    • Email
Re: Can't Load Saves? Use 64-bit Java! (Instructions Inside)
« Reply #32 on: December 11, 2014, 09:29:29 PM »

That's because you deleted the "-java" part of it.
Logged

apoch1999

  • Ensign
  • *
  • Posts: 2
    • View Profile
    • Email
Re: Can't Load Saves? Use 64-bit Java! (Instructions Inside)
« Reply #33 on: December 11, 2014, 09:52:27 PM »

did or didnt? or just put the - back in front of it on the first line? someone posted earlier saying it should look like and thiers didnt have the java.exe there
Logged

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2693
    • View Profile
    • Sc2Mafia
    • Email
Re: Can't Load Saves? Use 64-bit Java! (Instructions Inside)
« Reply #34 on: December 11, 2014, 10:00:29 PM »

DO you actually have java installed at C:\Program Files\Java\jre7\bin?

There are multiple ways of doing this.  For example, mine looks like this:

java -Djava.library.path=native\windows -Xms4g -Xmx6g -Dcom.fs.starfarer.settings.paths.logs=. -Dcom.fs.starfarer.settings.paths.saves=../saves -Dcom.fs.starfarer.settings.paths.screenshots=../screenshots -Dcom.fs.starfarer.settings.paths.mods=../mods -classpath janino.jar;commons-compiler.jar;commons-compiler-jdk.jar;starfarer.res.jar;starfarer.api.jar;starfarer_obf.jar;jogg-0.0.7.jar;jorbis-0.0.15.jar;json.jar;lwjgl.jar;lwjgl_util_applet.jar;jinput.jar;lwjgl_test.jar;log4j-1.2.9.jar;lwjgl_util.jar;fs.sound_obf.jar;fs.common_obf.jar;xstream-1.4.2.jar;"..\\mods\Version Checker\jars\lw_VersionChecker.jar" com.fs.starfarer.StarfarerLauncher
Logged

MooBoogie

  • Ensign
  • *
  • Posts: 6
    • View Profile
Re: Can't Load Saves? Use 64-bit Java! (Instructions Inside)
« Reply #35 on: December 29, 2014, 04:04:23 PM »

I installed Java and I have it installed, I modified the files per the instructions, I ran the starsector.bat file and it worked fine, but none of the mods I've installed are showing up in the "Mods..." part of the launcher.

I've reinstalled, and done it again and then once another time, and the mods (Starsector Plus, LazyLib. ShaderLib, and Knights Templar) Are clearly in the mods folder, yet the game doesn't recognize them.

Help?
Logged

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2693
    • View Profile
    • Sc2Mafia
    • Email
Re: Can't Load Saves? Use 64-bit Java! (Instructions Inside)
« Reply #36 on: December 29, 2014, 06:21:50 PM »

Does your .bat file contain "-Dcom.fs.starfarer.settings.paths.mods=../mods"?
Logged

MooBoogie

  • Ensign
  • *
  • Posts: 6
    • View Profile
Re: Can't Load Saves? Use 64-bit Java! (Instructions Inside)
« Reply #37 on: December 29, 2014, 07:41:32 PM »

This is the file:


C:\Program Files\Starsector\starsector-core>java -Djava.library.path=native\wind
ows -Xms6g -Xmx8g -Dcom.fs.starfarer.settings.paths.logs=. -Dcom.fs.starfarer.se
ttings.paths.saves=../saves -Dcom.fs.starfarer.settings.paths.screenshots=../scr
eenshots -Dcom.fs.starfarer.settings.paths.mods=../mods -classpath janino.jar;co
mmons-compiler.jar;commons-compiler-jdk.jar;starfarer.res.jar;starfarer.api.jar;
starfarer_obf.jar;jogg-0.0.7.jar;jorbis-0.0.15.jar;json.jar;lwjgl.jar;lwjgl_util
_applet.jar;jinput.jar;lwjgl_test.jar;log4j-1.2.9.jar;lwjgl_util.jar;fs.sound_ob
f.jar;fs.common_obf.jar;xstream-1.4.2.jar com.fs.starfarer.StarfarerLauncher
0    [main] INFO  com.fs.starfarer.StarfarerLauncher  - Starting Starsector 0.65
.1a-RC1 launcher
1    [main] INFO  com.fs.starfarer.StarfarerLauncher  - Running in C:\Program Fi
les\Starsector\starsector-core
1    [main] INFO  com.fs.starfarer.StarfarerLauncher  - OS: Windows NT (unknown)
 6.2
1    [main] INFO  com.fs.starfarer.StarfarerLauncher  - Java version: 1.7.0 (64-
bit)
10   [main] INFO  com.fs.starfarer.loading.LoadingUtils  - Loading JSON from [da
ta/config/settings.json]
385  [main] INFO  com.fs.starfarer.StarfarerLauncher  - Found display mode: 640x
480, 60Hz, 32bpp
385  [main] INFO  com.fs.starfarer.StarfarerLauncher  - Found display mode: 720x
480, 60Hz, 32bpp
385  [main] INFO  com.fs.starfarer.StarfarerLauncher  - Found display mode: 720x
576, 60Hz, 32bpp
385  [main] INFO  com.fs.starfarer.StarfarerLauncher  - Found display mode: 800x
600, 60Hz, 32bpp
385  [main] INFO  com.fs.starfarer.StarfarerLauncher  - Found display mode: 1024
x768, 60Hz, 32bpp
386  [main] INFO  com.fs.starfarer.StarfarerLauncher  - Found display mode: 1152
x864, 75Hz, 32bpp
386  [main] INFO  com.fs.starfarer.StarfarerLauncher  - Found display mode: 1280
x720, 60Hz, 32bpp
386  [main] INFO  com.fs.starfarer.StarfarerLauncher  - Found display mode: 1280
x1024, 75Hz, 32bpp
386  [main] INFO  com.fs.starfarer.StarfarerLauncher  - Found display mode: 1280
x768, 60Hz, 32bpp
386  [main] INFO  com.fs.starfarer.StarfarerLauncher  - Found display mode: 1280
x800, 75Hz, 32bpp
387  [main] INFO  com.fs.starfarer.StarfarerLauncher  - Found display mode: 1280
x960, 75Hz, 32bpp
387  [main] INFO  com.fs.starfarer.StarfarerLauncher  - Found display mode: 1360
x768, 60Hz, 32bpp
387  [main] INFO  com.fs.starfarer.StarfarerLauncher  - Found display mode: 1366
x768, 60Hz, 32bpp
Logged

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2693
    • View Profile
    • Sc2Mafia
    • Email
Re: Can't Load Saves? Use 64-bit Java! (Instructions Inside)
« Reply #38 on: December 29, 2014, 07:48:07 PM »

That .bat file looks really bizarre.  Shouldn't it look something like this?

java -Djava.library.path=native\windows -Xms4g -Xmx6g -Dcom.fs.starfarer.settings.paths.logs=. -Dcom.fs.starfarer.settings.paths.saves=../saves -Dcom.fs.starfarer.settings.paths.screenshots=../screenshots -Dcom.fs.starfarer.settings.paths.mods=../mods -classpath janino.jar;commons-compiler.jar;commons-compiler-jdk.jar;starfarer.res.jar;starfarer.api.jar;starfarer_obf.jar;jogg-0.0.7.jar;jorbis-0.0.15.jar;json.jar;lwjgl.jar;lwjgl_util_applet.jar;jinput.jar;lwjgl_test.jar;log4j-1.2.9.jar;lwjgl_util.jar;fs.sound_obf.jar;fs.common_obf.jar;xstream-1.4.2.jar;"..\\mods\Version Checker\jars\lw_VersionChecker.jar" com.fs.starfarer.StarfarerLauncher
Logged

MooBoogie

  • Ensign
  • *
  • Posts: 6
    • View Profile
Re: Can't Load Saves? Use 64-bit Java! (Instructions Inside)
« Reply #39 on: December 29, 2014, 07:53:56 PM »

I'll reinstall it again and see how it looks
Logged

MooBoogie

  • Ensign
  • *
  • Posts: 6
    • View Profile
Re: Can't Load Saves? Use 64-bit Java! (Instructions Inside)
« Reply #40 on: December 29, 2014, 08:03:58 PM »

Here we are:

java -Djava.library.path=native\windows -Xms6g -Xmx8g -Dcom.fs.starfarer.settings.paths.logs=. -Dcom.fs.starfarer.settings.paths.saves=../saves -Dcom.fs.starfarer.settings.paths.screenshots=../screenshots -Dcom.fs.starfarer.settings.paths.mods=../mods -classpath janino.jar;commons-compiler.jar;commons-compiler-jdk.jar;starfarer.res.jar;starfarer.api.jar;starfarer_obf.jar;jogg-0.0.7.jar;jorbis-0.0.15.jar;json.jar;lwjgl.jar;lwjgl_util_applet.jar;jinput.jar;lwjgl_test.jar;log4j-1.2.9.jar;lwjgl_util.jar;fs.sound_obf.jar;fs.common_obf.jar;xstream-1.4.2.jar com.fs.starfarer.StarfarerLauncher
Logged

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2693
    • View Profile
    • Sc2Mafia
    • Email
Re: Can't Load Saves? Use 64-bit Java! (Instructions Inside)
« Reply #41 on: December 29, 2014, 08:54:14 PM »

As far as I know, that should work.  If not, try the alternative method that involves replacing the jre folder.
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 3275
  • Toss a coin to your Modder, O' valley of plenty
    • View Profile
Re: Can't Load Saves? Use 64-bit Java! (Instructions Inside)
« Reply #42 on: December 30, 2014, 12:46:09 AM »

Be sure to use Starsector 0.65.1a. The previous version had a bizarre .bat that created another mod folder inside the data folder, and the mods only showed if you placed them inside that one. Sound like it's what you are experiencing.
Logged
 

MooBoogie

  • Ensign
  • *
  • Posts: 6
    • View Profile
Re: Can't Load Saves? Use 64-bit Java! (Instructions Inside)
« Reply #43 on: December 30, 2014, 02:58:11 AM »

I redownloaded to make sure, and yes, it is Starsector 0.65.1a, but I couldn't find the extra mods folder in the data folder, and the mods still aren't showing when I put them in the original mods folder. A new bug maybe? I just downloaded the game a few days ago.
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 3275
  • Toss a coin to your Modder, O' valley of plenty
    • View Profile
Re: Can't Load Saves? Use 64-bit Java! (Instructions Inside)
« Reply #44 on: December 30, 2014, 03:33:38 AM »

That was only a bug in SS 0.65a. If you don't have those extra folders, then you are using the right version and I have no idea about what causes your game not to see the mods :-\
Maybe try to reinstall the game making sure you have the previous one completely removed?
Logged
 
Pages: 1 2 [3] 4 5 ... 28