Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 24 25 [26] 27 28 ... 57

Author Topic: [0.9.1a] Interstellar Imperium 2.4.0  (Read 589672 times)

Dal

  • Lieutenant
  • **
  • Posts: 57
    • View Profile
Re: [0.8a] Interstellar Imperium 1.16.0
« Reply #375 on: May 16, 2017, 04:27:00 PM »

I've narrowed down this startup hang to some conflict with Better Beginnings that doesn't occur with other faction mods. I have no leads on what that conflict is, unfortunately.

Unrelated, I just ran into this, though it's only occurred once and did not prevent a second try from succeeding.
Code
[117573 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
at com.fs.starfarer.api.impl.campaign.procgen.themes.SalvageSpecialAssigner$ShipRecoverySpecialCreator.createSpecial(SalvageSpecialAssigner.java:482)
at com.fs.starfarer.api.impl.campaign.procgen.themes.SalvageSpecialAssigner.assignSpecialForDebrisField(SalvageSpecialAssigner.java:133)
at data.scripts.world.imperium.II_Corsica.generate(II_Corsica.java:150)
at data.scripts.II_ModPluginAlt.initII(II_ModPluginAlt.java:20)
at data.scripts.IIModPlugin.onNewGame(IIModPlugin.java:345)
at com.fs.starfarer.campaign.save.CampaignGameManager.super(Unknown Source)
at com.fs.starfarer.title.TitleScreenState.dialogDismissed(Unknown Source)
at com.fs.starfarer.ui.while.dismiss(Unknown Source)
at com.fs.starfarer.ui.impl.J.dismiss(Unknown Source)
at com.fs.starfarer.campaign.save.if.actionPerformed(Unknown Source)
at com.fs.starfarer.ui.j.o00000(Unknown Source)
at com.fs.starfarer.ui.I.processInput(Unknown Source)
at com.fs.starfarer.ui.V.o00000(Unknown Source)
at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
at com.fs.state.AppDriver.begin(Unknown Source)
at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Logged

Orikson

  • Captain
  • ****
  • Posts: 280
  • Always Seen on Discord
    • View Profile
    • Email
Re: [0.8a] Interstellar Imperium 1.16.0
« Reply #376 on: May 16, 2017, 04:50:25 PM »

I've narrowed down this startup hang to some conflict with Better Beginnings that doesn't occur with other faction mods. I have no leads on what that conflict is, unfortunately.

Unrelated, I just ran into this, though it's only occurred once and did not prevent a second try from succeeding.
Code
[117573 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
at com.fs.starfarer.api.impl.campaign.procgen.themes.SalvageSpecialAssigner$ShipRecoverySpecialCreator.createSpecial(SalvageSpecialAssigner.java:482)
at com.fs.starfarer.api.impl.campaign.procgen.themes.SalvageSpecialAssigner.assignSpecialForDebrisField(SalvageSpecialAssigner.java:133)
at data.scripts.world.imperium.II_Corsica.generate(II_Corsica.java:150)
at data.scripts.II_ModPluginAlt.initII(II_ModPluginAlt.java:20)
at data.scripts.IIModPlugin.onNewGame(IIModPlugin.java:345)
at com.fs.starfarer.campaign.save.CampaignGameManager.super(Unknown Source)
at com.fs.starfarer.title.TitleScreenState.dialogDismissed(Unknown Source)
at com.fs.starfarer.ui.while.dismiss(Unknown Source)
at com.fs.starfarer.ui.impl.J.dismiss(Unknown Source)
at com.fs.starfarer.campaign.save.if.actionPerformed(Unknown Source)
at com.fs.starfarer.ui.j.o00000(Unknown Source)
at com.fs.starfarer.ui.I.processInput(Unknown Source)
at com.fs.starfarer.ui.V.o00000(Unknown Source)
at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
at com.fs.state.AppDriver.begin(Unknown Source)
at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

What's your base game version, jre version and list of mods?
Logged
"A story teller and a trader. Tell me your tales and I'll tell you no lies."

Come join the Starsector Fan Chat! It's decently active.

Link: https://discord.gg/eb5UC

grinningsphinx

  • Captain
  • ****
  • Posts: 282
    • View Profile
    • Email
Re: [0.8a] Interstellar Imperium 1.16.0
« Reply #377 on: May 17, 2017, 03:52:20 PM »

Getting a hang every time i launch the game with the mod ticked.  Nearly always at Jan 6 or 7.

Narrowed it down to II or TUP, and seems II is the culprit:(

I have no idea why you think II is the culprit from that log.  That looks like a completely normal log to me.


Well...when i have II installed, it hangs on Jan 2-6 every time, which is the fleet spawning mechanic.  The last 3 mods i installed were TUP, II, and the update for GSK....so i used process of elimination.


Logged

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2702
    • View Profile
    • Sc2Mafia
    • Email
Re: [0.8a] Interstellar Imperium 1.16.0
« Reply #378 on: May 17, 2017, 07:00:49 PM »

That log message is made AFTER the fleet is spawned.  It could still be some other mod.  Can you please list them?
Logged

grinningsphinx

  • Captain
  • ****
  • Posts: 282
    • View Profile
    • Email
Re: [0.8a] Interstellar Imperium 1.16.0
« Reply #379 on: May 17, 2017, 08:34:30 PM »

That log message is made AFTER the fleet is spawned.  It could still be some other mod.  Can you please list them?



Arsenal Expansion
audio plus
Betterbeginning 3
combat chatter
common radar
console commands
DK engineering
diable
GKsec
GRaphics lib
Lazy lib
Hegemony Expeditionary
Lightshow with SS+
Portrait pack
Rebalnced pilums
Shadowyards
SS+
TUP
Unknown Skies
UpgradedRotaryWeapons
Version Checker
Logged

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2702
    • View Profile
    • Sc2Mafia
    • Email
Re: [0.8a] Interstellar Imperium 1.16.0
« Reply #380 on: May 17, 2017, 09:22:17 PM »

Of those you listed, Tore Up Plenty, Green Knight Security, and possibly Arsenal Expansion are fairly unsafe.  There might be others.
Logged

Wyvern

  • Admiral
  • *****
  • Posts: 2931
    • View Profile
Re: [0.8a] Interstellar Imperium 1.16.0
« Reply #381 on: May 18, 2017, 09:10:09 AM »

So, I don't have conclusive proof, but recently I've had stuttering, delays, and even one outright crash while saving after a long play-session*, and when I started a new game with Interstellar Imperium disabled (and otherwise the same set of mods), I've had no such problems - yet, at least.

It's entirely possible that II isn't at fault here, but the evidence is suggestive of a memory leak somewhere.

For reference, the other mods I'm running with are: Dassault-Mikoyan Engineering, Shadowyards, Diable Avionics, Outer Rim Alliance, and of course graphicslib and lazylib.

* I ran a test for this: when saving a game was slow and made the music stutter (but didn't crash outright), I then restarted starsector, reloaded the same save, and hit the save copy button; that second save was fast and without stuttering.
Logged
Wyvern is 100% correct about the math.

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2702
    • View Profile
    • Sc2Mafia
    • Email
Re: [0.8a] Interstellar Imperium 1.16.0
« Reply #382 on: May 18, 2017, 09:58:12 AM »

Then I will just stop updating the mod and let it die.  I don't have the 50+ hours it would take to track down a memory leak bug that only happens after playing normally for many hours.
Logged

Deshara

  • Admiral
  • *****
  • Posts: 1539
  • Suggestion Writer
    • View Profile
    • Email
Re: [0.8a] Interstellar Imperium 1.16.0
« Reply #383 on: May 18, 2017, 10:06:52 AM »

I was about to update II into my game, will test for conflicts
Logged
Quote from: Deshara
I cant be blamed for what I said 5 minutes ago. I was a different person back then

Bash

  • Ensign
  • *
  • Posts: 20
    • View Profile
Re: [0.8a] Interstellar Imperium 1.16.0
« Reply #384 on: May 18, 2017, 10:37:45 AM »

don't let the Imperium just die dude Oo they're my favorite
Logged

Wyvern

  • Admiral
  • *****
  • Posts: 2931
    • View Profile
Re: [0.8a] Interstellar Imperium 1.16.0
« Reply #385 on: May 18, 2017, 11:04:28 AM »

Then I will just stop updating the mod and let it die.  I don't have the 50+ hours it would take to track down a memory leak bug that only happens after playing normally for many hours.
Well, I guess that gives me a bit more reason to try and track this down myself.  Hm.  Well, worst case I can get a 15-day trial license for yourkit; I've used that at work and it makes tracking memory problems pretty straightforward.
Logged
Wyvern is 100% correct about the math.

McTrigger

  • Ensign
  • *
  • Posts: 20
    • View Profile
    • Email
Re: [0.8a] Interstellar Imperium 1.16.0
« Reply #386 on: May 18, 2017, 11:50:38 AM »

Then I will just stop updating the mod and let it die.  I don't have the 50+ hours it would take to track down a memory leak bug that only happens after playing normally for many hours.

Please no  :(

This has become my favorite faction mod.
Logged

ahrenjb

  • Commander
  • ***
  • Posts: 225
    • View Profile
Re: [0.8a] Interstellar Imperium 1.16.0
« Reply #387 on: May 18, 2017, 02:15:58 PM »

I've been playing with II since DR pushed the 0.8a update out, and I haven't had any issues.

I'm running a pretty good list of mods, but only the well maintained, good quality ones from established mod makers. I've had no crashed, slow downs, or issues.

I guess it needs to be said, thanks Dark.Revenant for your work! Love having II around, whether I'm running their ships in my fleet or clashing with them in orbit.
Logged

Phearlock

  • Ensign
  • *
  • Posts: 49
    • View Profile
Re: [0.8a] Interstellar Imperium 1.16.0
« Reply #388 on: May 18, 2017, 02:22:23 PM »

Can unhelpfully report that I haven't had any issues with this II version so far. Running 64bit Win 10 JRE 1.8.0_77 (8 gigs allocated to SS, fairly regular 5+ hour sessions)

Mod list:
Arsenal Expansion
Audio plus
Autosave
Betterbeginnings_v0.3
Combat Chatter
DME
DA
DissassemableReassemble_v0.3
Graphicslib
Hedgemony Expeditionary Auxiliary
II
Lazylib
Lightshow
Neutrino
ORA
SRA
Templars
Unknownskies
Logged

Dal

  • Lieutenant
  • **
  • Posts: 57
    • View Profile
Re: [0.8a] Interstellar Imperium 1.16.0
« Reply #389 on: May 18, 2017, 04:16:10 PM »

Grinningsphinx: The hang I was referring to in my post is the same one you're experiencing. Try disabling better beginnings. I'm not sure why it conflicts with II and nothing else, but apparently it does.
Logged
Pages: 1 ... 24 25 [26] 27 28 ... 57