Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 11 12 [13] 14 15

Author Topic: [0.95a] The P9 Colony Group - Faction mod (v0.53), Nexerelin Compatible again!  (Read 138735 times)

ThePinkPanzer

  • Commander
  • ***
  • Posts: 121
  • Professional accidentaly rude person
    • View Profile
    • Email

If you need a flag done I do graphic design, could help you out gladly.
Logged

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email

Did you ever find it an issue that the sks small mount cannon was on average extremely huge compared to most small mounts? Perhaps reducing the size by a margin of 25% would work better as I can't tell the difference in size from the sks to medium weapons. it just seems awkward on ships with many small mounts, they start overlapping, unfortunately. Maybe equalizing sizes by 25% across the board for the cannon series of weapons.
Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.

Alkin

  • Ensign
  • *
  • Posts: 9
    • View Profile

Was browsing the Colonies tab and was looking at structures and then this happened, not sure if it is this mod particularly but says pn.nexus and the mod is called "pn" when extracted
Logged

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email

Was browsing the Colonies tab and was looking at structures and then this happened, not sure if it is this mod particularly but says pn.nexus and the mod is called "pn" when extracted

Are you on the latest version? He previously removed the nexus but the update might not be save compatible in your case.
Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.

Alkin

  • Ensign
  • *
  • Posts: 9
    • View Profile

Was browsing the Colonies tab and was looking at structures and then this happened, not sure if it is this mod particularly but says pn.nexus and the mod is called "pn" when extracted

Are you on the latest version? He previously removed the nexus but the update might not be save compatible in your case.

Yes, updated today, on the RC-15 on 95a
Logged

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email

Was browsing the Colonies tab and was looking at structures and then this happened, not sure if it is this mod particularly but says pn.nexus and the mod is called "pn" when extracted

Are you on the latest version? He previously removed the nexus but the update might not be save compatible in your case.

Yes, updated today, on the RC-15 on 95a

If you did so today and the issue has arisen I'm going to bet my life on the fact that it's because your on a save that had the previous version on it.
Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.

Alkin

  • Ensign
  • *
  • Posts: 9
    • View Profile

Was browsing the Colonies tab and was looking at structures and then this happened, not sure if it is this mod particularly but says pn.nexus and the mod is called "pn" when extracted

Are you on the latest version? He previously removed the nexus but the update might not be save compatible in your case.

Yes, updated today, on the RC-15 on 95a

If you did so today and the issue has arisen I'm going to bet my life on the fact that it's because your on a save that had the previous version on it.

Nope, new save, just made another one without the mod and scrolling and no crash
Logged

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email

Was browsing the Colonies tab and was looking at structures and then this happened, not sure if it is this mod particularly but says pn.nexus and the mod is called "pn" when extracted

Are you on the latest version? He previously removed the nexus but the update might not be save compatible in your case.

Yes, updated today, on the RC-15 on 95a

If you did so today and the issue has arisen I'm going to bet my life on the fact that it's because your on a save that had the previous version on it.

Nope, new save, just made another one without the mod and scrolling and no crash

Then unfortunately this is beyond my knowledge of starsector mod troubleshooting, had this been kenshi this would have been a different story. My apologies, Zudgemud should be able to help you with that since he knows the internals about his mod. But as far as I go the mod works on 0.91a perfectly fine, I can't replicate the issue.
Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.

Zudgemud

  • Commander
  • ***
  • Posts: 216
    • View Profile

Was browsing the Colonies tab and was looking at structures and then this happened, not sure if it is this mod particularly but says pn.nexus and the mod is called "pn" when extracted
Nope, new save, just made another one without the mod and scrolling and no crash

That is very strange seeing as I deleted the nexus and all references to it. Are you sure you installed the latest 0.52a version of the mod by first deleting the old folder? If you didn't delete the old folder first and simply replaced all the contents then the pn\data\campaign folder will still contain the .csv file "industries" which refers to a non existant nexus, which will crash the game. I cant replicate your error without doing the update by "replace all contents" type of update, which is not recommended for any mod I think. I'll put a clarification of this in the OP.
Logged

Shuka

  • Lieutenant
  • **
  • Posts: 58
    • View Profile
    • Email

Was browsing the Colonies tab and was looking at structures and then this happened, not sure if it is this mod particularly but says pn.nexus and the mod is called "pn" when extracted

That is very strange seeing as I deleted the nexus and all references to it. Are you sure you installed the latest 0.52a version of the mod by first deleting the old folder? If you didn't delete the old folder first and simply replaced all the contents then the pn\data\campaign folder will still contain the .csv file "industries" which refers to a non existant nexus, which will crash the game. I cant replicate your error without doing the update by "replace all contents" type of update, which is not recommended for any mod I think. I'll put a clarification of this in the OP.

I had the same issue, deleting the old folder and installing the latest version of P9 fixed it. Cheers and thanks for the mod.
Logged

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email

started using the P9 EX Burst Cannon and I got this after I crashed in the log

319352 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
   at com.fs.starfarer.combat.entities.ship.A.if.startedChargeup(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.trackers.new.o00000(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.trackers.O0OO.o00000(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.trackers.O0OO.o00000(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.trackers.new.Ô00000(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.A.if.advance(Unknown Source)
   at com.fs.starfarer.combat.systems.oOoO.advanceLinked(Unknown Source)
   at com.fs.starfarer.combat.systems.oOoO.advance(Unknown Source)
   at com.fs.starfarer.combat.entities.Ship.fire(Unknown Source)
   at com.fs.starfarer.combat.entities.Ship.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advanceInner(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

The gun doesn't even fire anything before it crashes.

Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.

Zudgemud

  • Commander
  • ***
  • Posts: 216
    • View Profile

started using the P9 EX Burst Cannon and I got this after I crashed in the log

319352 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
   at com.fs.starfarer.combat.entities.ship.A.if.startedChargeup(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.trackers.new.o00000(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.trackers.O0OO.o00000(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.trackers.O0OO.o00000(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.trackers.new.Ô00000(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.A.if.advance(Unknown Source)
   at com.fs.starfarer.combat.systems.oOoO.advanceLinked(Unknown Source)
   at com.fs.starfarer.combat.systems.oOoO.advance(Unknown Source)
   at com.fs.starfarer.combat.entities.Ship.fire(Unknown Source)
   at com.fs.starfarer.combat.entities.Ship.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advanceInner(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

The gun doesn't even fire anything before it crashes.

I'm not able to replicate this error with or without the 7 mods that I have. What mods do you run and which ship did you fit the gun to? It might be incompatible with some hull specific mod or ship system or something. Alternatively some mod specific skill? And does it still occur if you reinstall the mod? I think I have tried all relevant skills in vanilla and that didn't generate a crash, unless it it some specific mix of skills.
Logged

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email

it's odd I'm assuming this is unique to 0.91a so what I did was just delete the burst cannon completely from the mod and redid all references to it including ship variants and now it's working albeit no longer having that weapon. weird?
Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.

Mr_8000

  • Ensign
  • *
  • Posts: 43
    • View Profile

(this was played on 0.95a)

I've had this mod for a bit now, and while I'm not much of a balance guy, I will drop a list of potential issues/oversights I noticed.

First off, multiple missing descriptions:
Spoiler

Ship system:
[close]
I've probably missed a few so it might be a good idea to check each one

The faction has a crest, but no logo, and it looks weird in the intel feed (also why is it called Dr? nothing in their name can be shortened to that)
Spoiler
[close]

You've got missing columns in the shipsystem csv, when a custom phase cloak lacks "isPhaseCloak" set to true, it fails to benefit from the ship skill. In the same vein, when your phase ships lack the "PHASE" hint (in the shipdata csv), they fail to benefit from fleetwide phase skills.

The faction weapons lack a tech/manufacturer and as such get lumped in and lost in the "common" type weapon tab.

This ship has a shield upkeep of 0.9, meaning that when your shield is up you only have 150 effective flux for your weapons, if you don't install stabilized shields (which the ai often doesn't) (might be intended, but might as well point it out)
Spoiler
[close]

The Samaa-DSI class appears to be built around its main beam, and as such has very few mounts. However said beam is terrible compared to the tachyon lance. On top of the mediocre (damage) stats, the long burst duration and kinetic typing mean it's effectively useless against armor (which is probably the intent, but it's also poor against shields due to low dps, and despite being terribly inefficient it still doesn't use the majority of the ship's flux). I can't tell if it arcs like the tachyon, but any additional text alluding to such functionality is missing ... oh and the entire description is missing.
Spoiler

Tach lance for reference
[close]

Overall, I like the sprites and their glass cannon/low flux capacity approach to combat, but what they really need is some polish.

EDIT:
While looking around some more I've noticed that
- the Samaa-DSI has strangely low ppt for its class at only 450
- this destroyer has infinite ppt
Spoiler
[close]
« Last Edit: May 16, 2021, 12:24:03 PM by Mr_8000 »
Logged

Brightness

  • Ensign
  • *
  • Posts: 15
    • View Profile

It's almost got a giger-esque feel to them. I love it!
Logged
Pages: 1 ... 11 12 [13] 14 15