Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.97a is out! (02/02/24); New blog post: Planet Search Overhaul (07/13/24)

Author Topic: Help from Devteam  (Read 1207 times)

kiwimatsch

  • Ensign
  • *
  • Posts: 3
    • View Profile
Help from Devteam
« on: January 06, 2023, 05:12:33 AM »

Dear Devs <3

i saw a youtube video of your awesome game, it was in german language,

after i was buy it i saw its only english, now i download this only one german gametranslation, BUT this mod i cant use because the game have a other game version

can u devs maybe ake the existing MOD (german translation) make it working for the newest gameversion? m

maybe it is not that hard, i dont know

the maker of this mod dosnt response sadly

regards
kiwi
Logged

Fenrir

  • Captain
  • ****
  • Posts: 252
    • View Profile
Re: Help from Devteam
« Reply #1 on: January 06, 2023, 07:17:35 AM »

Well, it might work directly if the game version wasn't too far apart, between 0.95 and 0.95.1 for example, just ignore the warning in that case.
The other way, you might need more luck. You can manually change the required version of your mod in the mod_info.json file of your mod via any software supporting UTF-8 code. This MIGHT make your mod work, but most likely not achieve full translation, if it works at all, and cause unexpected issues.
You can also download an older version of game that fits your mod in the forum, try find it in Announcements.

Übersetzung von bot
Nun, es könnte direkt funktionieren, wenn die Spielversion nicht zu weit auseinander liegt, z. B. zwischen 0.95 und 0.95.1, ignorieren Sie in diesem Fall einfach die Warnung.
Umgekehrt brauchen Sie vielleicht mehr Glück. Sie können die erforderliche Version Ihres Mods in der Datei mod_info.json Ihres Mods über jede Software, die UTF-8-Code unterstützt, manuell ändern. Dies KANN dazu führen, dass Ihr Mod funktioniert, aber höchstwahrscheinlich keine vollständige Übersetzung erreicht, wenn es überhaupt funktioniert, und unerwartete Probleme verursachen.
Sie können auch eine ältere Version des Spiels herunterladen, die zu Ihrem Mod im Forum passt, versuchen Sie, sie in den Ankündigungen zu finden.
Logged
*cough* try tossing the PK into a black hole *cough*

kiwimatsch

  • Ensign
  • *
  • Posts: 3
    • View Profile
Re: Help from Devteam
« Reply #2 on: January 06, 2023, 11:51:27 AM »

thx for reply :D

i change it to that newest version but while game start it give alot error messages and game wont load

:,(

then i have to wait, maybe someone will make a translation mod with google translator , that will be enought for me, my english realy suxx at all
but i love that game for real
Logged

Mortrag

  • Commander
  • ***
  • Posts: 230
    • View Profile
Re: Help from Devteam
« Reply #3 on: January 06, 2023, 04:36:16 PM »

English:
What mod exactly are you talking about, kiwimatsch?
If it's such a problem for you maybe I have a look at it.

Deutsch:
Welche Mod meinst du genau? (Name + wo hast du sie gefunden/geladen?)
Ich habe zwar bisher keine Erfahrung mit dem Modden, aber ne reine Übersetzung klingt in der Theorie nicht so schwer. Ich würde jedenfalls mal drüber schauen und dann hier noch was dazu schreiben.
Logged

kiwimatsch

  • Ensign
  • *
  • Posts: 3
    • View Profile
Re: Help from Devteam
« Reply #4 on: January 07, 2023, 12:10:55 AM »

HI, thx so much for trying to help out!

here is the mod : https://fractalsoftworks.com/forum/index.php?topic=19363.0
Logged

Schwartz

  • Admiral
  • *****
  • Posts: 1453
    • View Profile
Re: Help from Devteam
« Reply #5 on: January 07, 2023, 02:18:21 AM »

Es kommt halt mit jeder Version einiges an Text dazu. Für die aktuelle Version wird das wohl eher schlecht funktionieren, selbst wenn man die Mod zum laufen bringt. Der Modmacher sagte ja selbst, dass die Mod auch für 0.9.1 nicht als Final angesehen werden kann.

Ich würde die Mod entfernen und auf Englisch spielen, bis sich jemand des Themas annimmt. Wir haben hier ein paar deutsche Modder, aber eine Übersetzung ist halt reine Fleißarbeit und Mods entstehen meistens weil derjenige auch Bock drauf hat. Wenn Mortrag es macht wäre das natürlich cool.
Logged

Mortrag

  • Commander
  • ***
  • Posts: 230
    • View Profile
Re: Help from Devteam
« Reply #6 on: January 10, 2023, 06:51:47 PM »

Quick status-report in german:

Also, ich habe mir die Mod mal angeschaut und zumindest die Problemursache auf zwei Dateien eingegrenzt. Diese wären:
- special_items in data\campaign, und
- hull_mods in data\hullmods

Die Notlösung also lautet, diese beiden Dateien zu löschen und die "gameVersion" in der mod_info umzuschreiben und dann läuft der Rest der Mod.

Ich habe auch versucht die beiden Dateien zu korrigieren, allerdings kommt, sobald ich nur irgendwas in einer Datei verändere und die Änderung speicher, beim Start von Starsector eine neue Fehlermeldung. Da ich noch nie gemoddet habe, muss ich mich da erst reinfuchsen und habe keine Ahnung, wie lange das dauert.

Edit:
Dank ModdedLaharl und HowlerXIII (keine Ahnung unter welchem Namen er im Forum hier unterwegs ist) ist das Problem mit dem Speichern bereits gelöst. Jetzt fehlt halt noch die eigentliche Bearbeitung der Dateien: special_items ist noch relativ übersichtlich und dürfte zügig zu fixen sein, hull_mods hat leider die ca. 6fache Zeilenzahl und wird entsprechend länger dauern.

Edit 2: special_items ist gefixt.
« Last Edit: January 10, 2023, 09:18:09 PM by Mortrag »
Logged

Mortrag

  • Commander
  • ***
  • Posts: 230
    • View Profile
Re: Help from Devteam
« Reply #7 on: January 10, 2023, 10:57:07 PM »

Die hull_mods-Datei ging deutlich schneller als gedacht, das Ergebnis findet ihr nun hier: SideshowDogs German Translation -gefixt-
Logged