Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  


Starsector 0.97a is out! (02/02/24); New blog post: New music for Galatia Academy (06/12/24)

Author Topic: SOLVED Null pointer CTD on launch  (Read 207 times)


  • Ensign
  • *
  • Posts: 2
    • View Profile
SOLVED Null pointer CTD on launch
« on: December 27, 2022, 06:49:06 AM »

Edit: Realized I'd installed the old version of yunrucore, updating it fixed this.

Did a new install on a laptop and added mods I've used together without CTD's in the past. Crash log and modlist below:

37828 [Thread-3] WARN  com.fs.starfarer.loading.ShipHullSpreadsheetLoader  - Ship hull [yunru_nyx] from ship_data.csv not found in store
37875 [Thread-3] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
at com.fs.starfarer.loading.ShipHullSpecLoader.o00000(Unknown Source)   at com.fs.starfarer.loading.ShipHullSpreadsheetLoader.super(Unknown Source)
   at com.fs.starfarer.loading.SpecStore.public(Unknown Source)
   at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$ Source)

 "enabledMods": [
    "Diktat Enhancement",
    "Angry Periphery",
    "Everybody loves KoC",
« Last Edit: December 27, 2022, 07:02:05 AM by Afrolicious »