Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Crash during battle.  (Read 103 times)

al00195

  • Ensign
  • *
  • Posts: 15
    • View Profile
Crash during battle.
« on: October 11, 2021, 11:03:28 AM »

Hello,
During a battle, any ship firing with a phase lance will crash the game. It's probably a problem with a mod but the facts that it's a vanilla weapon that causes the crash give me no clue about which one is implied.

Here is the error in the log :

Spoiler
520439 [Thread-7] INFO  sound.oo0O  - Cleaning up music with id [faction_generic_market_01_neutral_var01.ogg]
520750 [Thread-9] INFO  sound.oo0O  - Creating streaming player for music with id [BFG3.ogg]
520752 [Thread-9] INFO  sound.OooO  - Playing music with id [BFG3.ogg]
523756 [Thread-3] INFO  org.histidine.chatter.combat.ChatterCombatPlugin  - Adding ship Nephi-Prizon, isEnemy 0
523757 [Thread-3] INFO  org.histidine.chatter.combat.ChatterCombatPlugin  - Adding ship HSS Mephitis, isEnemy 0
523757 [Thread-3] INFO  org.histidine.chatter.combat.ChatterCombatPlugin  - Adding ship Sword of Retribution, isEnemy 0
544328 [Thread-3] INFO  sound.oo0O  - Cleaning up music with id [miscallenous_corvus_campaign_music.ogg]
544331 [Thread-7] INFO  sound.oo0O  - Cleaning up music with id [BFG3.ogg]
544607 [Thread-3] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
   at com.fs.starfarer.combat.entities.ship.A.G.this.super(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.A.G.createBeam(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.trackers.E.super(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.trackers.O0OO.super(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.trackers.O0OO.super(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.trackers.E.super(Unknown Source)
   at com.fs.starfarer.combat.entities.ship.A.G.advance(Unknown Source)
   at com.fs.starfarer.combat.systems.G.o00000(Unknown Source)
   at com.fs.starfarer.combat.systems.G.advance(Unknown Source)
   at com.fs.starfarer.combat.entities.Ship.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advanceInner(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
544778 [Thread-9] INFO  sound.oo0O  - Creating streaming player for music with id [DawII1.ogg]
544781 [Thread-9] INFO  sound.OooO  - Playing music with id [DawII1.ogg]
[close]

I play with these mods :

Spoiler
  "$$$_lightshow",
  "pantera_ANewLevel20",
  "anotherportraitpack",
  "raccoonarms",
  "bsgportraitspack",
  "beyondthesector",
  "BSC",
  "CWSP",
  "CSP",
  "chatter",
  "lw_console",
  "diableavionics",
  "dronelib",
  "exshippack",
  "fluffships",
  "sun_fuel_siphoning",
  "hte",
  "ImperialNavy",
  "IndEvo",
  "interestingportraitspack",
  "kadur_remnant",
  "kingdomofterra",
  "LTA",
  "lw_lazylib",
  "ArkLeg",
  "MagicLib",
  "missingships",
  "more_hullmods",
  "nexerelin",
  "pn",
  "wyv_planetaryShieldAccessControl",
  "PulseIndustry",
  "rotcesrats",
  "sanguinary_autonomist_defectors",
  "tahlan_scalartech",
  "SEEKER",
  "speedUp",
  "superweapons",
  "timid_supply_forging",
  "tahlan",
  "Terraforming and Station Construction",
  "exalted",
  "star_federation",
  "transfer_all_items",
  "US",
  "URW",
  "vic",
  "vayrashippack",
  "whichmod",
  "audio_plus",
  "astroidships",
  "shaderLib"
[close]

I don't know if it is correlated but I play the game with java 7 since the game won't launch with java 8 and a vmparams modified. (Sorry if there are mistakes, English is not my native language)

Logged

al00195

  • Ensign
  • *
  • Posts: 15
    • View Profile
Re: Crash during battle.
« Reply #1 on: October 14, 2021, 01:52:48 PM »

Problem solved, I forgot to update a mod that I have modified (audio+ here).
Logged