Fractal Softworks Forum

Please login or register.

Login with username, password and session length

Author Topic: [CTD after loading and unpausing] - stats with the same source [battle_mod_flat]  (Read 92 times)

Hiroyan495

  • Lieutenant
  • **
  • Posts: 61
    • View Profile

Crash happens exactly after unpausing a loaded save file's running game.

Spoiler
"java.lang.RuntimeException: Attempting to modify multiple stats with the same source [battle_mod_flat]
    at com.fs.starfarer.campaign.fleet.MutableFleetStats.getMod(Unknown Source)
    at com.fs.starfarer.campaign.fleet.MutableFleetStats.addTemporaryModFlat(Unknown Source)
    at com.fs.starfarer.campaign.fleet.Battle.applyVisibilityMod(Unknown Source)
    at com.fs.starfarer.campaign.fleet.Battle.advance(Unknown Source)
    at com.fs.starfarer.campaign.BaseLocation.advanceEvenIfPaused(Unknown Source)
    at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
    at com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
    at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
    at com.fs.state.AppDriver.begin(Unknown Source)
    at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
    at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
    at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)"
[close]

Modlist (including Scarlet Devils and Space Jihad Modifications, which are my own mods and which I suspect might be the cause):

https://cdn.discordapp.com/attachments/619635013201428481/873565174991290418/unknown.png

Spoiler
{"enabledMods": [
  "anotherportraitpack",
  "arbuzwork",
  "ARC",
  "armaa",
  "astroidships",
  "BSC",
  "HMI_brighton",
  "clearCommands",
  "lw_console",
  "diableavionics",
  "XLU",
  "HHE",
  "FPE",
  "fluffships",
  "GrandColonies",
  "HMI",
  "HMI_SV",
  "IndEvo",
  "interestingportraitspack",
  "internalaffairs",
  "kadur_remnant",
  "kazeron",
  "keruvim_shipyards",
  "kingdomofterra",
  "lw_lazylib",
  "ArkLeg",
  "LTA",
  "luddenhance",
  "mag_protect",
  "mag_protect_soldier",
  "MagicLib",
  "Mayasuran Navy",
  "memeportraits",
  "missingships",
  "su_CarrierHullmod",
  "more_hullmods",
  "nexerelin",
  "kayse_phaseships",
  "OcuA",
  "ORA",
  "paraqueeght",
  "wisp_perseanchronicles",
  "prv",
  "PulseIndustry",
  "rotcesrats",
  "roider",
  "sanguinary_autonomist_defectors",
  "tahlan_scalartech",
  "scarlet_devils",
  "SCY",
  "shadow_ships",
  "space_jihad_modifications",
  "superweapons",
  "surveycorpssp",
  "tahlan",
  "Terraforming and Station Construction",
  "exalted",
  "star_federation",
  "TORCHSHIPS",
  "underworld",
  "US",
  "UGH",
  "vayrashippack",
  "vic",
  "shaderLib"
]}
[close]

Did some testing. Good news for me personally, is that my mod (hullmods that alter various ship stats etc.) is not the likely cause of this particular crash. Bad news is, I still don't known what the cause is.

Method: Since my game crashed earlier, when I tried to load a save (after I had rebooted the game), I attempted to recreate the bug with a fresh save. To do so, I made a new character, saved, went back to the main menu and loaded the save again. No crash, even after a minute of travelling through space, so completely unlike earlier. Then I did the same with a complete game reboot inbetween. Still, no issue.

It seems the crash is caused by something that happens throughout the game.
« Last Edit: August 07, 2021, 09:05:18 AM by Hiroyan495 »
Logged