Fractal Softworks Forum

Please login or register.

Login with username, password and session length

Author Topic: Game CTD  (Read 170 times)


  • Ensign
  • *
  • Posts: 5
    • View Profile
Game CTD
« on: July 22, 2021, 10:12:25 AM »

My game crashed when i tried to make a new game, more specifically it crashed when generating the sector.

Here's the error in the log

1067877 [Thread-3] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
   at com.fs.starfarer.campaign.CharacterStats.refreshCharacterStatsEffects(Unknown Source)
   at com.fs.starfarer.api.impl.campaign.fleets.FleetFactoryV3.addCommanderSkills(
   at com.fs.starfarer.api.impl.campaign.fleets.FleetFactoryV3.addCommanderAndOfficer sV2(
   at com.fs.starfarer.api.impl.campaign.fleets.FleetFactoryV3.addCommanderAndOfficer s(
   at com.fs.starfarer.api.impl.campaign.fleets.FleetFactoryV3.createFleet(
   at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
   at Source)
   at com.fs.starfarer.title.TitleScreenState.dialogDismissed(Unknown Source)
   at com.fs.starfarer.ui.Oo0O.dismiss(Unknown Source)
   at com.fs.starfarer.ui.impl.o0oO.dismiss(Unknown Source)
   at Source)
   at com.fs.starfarer.ui.newnew.buttonPressed(Unknown Source)
   at com.fs.starfarer.ui.I.Ò00000(Unknown Source)
   at com.fs.starfarer.ui.I.processInput(Unknown Source)
   at com.fs.starfarer.ui.Stringsuper.super(Unknown Source)
   at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$ Source)
   at Source)

And my modlist:

{"enabledMods": [
  "Adjusted Sector",
  "Mayasuran Navy",
  "Terraforming and Station Construction",

More context:

Just updated Starsector, i had been waiting a while for the mods that i normally use to be updated to the new version, i uninstalled the game and reinstalled from a fresh installer (because i wanted to make sure nothing wrong happens since i always seem to mess up something when related to modding/updating games), after the game was isntalled i extracted the mods into the mod folder and booted the game, then when i was making a new game the game crashed in the sector generation part.
Any help is much appreciated, thanks.


  • Admiral
  • *****
  • Posts: 3434
    • View Profile
    • Bitbucket profile
    • Email
Re: Game CTD
« Reply #1 on: July 23, 2021, 06:33:34 PM »

This looks like a mod faction with an invalid admiral skill specified, but can't tell which one from the log.

Most of the mods should be fine; try disabling the ones that aren't highly popular (per forum thread replies or something) to narrow it down.

EDIT: Actually, any mod with any sort of public user base whatsoever should have this issue detected already. Check if all your mods are up to date using the Mod Manager.
« Last Edit: July 23, 2021, 06:37:30 PM by Histidine »


  • Ensign
  • *
  • Posts: 5
    • View Profile
Re: Game CTD
« Reply #2 on: July 24, 2021, 08:18:24 AM »

Actually, i have simply no idea why or how but i just kept trying and the errors simply went away by themselves lmao.
Like, after this happened, i tried to start a new game again and the sector generation worked so that error went away, but as soon as the game started it crashed and gave me another error, i restarted starsector and tried a new game and sector generation worked and the game didnt crash after starting, it was pretty weird but i found it funny, the errors simply fixed themselves without me doing anything.  ;D