Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: Skill Changes, Part 2 (07/15/21)

Author Topic: Fleet quality won't improve  (Read 149 times)

Yunru

  • Admiral
  • *****
  • Posts: 854
    • View Profile
Fleet quality won't improve
« on: June 06, 2021, 02:55:57 AM »

So brief rundown of mods I'm running:
  "adjustable_skill_thresholds",
  "Adjusted Sector",
  "anotherportraitpack",
  "lw_console",
  "exploration",
  "GrandColonies",
  "IndEvo",
  "interestingportraitspack",
  "lw_lazylib",
  "leadingPip",
  "low_maintenance",
  "MagicLib",
  "yunru_midline_expansion",
  "moreflags",
  "yunru_pirate_collection",
  "Terraforming and Station Construction",
  "trulyautomatedships",
  "unpackblueprints"

Now for the issue I'm experiencing:
Regardless of fleet doctrine, or the fact that I've an Orbital Works with a Pristine Nanoforge, my faction's fleets are stuck at the lowest quality and maximum chance of d-mods (I believe, I don't know if it's shown, but it's what's predicted and seen in patrol fleets):
Spoiler
[close]

Arcalane

  • Lieutenant
  • **
  • Posts: 85
    • View Profile
    • Email
Re: Fleet quality won't improve
« Reply #1 on: June 06, 2021, 05:42:46 AM »

Check the colony screen; it should show a breakdown of everything affecting fleet size & quality if you hover over the relevant % at the top, next to Defenses.

My guess is your orbital works are experiencing a supply shortage, but that ought to be obvious from the colony screen... ??? Would need to see the colony screen itself to be sure.
Logged

Yunru

  • Admiral
  • *****
  • Posts: 854
    • View Profile
Re: Fleet quality won't improve
« Reply #2 on: June 06, 2021, 06:46:23 AM »

I wish I could tell you what the cause was. Loaded the save back up, having gotten back from lunch, and now it does it correctly.

(Only other change was I updated IndEvo from D to F.)

xescape

  • Ensign
  • *
  • Posts: 8
    • View Profile
Re: Fleet quality won't improve
« Reply #3 on: June 06, 2021, 07:18:03 AM »

I had the same problem, and fixed by updating industrial evolution.

It basically didn't think my heavy industry existed and has the cross faction penalty as well as no bonuses from nanoforge.
Logged

Arcalane

  • Lieutenant
  • **
  • Posts: 85
    • View Profile
    • Email
Re: Fleet quality won't improve
« Reply #4 on: June 06, 2021, 12:01:23 PM »

Weird. ??? Maybe there was some niche/edge-case bug in IndEvo, or simply reloading the save forced it to recalculate the assorted supply chains and they updated correctly.
Logged