Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: Skill Changes, Part 2 (07/15/21)

Author Topic: Continuous game crash at the same date "n must be positive" [SOLVED]  (Read 117 times)

Amberbeads

  • Ensign
  • *
  • Posts: 1
    • View Profile

Hi everyone,

This is my first post on this forum so apologies if i made any errors.
As the subject suggests my game crashes continuously at the end of June 30 cycle 219 with the following error in the starsector.log file:

Code
122470 [Thread-3] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.IllegalArgumentException: n must be positive
java.lang.IllegalArgumentException: n must be positive
at java.util.Random.nextInt(Unknown Source)
at com.fs.starfarer.api.impl.campaign.econ.impl.IndEvo_dryDock.removeDMods(IndEvo_dryDock.java:193)
at com.fs.starfarer.api.impl.campaign.econ.impl.IndEvo_dryDock.reportEconomyTick(IndEvo_dryDock.java:103)
at com.fs.starfarer.api.campaign.listeners.ListenerUtil.reportEconomyTick(ListenerUtil.java:100)
at com.fs.starfarer.campaign.econ.reach.ReachEconomyStepper.doEndOfStepStuff(Unknown Source)
at com.fs.starfarer.campaign.econ.reach.ReachEconomyStepper.nextFrame(Unknown Source)
at com.fs.starfarer.campaign.econ.Economy.advance(Unknown Source)
at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
at com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
at com.fs.state.AppDriver.begin(Unknown Source)
at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

The mods i have activated are the following:
-Lightshow 1.41
-Trailer Moments 1.2
-A new level of confidence 1.1
-Adjustable skill thresholds 1.0.0
-Arsenal expansion 1.5.4a
-Beyond the sector 1.0.0
-Diable Avionics
-High Tech expansion 1.4.3
-Industrial evolution 2.2.b
-LazyLib 2.6
-Luddic enhancement 1.2.4d
-MagicLib 0.34
-Nexerelin 0.10.1
-Outer Rim Alliance 0.93rc3
-Scalar Tech solutions 0.7 (was added later in the playthrough)
-Scy Nation 1.64
-Seeker-unidentified contact 0.42
-Stellar Networks 1.0.1
-Tahlan Shipworks 0.6
-Torchships and deadly armaments 0.16rc2
-Underworld 1.6.1
-Unknown Skies 0.43
-GraphicsLib 1.5.1

Its quite the large modlist, so it was bound to cause problems eventually i guess  ;D
but its a rather odd way to crash and i myself cant really think of what mod would cause a crash like that on the same exact date every time,
so any help is greatly appreciated!
Ive attempted to avoid the crash by changing my position during the crash date and making sure none of my colonies or agents were performing anything, however the crash still happened.
I have also tried following the file path the crash log gives me but im not good at code and so that idea did not get me very far either.

The issue has now been solved! The crash was caused by a restoration dock from industrial evolution trying to repair D-mods despite having no ships in its storage. Shutting down the structure prevented the crash.
« Last Edit: May 29, 2021, 01:40:02 AM by Amberbeads »
Logged