Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: Skill Changes, Part 2 (07/15/21)

Author Topic: Low FPS after battles during campaign  (Read 168 times)

Mytre

  • Ensign
  • *
  • Posts: 31
  • So i see you read this
    • View Profile
    • Email
Low FPS after battles during campaign
« on: May 27, 2021, 08:24:28 PM »

Hello, so I have a lot of mods, and I also went and allowed around 700 battle size and stuff. Usually I play with good FPS on campaing travelling around, however after a while or after a massiva battle (lets say after a hit fleet gets to me ) my fps on campaign drop to low 20s or lower. My specs are gtx 1070, 32gb ram, ryzen 3600x.  I gave starsector 8GB of ram.  Now when this happens with low FPS aafter a big battle all I do is just save , exit and close starsector, reopen it and load my save game and FPS are back to normal.

Is there a way to fix this? or is it a limitation of Java ?
Logged

Sutopia

  • Admiral
  • *****
  • Posts: 901
    • View Profile
Re: Low FPS after battles during campaign
« Reply #1 on: May 27, 2021, 10:30:22 PM »

It can be due to a mod accidentally keeping object reference of combat engine so the Java is not able to garbage collect it, leaving a big chunk of memory occupied indefinitely.
The dead memory will add up each battle, slowly deteriorate the performance of the game and eventually force you to restart completely.
It would be helpful if you can give the list of mod you installed.

Mytre

  • Ensign
  • *
  • Posts: 31
  • So i see you read this
    • View Profile
    • Email
Re: Low FPS after battles during campaign
« Reply #2 on: May 28, 2021, 06:42:40 AM »

It can be due to a mod accidentally keeping object reference of combat engine so the Java is not able to garbage collect it, leaving a big chunk of memory occupied indefinitely.
The dead memory will add up each battle, slowly deteriorate the performance of the game and eventually force you to restart completely.
It would be helpful if you can give the list of mod you installed.

Sure, my currents mods as taken from my mod folder with their folder names is :

Spoiler
A New Level of Confidence - 40 - Rapid
Adjusted Sector v0.3.3
Another Portrait Pack
Arsenal Expansion 1.5.4a
Audio Plus
automatic-orders-0.3.2
Better Colonies
BeyondTheSector
BSC v0.1.2
CaptainsLog
Caymon's Ship Pack
Combat Chatter
Console Commands
DIABLEAVIONICS
enabled_mods.json
Exalted
EXPSP Kitbashes Only
Extratential Lanestate Union
FED
Grand.Colonies1.0.c
GraphicsLib
Hegemony Expeditionary Auxiliary
Hiigaran Descendants
HTE
Hyperdrive
Industrial.Evolution2.2.b
Kadur Remnant
LazyLib
Leading Pip
Legacy of Arkgneisis
Logistics Notifications
LowMaintenance
MagicLib
Mayasuran Navy
Missing ships
Modern Carrier
More HullMods
Nexerelin
Oculian Armada
Ocutek Pirates
OldHyperion
ORA
prv Starworks
Quality Captains
Roider Union
RotcesRats
SCY
SEEKER_UC
Shadowyards
SS-armaa-1.4.7
Starship Legends
tahlan-scalartech
tahlan-shipworks
Terraforming and Station Construction
Torchships
Transfer All Items
UnknownSkies
UpgradedRotaryWeapons
Vayra's Ship Pack
XhanEmpire
[close]


Logged