Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: Skill Changes, Part 2 (07/15/21)

Pages: 1 [2] 3

Author Topic: Troubleshooting  (Read 37863 times)

noob_i_am

  • Ensign
  • *
  • Posts: 7
    • View Profile
Re: Troubleshooting
« Reply #15 on: September 29, 2017, 02:51:41 PM »

Hi,

where is starsector error log? After enabling some mods i cannot run the game, i dont know where to find the log to seek help on my problem. (Win 10)
Logged

AxleMC131

  • Admiral
  • *****
  • Posts: 1714
  • Amateur World-Builder
    • View Profile
Re: Troubleshooting
« Reply #16 on: September 29, 2017, 03:23:24 PM »

Hi,

where is starsector error log? After enabling some mods i cannot run the game, i dont know where to find the log to seek help on my problem. (Win 10)

It's in the "starsector_core" folder. Since you've been playing with mods, I presume you'll know where that is.
Logged

vaygr_Pilot

  • Ensign
  • *
  • Posts: 3
    • View Profile
    • Email
Re: Troubleshooting
« Reply #17 on: July 01, 2019, 07:07:44 PM »

Hi all!

New guy here! After playing for quite some hours (and adding a few mods) I got this error while traveling around:

Fatal: null
Check starsector.log for more info


Taking a look at the log, this is what I get at the very end:


54516 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
   at data.campaign.fleets.MessFleetManager.spawnFleet(MessFleetManager.java:46)
   at com.fs.starfarer.api.impl.campaign.fleets.BaseLimitedFleetManager.advance(BaseLimitedFleetManager.java:84)
   at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
   at com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
   at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

My current modlist is:

Arsenal Expansion 1.5.3g
Audio Plus
Combat Alarm Sounds
Combat Chatter
DisassembleReassemble_v1.6.9
GraphicsLib
HighTechArmada
HMI
JP_RC
LazyLib
Leading Pip
MagicLib
Portrait pack
Ship and Weapon Pack
Starship Legends
UnknownSkies
Version Checker

If someone can help me out I thank you in advance...
Logged

King Alfonzo

  • Admiral
  • *****
  • Posts: 611
  • -- D O C T O R --
    • View Profile
    • Email
Re: Troubleshooting
« Reply #18 on: July 02, 2019, 05:42:05 AM »

Hi all!

New guy here! After playing for quite some hours (and adding a few mods) I got this error while traveling around:
...
If someone can help me out I thank you in advance...

This is caused by HMI. May I ask if you had HMI activated before starting a new game? It's highly likely this error is caused by adding HMI, then loading a previous save which previously did not have this mod active. Further, make sure that the mod is updated to the current version as well. Please tell me if the problem persists.

vaygr_Pilot

  • Ensign
  • *
  • Posts: 3
    • View Profile
    • Email
Re: Troubleshooting
« Reply #19 on: July 02, 2019, 04:25:43 PM »

Hi all!

New guy here! After playing for quite some hours (and adding a few mods) I got this error while traveling around:
...
If someone can help me out I thank you in advance...

This is caused by HMI. May I ask if you had HMI activated before starting a new game? It's highly likely this error is caused by adding HMI, then loading a previous save which previously did not have this mod active. Further, make sure that the mod is updated to the current version as well. Please tell me if the problem persists.

Yep, I added HMI to an ongoing game some days ago. Well, time to revert to an old save then. Thanks for taking the time to help!
« Last Edit: July 02, 2019, 04:28:10 PM by vaygr_Pilot »
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 19092
    • View Profile
Re: Troubleshooting
« Reply #20 on: August 15, 2019, 10:51:22 AM »

Added sections on OpenAL and _JAVA_OPTIONS issues.
Logged

couchpotatoe02

  • Ensign
  • *
  • Posts: 1
    • View Profile
    • Email
Re: Troubleshooting
« Reply #21 on: October 04, 2019, 10:49:27 PM »

Hi All,
I'm having trouble downloading the 0.9.1 version (starsector_install-0.9.1a-RC8.exe)
The problem is that as soon as I start the download, it instantly says 'failed' before doing anything. (I'm using Firefox by the way)
I have tried:
-Restarting download
-Restarting PC
-Trying all links that I can find
-Disabling Smartscreen
-Disabling security
-Changing download location
Unfortunately none of these have worked, it still instantly says 'failed' as soon as I click the link. If someone could help me out, that would be greatly appreciated!

Edit: A friend of mine helped me out, I downloaded it manually using Powershell. Thanks anyway!
« Last Edit: October 04, 2019, 11:25:21 PM by couchpotatoe02 »
Logged

Rei Akiba

  • Ensign
  • *
  • Posts: 16
    • View Profile
    • Email
Re: Troubleshooting
« Reply #22 on: July 02, 2020, 08:59:04 AM »

Can you help me to fix this problem??

154020 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154021 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154021 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154021 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154021 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154021 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154021 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154021 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154021 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154021 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154021 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154021 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154021 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154022 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154022 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154022 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154022 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154022 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154022 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154022 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154022 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154022 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154022 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154022 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154022 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154022 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154023 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154023 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154023 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154023 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154023 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154023 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154023 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154023 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154023 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154023 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154024 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154024 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154024 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154024 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154024 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154024 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154024 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154024 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154024 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154024 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154025 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154025 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154025 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154025 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154025 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154025 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154025 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154025 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154025 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154025 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154025 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154025 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154025 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154026 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154026 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154026 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154026 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154026 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154026 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154026 [Thread-4] WARN  exerelin.utilities.ExerelinConfig  - Faction config ae_ixbattlegroup not found, using default
154030 [Thread-4] INFO  exerelin.campaign.SectorManager  - Faction Rhine Federation has 6 markets left
154031 [Thread-4] WARN  exerelin.campaign.econ.RebellionCondition  - Event is null, re-fetching
154034 [Thread-4] INFO  com.fs.starfarer.loading.LoadingUtils  - Loading CSV data from [DIRECTORY: D:\Starsector\starsector-core\..\mods\Nexerelin]
154041 [Thread-4] INFO  exerelin.world.NexMarketBuilder  - Added special industry class: commerce
154041 [Thread-4] INFO  exerelin.world.NexMarketBuilder  - Added special industry class: waystation
154042 [Thread-4] INFO  exerelin.world.NexMarketBuilder  - Added special industry class: cryosanctum
154042 [Thread-4] INFO  exerelin.world.NexMarketBuilder  - Added special industry class: ii_interstellarbazaar
154043 [Thread-4] INFO  com.fs.starfarer.loading.LoadingUtils  - Loading CSV data from [DIRECTORY: D:\Starsector\starsector-core\..\mods\Nexerelin]
154052 [Thread-4] INFO  com.fs.starfarer.loading.LoadingUtils  - Loading JSON from [DIRECTORY: D:\Starsector\starsector-core\..\mods\Nexerelin (data/config/exerelin/planetNames.json)]
154055 [Thread-4] INFO  exerelin.campaign.ColonyManager  - Processing NPC construction queue for Ava
154060 [Thread-4] WARN  exerelin.campaign.econ.RebellionCondition  - Event is null, re-fetching
154062 [Thread-4] INFO  sound.oo0O  - Cleaning up music with id [RunningDark.ogg]
154078 [Thread-8] INFO  sound.oo0O  - Cleaning up music with id [campaign_music_part_2_v28.ogg]
154310 [Thread-11] INFO  sound.oo0O  - Creating streaming player for music with id [campaign_music_part_2_v28.ogg]
154310 [Thread-11] INFO  sound.null  - Playing music with id [campaign_music_part_2_v28.ogg]
154734 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
   at com.fs.starfarer.api.impl.campaign.econ.impl.deconomics_embassy.betaCoreRemoval Penalty(deconomics_embassy.java:352)
   at com.fs.starfarer.api.impl.campaign.econ.impl.deconomics_embassy.advance(deconomics_embassy.java:374)
   at com.fs.starfarer.campaign.econ.Market.advance(Unknown Source)
   at com.fs.starfarer.campaign.econ.Economy.advance(Unknown Source)
   at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
   at com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
   at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

so long story short...this problem occur after i invaded shanghai,retaking it from persean league and transfer the market to the tiandong industries which originally their market base...after that i went out to protect my colony from luddic church invasion, yes you can tell i added nexerelin if i can do this things... Here's the list of the mods

arsenal expansion
better colonies
commissioned crews
diableavionics
DIYplanets
ED shipyard
Foundation Of Borken
Gates-awakened
Hyperdrive
Industrial Evolution
Interstellar Imperium
JP_RC
Kadur Remnant
Legacy Of Arkgenesis
Metelson
Missing ships
nabaal
Nexerelin
Ship and Weapon Pack
SkilledUp
tahlan
Terraforming and station construction
Tiandong Heavy industries
Torchships
Tyrador Safeguard Coalition
UnknownSkies
Vayra sector
Vayra ship pack
vesperon

i start the save from beginning, i didnt do anything and i didnt add other mods, it just like that and error happenned

the error said "Fatal: null Check starsector log for more info" but the icon its not starscetor icon, but its java icon, i think java is the problem??
Logged

SirHartley

  • Captain
  • ****
  • Posts: 458
    • View Profile
Re: Troubleshooting
« Reply #23 on: July 02, 2020, 09:05:00 AM »

This should have been it's own post under Bug reports: Modded.
But, since we are here already:

Did you try to remove the Beta core from an Embassy?

Edit - Checked the code, removing a beta core while having no ambassador installed causes this crash. Don't do that for now, I fixed it for the next version.
« Last Edit: July 02, 2020, 09:16:09 AM by SirHartley »
Logged

Rei Akiba

  • Ensign
  • *
  • Posts: 16
    • View Profile
    • Email
Re: Troubleshooting
« Reply #24 on: July 02, 2020, 10:40:37 AM »

So what do i do now?? Am I stuck for now with the bug? ... Uh yes i tried to removing beta core on embassy and replaced it with Alpha core (while still docked at ava colony) but I was unsure if want to use alpha core for an embassy that is not really important, so I unplug the alpha core and replace it AGAIN with beta, while didn't have an ambassador, and the colony having that is far away from the core world and the crash immediate happened when I was traveling... Anyway thanks for the help, so it's from the beta core right okay I'll wait, and please I don't want to lose this save file cause I already have a good colony, very rare ships (maybe it's the only ships in the game that doesnt have any blueprints and market) , the best so far from other saves I played.. So I'll wait for the updates
Logged

SirHartley

  • Captain
  • ****
  • Posts: 458
    • View Profile
Re: Troubleshooting
« Reply #25 on: July 02, 2020, 10:48:49 AM »

the next update for Industrial.Evolution will not be save compatible.

If you have a beta core in the Embassy now, it will not crash.

If you have a Beta Core in your inventory, you can enable "allowRemoteIndustryItemManagement" in settings.json, start the game, enter the colony from the management screen and place a core into the industry.

If you don't have one, you can just use console commands to do "addItem betaCore", then place it remotely.
Logged

Mondaymonkey

  • Admiral
  • *****
  • Posts: 777
    • View Profile
Re: Troubleshooting
« Reply #26 on: July 02, 2020, 10:54:31 AM »

the next update for Industrial.Evolution will not be save compatible.

Spoiler
[close]
Logged
I dislike human beings... or I just do not know how to cook them well.

Yunru

  • Admiral
  • *****
  • Posts: 922
    • View Profile
Re: Troubleshooting
« Reply #27 on: July 02, 2020, 12:25:44 PM »

the next update for Industrial.Evolution will not be save compatible.
Jokes on you, I suffer from World Restart Syndrome anyway! Haha ha ha wah...

Rei Akiba

  • Ensign
  • *
  • Posts: 16
    • View Profile
    • Email
Re: Troubleshooting
« Reply #28 on: July 02, 2020, 11:57:14 PM »

i already have the beta core in embassy for at least one cycle in game,its a long time ago, it still crash
Logged

Rei Akiba

  • Ensign
  • *
  • Posts: 16
    • View Profile
    • Email
Re: Troubleshooting
« Reply #29 on: July 03, 2020, 12:04:44 AM »

wait forget what i said... so i tried to shutdown the embassy with the beta core and ambassador and it turns out i didnt crash anymore
Logged
Pages: 1 [2] 3