Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95.1a is out! (12/10/21); Blog post: Hyperspace Topography (10/12/22)

Author Topic: [0.95] can enable old mods with 'enable all'  (Read 452 times)

Vayra

  • Admiral
  • *****
  • Posts: 627
  • jangala delenda est
    • View Profile
[0.95] can enable old mods with 'enable all'
« on: March 26, 2021, 11:30:23 AM »

clicking the little box doesn't work for 0.91 mods, this seems intended
clicking 'enable all' does work, which of course crashes the game when it finishes loading
Logged
Kadur Remnant: http://fractalsoftworks.com/forum/index.php?topic=6649
Vayra's Sector: http://fractalsoftworks.com/forum/index.php?topic=16058
Vayra's Ship Pack: http://fractalsoftworks.com/forum/index.php?topic=16059

im gonna push jangala into the sun i swear to god im gonna do it

Vayra

  • Admiral
  • *****
  • Posts: 627
  • jangala delenda est
    • View Profile
Re: [0.95] can enable old mods with 'enable all'
« Reply #1 on: March 26, 2021, 11:35:57 AM »

also idk if this is a bug, but having to double-click updated mods (once to select the line, once to toggle the button) to enable/disable them feels a bit wonky
Logged
Kadur Remnant: http://fractalsoftworks.com/forum/index.php?topic=6649
Vayra's Sector: http://fractalsoftworks.com/forum/index.php?topic=16058
Vayra's Ship Pack: http://fractalsoftworks.com/forum/index.php?topic=16059

im gonna push jangala into the sun i swear to god im gonna do it

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 20990
    • View Profile
Re: [0.95] can enable old mods with 'enable all'
« Reply #2 on: March 26, 2021, 12:18:34 PM »

Thank you, fixed!

also idk if this is a bug, but having to double-click updated mods (once to select the line, once to toggle the button) to enable/disable them feels a bit wonky

Ah - kind of how it needs to work, since you want to be able to select the line item just to see its info.
Logged

BTracer

  • Ensign
  • *
  • Posts: 32
    • View Profile
Re: [0.95] can enable old mods with 'enable all'
« Reply #3 on: March 26, 2021, 07:02:26 PM »

Ah - kind of how it needs to work, since you want to be able to select the line item just to see its info.

This also felt wonky to me. I almost thought I downloaded incompatible mods. IMHO clicking directly on a checkbox should both select the line and check/uncheck the box - clicking anywhere else should just select the corresponding line. 
Logged