Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: Skill Changes, Part 2 (07/15/21)

Pages: 1 2 [3]

Author Topic: [0.95a] RotcesRats v0.13  (Read 45391 times)

Nameless

  • Lieutenant
  • **
  • Posts: 67
    • View Profile
Re: [0.95a] RotcesRats v0.12
« Reply #30 on: June 24, 2021, 11:01:28 AM »

I hate this mod. Now I try to read every ship name backwards.
Logged

Amazigh

  • Commander
  • ***
  • Posts: 128
    • View Profile
    • Email
Re: [0.95a] RotcesRats v0.12
« Reply #31 on: June 29, 2021, 02:34:02 PM »

Update 0.13

-- Now Requires LazyLib
New Ships
- Sojurn (Cruiser)
- Shkiper (Frigate)
- Dominatrix (Cruiser)
- Dram Mk.= (Frigate)
- Hooligan (Frigate)

-- Lamia/Lerna chargeup time changed from 0.5/1 to 0.2/0.6
-- Flint Coilgun range increased to 650
-- Adjusted launch angle on various launch bays to match the visual appearance of the bays.



Is still suppose RotcesRats v0.12 still 0.9.1a compatible? Cause for me it crash and send me message about missile spread and combat API.
Missile Spread is a new feature added in 0.95a, and with me adding some scripted components to the mod as well, it will no longer be backwards compatible without removing content.
Logged

peppermeth

  • Ensign
  • *
  • Posts: 36
    • View Profile
Re: [0.95a] RotcesRats v0.13
« Reply #32 on: July 11, 2021, 09:38:44 AM »


"Is still suppose RotcesRats v0.12 still 0.9.1a compatible? Cause for me it crash and send me message about missile spread and combat API.
Missile Spread is a new feature added in 0.95a, and with me adding some scripted components to the mod as well, it will no longer be backwards compatible without removing content."

 What content would need to be remove? May i ask?
Logged

Amazigh

  • Commander
  • ***
  • Posts: 128
    • View Profile
    • Email
Re: [0.95a] RotcesRats v0.13
« Reply #33 on: July 16, 2021, 05:45:13 PM »

What content would need to be remove? May i ask?
I know you'd have to go into the weapons.csv and remove the "MISSILE_SPREAD" tag from the weapons that use it. But other than that i don't know, and you'd have to test to see if there is anything else causes crashes and work from there.
Logged

peppermeth

  • Ensign
  • *
  • Posts: 36
    • View Profile
Re: [0.95a] RotcesRats v0.13
« Reply #34 on: July 17, 2021, 04:28:50 PM »

What content would need to be remove? May i ask?
I know you'd have to go into the weapons.csv and remove the "MISSILE_SPREAD" tag from the weapons that use it. But other than that i don't know, and you'd have to test to see if there is anything else causes crashes and work from there.

I tried to alter that file on other mod, but the game just kept crashing.
So how do i do that while keeping the mod functional? 
Logged

Amazigh

  • Commander
  • ***
  • Posts: 128
    • View Profile
    • Email
Re: [0.95a] RotcesRats v0.13
« Reply #35 on: July 23, 2021, 02:59:42 PM »

I tried to alter that file on other mod, but the game just kept crashing.
So how do i do that while keeping the mod functional? 
Could be you're using  a program that has issues with editing CSV files (excel for example) if you're having more issues and really want to try and backport the mod, your best best is to go onto the unofficial discord and ask for help there and someone will be able to walk you through any issues you're having.
Logged
Pages: 1 2 [3]