Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: Skill Changes, Part 2 (07/15/21)

Author Topic: Windows Aero Bug (Possibly)  (Read 504 times)

SierraTangoDelta

  • Commander
  • ***
  • Posts: 149
  • Who could it be?
    • View Profile
Windows Aero Bug (Possibly)
« on: August 24, 2020, 12:13:48 PM »

Hey, posting here to inform Alex about this weird *** bug I was dealing with for Starsector.

I just recently built a new computer (specs below) and reinstalled most of my games on it. I wanted to see how Starsector would run on it, but it wouldn't start.
https://i.imgur.com/HI1jrOm.png

Running it in the suggested compatibility mode did not work either
https://i.imgur.com/4QlPfpl.png

Then I tried something stupid, I just disabled all excess visual effects for Windows 7
https://cdn.discordapp.com/attachments/619635013201428481/747528841878175946/unknown.png

This actually caused the game to run.

I then went down the list, enabling each one and running the game to see if I could figure out if it was a specific setting or a combination of settings doing it.
https://i.imgur.com/F6EIOB4.png

I get to the last one (Use visual styles on windows and buttons) and somehow that's the one that stops Starsector's launch window from showing up. Switching to Windows 7 Classic or disabling Windows visuals entirely fixed the issue, it just makes the computer look like it's running Windows 95 for the menus. Not a huge deal.
https://cdn.discordapp.com/attachments/619635013201428481/747529676125372496/unknown.png


Long story short, for SOME reason, having Windows Aero enabled on my system caused Starsector to not run properly.
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 18894
    • View Profile
Re: Windows Aero Bug (Possibly)
« Reply #1 on: August 24, 2020, 12:43:01 PM »

Huh - thank you for letting me know, and for the detailed info! It *seems* like this wouldn't always be the case - or more people would probably have trouble with it? - but this is really good to know for when this might come up for someone else.
Logged

SierraTangoDelta

  • Commander
  • ***
  • Posts: 149
  • Who could it be?
    • View Profile
Re: Windows Aero Bug (Possibly)
« Reply #2 on: August 24, 2020, 02:22:34 PM »

Yeah I was talking about it with a few people on the Discord, from what I saw only one other person had ever seen anything related to it. It seems like Windows Aero causes the launcher to not show up, since I saw that Java was running in my processes and taking up a sizable amount of memory.
Logged

Bodyless

  • Ensign
  • *
  • Posts: 1
    • View Profile
Re: Windows Aero Bug (Possibly)
« Reply #3 on: November 22, 2020, 11:34:31 AM »

I actually have the same issue on my windows 7 machine. Seems to be an issuse specific to windows 7, i dont think later windows versions use the aero design.
Logged