Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: Skill Changes, Part 2 (07/15/21)

Pages: 1 ... 4 5 [6]

Author Topic: [Late Game] Battles & Colony Management ruin FPS gradually & permanently.  (Read 7151 times)

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email
Re: [Late Game] Battles & Colony Management ruin FPS gradually & permanently.
« Reply #75 on: January 03, 2021, 04:33:09 AM »

Maybe Magiclib is the culprit, I mean it deals with community scripts that might be prone to memory leak issues abroad I'm finding my game unplayable now seems the more time I spend on one save the faster it gets slower after big battles even though the UI is perfectly fine I can reach a saving time of 1 minute sometimes lmao on an SSD! I even reduced my map size to vanilla still happening I'm about to cry it's my favourite game.
I hope my donations go well but I really can't enjoy the game without the mods. lowkey depressed.
Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.

SirHartley

  • Captain
  • ****
  • Posts: 459
    • View Profile
Re: [Late Game] Battles & Colony Management ruin FPS gradually & permanently.
« Reply #76 on: January 03, 2021, 12:51:34 PM »

No solution for the post combat problem. Vayras' sector has been identified as culprit for most campaign layer lag issues due to fleet spam.
This can be alleviated by using ClearCommands, https://fractalsoftworks.com/forum/index.php?topic=19210, cSmartClear, but it's nothing other than a band aid.
For new saves, do this before starting:

Go to Vayra's Sector\data\config\vayraRaiders
Open warhawk_republic.json
find the line:
"spawnNonEventFleets":true, # OPTIONAL Boolean, default false
    # Causes small, NON-EVENT-RELATED fleets to spawn from ALL markets owned by the faction (i.e. not just bases created by this framework)


and set it to false
do the same for hegemony.json
Logged

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email
Re: [Late Game] Battles & Colony Management ruin FPS gradually & permanently.
« Reply #77 on: January 04, 2021, 12:13:04 AM »

No solution for the post combat problem. Vayras' sector has been identified as culprit for most campaign layer lag issues due to fleet spam.
This can be alleviated by using ClearCommands, https://fractalsoftworks.com/forum/index.php?topic=19210, cSmartClear, but it's nothing other than a band aid.
For new saves, do this before starting:

Go to Vayra's Sector\data\config\vayraRaiders
Open warhawk_republic.json
find the line:
"spawnNonEventFleets":true, # OPTIONAL Boolean, default false
    # Causes small, NON-EVENT-RELATED fleets to spawn from ALL markets owned by the faction (i.e. not just bases created by this framework)


and set it to false
do the same for hegemony.json

As I expected this does nothing for my after battle lag issue where it slows to a crawl but it seems useful when using a big sector map for the adjusted sector. May I ask what the varya's non event fleets do? does it make more things to kill or just bloats for no reason because I want to know if I'm essentially disabling more spawns of enemies because I like killing things.
Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.

SirHartley

  • Captain
  • ****
  • Posts: 459
    • View Profile
Re: [Late Game] Battles & Colony Management ruin FPS gradually & permanently.
« Reply #78 on: January 04, 2021, 10:15:22 AM »

spawns hundreds of small (1-2 ship) fleets that do nothing and never despawn. Single largest contributor to the endemic campaign stutter issues and people running out of RAM to save.
Logged

Quantax

  • Ensign
  • *
  • Posts: 2
    • View Profile
Re: [Late Game] Battles & Colony Management ruin FPS gradually & permanently.
« Reply #79 on: January 28, 2021, 06:44:13 AM »

I'm having similar performance issues and I can definitely say that battles the triggering event for the slowdown, at least for me. For a while I have observed that FPS seems to tank after sizeable battles, and just a moment ago I was flying around  at pretty stable in-system 60 FPS but immediately after a large(ish) battle my in-system FPS drops to sub-20 and hyperspace FPS is even worse at 12 - 18 FPS (was 40ish before slowdown). FPS don't recover without a game reboot.
« Last Edit: January 28, 2021, 06:46:00 AM by Quantax »
Logged

GhostReconZB

  • Ensign
  • *
  • Posts: 5
    • View Profile

I did some observation with this battle triggered slowdown of the game. For the battle to trigger the slowdown, I believe 2 critierias need to be met:
1. The battle should take place in the core sector. 
2. The player needs to be near or in the battle.
For what I found out is that in late game, if u spent all the time exploring the unknow space, u can keep engaging in big battles with remnant fleet or derelict probes without triggering the slowdown. But the same thing can not be said while u are in core sector, even if u just roam around the core sector without engaging in fight as long as u are regularly "exposed" to nearby big fights between AI, at some point the slowdown will still be triggered. My guess is that the reaction script by the "living" faction in the core sector (instead of somewhat dead faction like remnant) will slowly cumlating performance issues until eventually slowdown the game.
« Last Edit: March 20, 2021, 02:53:40 AM by GhostReconZB »
Logged

phonon5891

  • Ensign
  • *
  • Posts: 7
    • View Profile

Just wanted to add my own experiences with this issue. In no particular order:
  • The performance issues vary, including (but not limited to) FPS drops in campaign and/or combat layers, saving the game taking absurd amounts of time, several seconds of freezing upon entering a new system or opening a storage/transfer interface (salvage screen, inventory, trading at stations, etc), and jitters/stutters on the campaign layer. These symptoms do not always appear together, and each can appear separately from the others; for example, I've had a session where I only became aware of the issue when I hit F5 and the game took a full minute to save (on an NVMe drive no less). So far I haven't found a pattern for what symptom happens when -- the only certainty is that at least one of these symptoms will eventually force me to save, quit and restart the game.
  • I have definitely had battles, especially large ones (station assaults/defense, vengeance fleets, etc.) after which some of these symptoms appear.
  • I have also had symptoms appear after taking a long time in the fleet refit screen (both with and without combat simulations), and even a couple times after merely pausing the game on the campaign layer and taking an extended break from the computer.
  • RAM/VRAM usage does not seem to have any bearing on this issue for me, nor does cSmartClear help with the symptoms once they appear.
  • The most recent release of Vayra's Sector (which I am using) seems to have deprecated the "spawnNonEventFleets" option entirely. This, combined with cSmartClear seemingly having no effect on symptoms makes me unsure if it is ultimately relevant to this slowdown issue.
  • [EDIT2ADD:] I have experienced slowdown issues with both modded and vanilla runs since as far back as 0.7.2 IIRC, across 3 different PCs I have owned since then. Also of note: back then I stuck only to faction/weapon mods (so no (N)exerelin or Vayra's Sector or similar major mechanics-changing mods) but slowdowns occurred nonetheless.

As mentioned before, so far the only thing that helps is a complete quit and restart of the game.
« Last Edit: March 24, 2021, 04:41:34 AM by phonon5891 »
Logged

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email

Is this issue still relevant in 0.95a?
Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.

Histidine

  • Admiral
  • *****
  • Posts: 3352
    • View Profile
    • Bitbucket profile
    • Email

Is this issue still relevant in 0.95a?
I'm still getting it on 0.95a (and IIRC it happened on my unmodded/minimally modded run). Haven't tested if the Java 8 workaround still works.
Logged

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email

Is this issue still relevant in 0.95a?
I'm still getting it on 0.95a (and IIRC it happened on my unmodded/minimally modded run). Haven't tested if the Java 8 workaround still works.

That's unfortunate it seems the memory leak indicator introduced in 0.95a changelog didn't do the trick but still is useful for the future. Going to try Java 8 workaround as well and if it even starts up for me this time ill follow your instructions.

EDIT: Might be dumb but you mentionned simply deleting ..\jre\bin\java.exe in starsector.bat which im using to launch and replace with just java therefore it being java.exe -Djava.library.path=native\windows and so on or just java without the .exe or do I need to specify the directory to the latest java on my computer? I ask this because it opens the cmd for like 1 second and does nothing now. I have allow any java version set to true.

Off topic: I apologize sincerely for asking too many questions on your nex thread I really do respect your work and your efforts its just some information isn't readily available with keyword searches on the forum or some documentation is not readily available. I do not want to come across as annoying by any means.
« Last Edit: May 14, 2021, 05:56:19 PM by Flacman3000 »
Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.

Histidine

  • Admiral
  • *****
  • Posts: 3352
    • View Profile
    • Bitbucket profile
    • Email

It's just java with no .exe.
If the CMD window disappears without the game starting, add a PAUSE to the end of the .bat file so it keeps the window around and you can see any error message it's printing.
Logged

Vind

  • Admiral
  • *****
  • Posts: 707
    • View Profile

I got massive slowdown after destroying path battle station and reloading save file after game restart did nothing - switching to oracle 8 java version eliminated slowness after reload but the most puzzling part - next day same "crawling" save file worked fine with game default java. Something with memory fragmentation maybe the issue so immediately reloading game and save file doesnt help due to OS caching.
Logged

Gazelem

  • Ensign
  • *
  • Posts: 5
    • View Profile

I've been testing some things and I think I may be having a different issue. I also have been getting the mid and late-game crawl, but it seems to be related to the number of ships I have. Doesn't matter how many OP they have or if they're outfitted or not, but once I go over 10 I drop below 60 fps, and once I go beyond 15 I drop below 45 fps. Here are my computer specs and mod list:

The odd thing is that I spawned large fleets with this mod list and nuked them, probably about a dozen 500 point fleets, and I didn't get any slowness until I started scavenging ships.

Spoiler
Mods:

Lightshow
Trailer Moments
A New Level of Confidence
Adjusted Sector
Better Colonies
Beyond the Sector
Captain's Log
Caymon's Ship Pack
Combat Chatter
Console Commands
DIY Planets
Fluff Ship Pack
Hegemony Expeditionary Auxiliaries
Internal Affairs
Kadur Remnant
LazyLib
Legacy of Arkgneisis
Persean Chroniccles
Quality Captains
Stellar Networks
Supply Foraging
Tahland Shipworks
Vayra's Ship PAck
ZZ Audio Plus
Modified Industry Requirements
Graphicslib (disabled)
[close]

Spoiler
Specs

Windows 10
Processor   Intel(R) Core(TM) i7-10750H CPU @ 2.60GHz, 2592 Mhz, 6 Core(s), 12 Logical Processor(s)
Installed Physical Memory (RAM)   16.0 GB
Total Virtual Memory   29.3 GB
NVIDIA GeForce RTX 2060


I've allocated 4 GB of RAM to Starsector and never come close to that limit. I do seem to have large VRAM spikes, but typically float 1 or 2 GB free
[close]


EDIT:

Found the culprit in my case. It was Legacy of Arkgneisis, which is a shame because I quite like that mod.
« Last Edit: May 22, 2021, 02:33:01 PM by Gazelem »
Logged

Avallac

  • Ensign
  • *
  • Posts: 11
    • View Profile
Re: [Late Game] Battles & Colony Management ruin FPS gradually & permanently.
« Reply #88 on: September 01, 2021, 06:04:35 PM »

I keep having some of the same issues as this thread. Even if I use smartclear command from console mod the INTERFACE still stays extremely laggy and it takes minutes to click on something like colony panel or save the game. Super annoying having to save and restart the game every few battles.
Logged
Pages: 1 ... 4 5 [6]