Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95.1a is out! (12/10/21); Blog post: Hyperspace Topography (10/12/22)

Pages: 1 ... 59 60 [61] 62 63 ... 109

Author Topic: [0.95.1a] Industrial.Evolution 3.1.f - Campaign content expansion  (Read 661671 times)

Paper Kite

  • Ensign
  • *
  • Posts: 5
    • View Profile
Re: [0.95a] Industrial.Evolution 2.2.f - Campaign content expansion
« Reply #900 on: June 05, 2021, 10:22:03 PM »

I don't mean to be rude, but I'm gonna fiddle with this mod in my computer and find a way to build the Industrial Ruins buildings everywhere

Kinda bothers me that they only spawn on *** worlds in the middle of bumfuck nowhere
so i'm going to change it for myself
Logged

SirHartley

  • Admiral
  • *****
  • Posts: 634
    • View Profile
Re: [0.95a] Industrial.Evolution 2.2.f - Campaign content expansion
« Reply #901 on: June 06, 2021, 12:59:18 AM »

Do not publicly release any versions of this mod that have been tampered with or been changed in any way and we can stay friends.
Logged

Farya

  • Commander
  • ***
  • Posts: 218
    • View Profile
Re: [0.95a] Industrial.Evolution 2.2.f - Campaign content expansion
« Reply #902 on: June 06, 2021, 02:33:12 AM »

What about allowing to transfer D-mods not only between same ships but also between different variants? Provided mod author would specificaly whitelist it.
So you could for example take a working engine from luddic Lasher to repair a stock one. Maybe there should be two lists though. For close compatability and partial one. In later case you may either only transfer a limited list of defects or have to provide some ship components for the process as you have to modify donated parts to fit properly into differ hull. Pirate hulls may also have it easier to be repaired with parts taken from stock variants.
Logged

DecoyGrenadeOut

  • Ensign
  • *
  • Posts: 18
    • View Profile
Re: [0.95a] Industrial.Evolution 2.2.f - Campaign content expansion
« Reply #903 on: June 06, 2021, 12:20:26 PM »

Hello, I got this error trying to load my save. Attached in the text file because it's too long to be posted in this comment. I'm using 2.2.f and I've tried reinstalling the mod multiple times.
Logged

Adv3nt0r

  • Ensign
  • *
  • Posts: 1
    • View Profile
Re: [0.95a] Industrial.Evolution 2.2.f - Campaign content expansion
« Reply #904 on: June 06, 2021, 12:43:19 PM »

I have the Problem that the Boni of the ancient Laboratory change a few times. I had a Laboratory on a Planet which gave me +3 heavy Armaments so i built Orbital Works, then it changed to +3 Ship Hulls, still okay i guess. But now it changed again to +3 Volatiles, which is completely usless for me on this planet
Logged

SirHartley

  • Admiral
  • *****
  • Posts: 634
    • View Profile
Re: [0.95a] Industrial.Evolution 2.2.f - Campaign content expansion
« Reply #905 on: June 06, 2021, 01:09:03 PM »

Hello, I got this error trying to load my save. Attached in the text file because it's too long to be posted in this comment. I'm using 2.2.f and I've tried reinstalling the mod multiple times.
hm, this is a weird one - No idea what went wrong, I'll try to fix it.

I have the Problem that the Boni of the ancient Laboratory change a few times. I had a Laboratory on a Planet which gave me +3 heavy Armaments so i built Orbital Works, then it changed to +3 Ship Hulls, still okay i guess. But now it changed again to +3 Volatiles, which is completely usless for me on this planet
heard about this, but no idea what causes it. Sorry for the issue, I'll take a look, and thank you for the report.

What about allowing to transfer D-mods not only between same ships but also between different variants? Provided mod author would specificaly whitelist it.
So you could for example take a working engine from luddic Lasher to repair a stock one. Maybe there should be two lists though. For close compatability and partial one. In later case you may either only transfer a limited list of defects or have to provide some ship components for the process as you have to modify donated parts to fit properly into differ hull. Pirate hulls may also have it easier to be repaired with parts taken from stock variants.
I'll think about this!
Logged

callitri

  • Ensign
  • *
  • Posts: 13
    • View Profile
    • Email
Re: [0.95a] Industrial.Evolution 2.2.f - Campaign content expansion
« Reply #906 on: June 06, 2021, 09:21:02 PM »

Hi there i have a problem and its most likely from industrial evolution , i say this because i can play the game fine for days nothing happens , but as soon as i touch some buildings from this mod for ex the military relay it fatal:null crashes the game
i tried looking in the crash report but i know nothing about it so its useless to me
another thing , i cannot build a commerce industry because it says there can only be one in system but i have none , someone mentioned its an industrial evolution bug but its fixed in current version , well i still have it
if these problems arent related to your mod ignore this and i apologize
Great mod btw been using it for a long time now
wanted to upload the crash report but apparently its over the size limit and i dont know which part is the relevant one
Logged

SirHartley

  • Admiral
  • *****
  • Posts: 634
    • View Profile
Re: [0.95a] Industrial.Evolution 2.2.f - Campaign content expansion
« Reply #907 on: June 07, 2021, 12:48:37 AM »

old issue, fixed in 2.2.f, update the mod!
Logged

SpirituMagno

  • Ensign
  • *
  • Posts: 7
    • View Profile
    • Email
Re: [0.95a] Industrial.Evolution 2.2.f - Campaign content expansion
« Reply #908 on: June 07, 2021, 07:48:04 PM »

Hi! Got a corrupted save after using the rift generator, Im not sure if it is 100% related to it but Ill try my luck here. Ill copy the same thing that I put in Bug Reports.

Quote
First time posting here but read how to post bugs here.
1)Code:
Code
53229 [Thread-3] ERROR com.fs.starfarer.combat.CombatMain  - java.util.ConcurrentModificationException
java.util.ConcurrentModificationException
at java.util.ArrayList$Itr.checkForComodification(Unknown Source)
at java.util.ArrayList$Itr.next(Unknown Source)
at com.fs.starfarer.api.plugins.update.IndEvo_ModUpdater.replaceIndustries(IndEvo_ModUpdater.java:131)
at com.fs.starfarer.api.plugins.update.IndEvo_ModUpdater.run(IndEvo_ModUpdater.java:44)
at com.fs.starfarer.api.plugins.IndEvo_modPlugin.updateVersionIfNeeded(IndEvo_modPlugin.java:129)
at com.fs.starfarer.api.plugins.IndEvo_modPlugin.onGameLoad(IndEvo_modPlugin.java:54)
at com.fs.starfarer.campaign.save.CampaignGameManager.o00000(Unknown Source)
at com.fs.starfarer.title.TitleScreenState.dialogDismissed(Unknown Source)
at com.fs.starfarer.ui.Oo0O.dismiss(Unknown Source)
at com.fs.starfarer.ui.impl.o0oO.dismiss(Unknown Source)
at com.fs.starfarer.campaign.save.LoadGameDialog.actionPerformed(Unknown Source)
at com.fs.starfarer.ui.newnew.buttonPressed(Unknown Source)
at com.fs.starfarer.ui.I.?00000(Unknown Source)
at com.fs.starfarer.ui.I.processInput(Unknown Source)
at com.fs.starfarer.ui.Stringsuper.super(Unknown Source)
at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
at com.fs.state.AppDriver.begin(Unknown Source)
at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
2)List of mods:
"anotherportraitpack",
  "gflportraitpack",
  "gflportraitpack2",
  "HMI",
  "IndEvo",
  "kadur_remnant",
  "lw_lazylib",
  "ArkLeg",
  "MagicLib",
  "Mayasuran Navy",
  "missingships",
  "nexerelin",
  "simpleplayerflags",
  "Terraforming and Station Construction",
  "star_federation",
  "vayrashippack",
  "shaderLib"
Acording to the updater all mods that it can detect are up to date (when checking on another save).

3)Context: I was experimenting with the rift generator, first time moved a planet without problems (option was closest colony), second time (same option) it started but didnt do anything and the "teleport" sound still playing for more than a month, decided to exit and reload but game crashed saying "Fatal: null Check starsector.log for more info". Loading with or without sound results in the same crash.
When creating a new game, game works as normal.

Using 4gb (4096m) for RAM and starting the game from the starsector.exe.

Now Im sad because save not working  :'(

EDIT 1: If there is just a solution to somehow cancel the animation without fixing the issue I would gladly accept it and just not use the teleport building for planets.
Logged

SirHartley

  • Admiral
  • *****
  • Posts: 634
    • View Profile
Re: [0.95a] Industrial.Evolution 2.2.f - Campaign content expansion
« Reply #909 on: June 08, 2021, 12:34:48 AM »

update the mod, that's been fixed in 2.2.f
Logged

SpirituMagno

  • Ensign
  • *
  • Posts: 7
    • View Profile
    • Email
Re: [0.95a] Industrial.Evolution 2.2.f - Campaign content expansion
« Reply #910 on: June 08, 2021, 12:40:16 PM »

update the mod, that's been fixed in 2.2.f
Sorry! Trusted in the updater but it wasnt actually on the .f version. Its alright, the only problem is that the planet gets teleported to the center of the system inside the stars and its invisible (both in the  command window and the 3d fleet view). Also half the star doesnt have the Corona debuff.
Screenshots:
https://imgur.com/a/7FRzKJt
« Last Edit: June 08, 2021, 12:44:26 PM by SpirituMagno »
Logged

SirHartley

  • Admiral
  • *****
  • Posts: 634
    • View Profile
Re: [0.95a] Industrial.Evolution 2.2.f - Campaign content expansion
« Reply #911 on: June 08, 2021, 01:09:15 PM »

it's possible that this planet is broken and lost due to that bug you encountered - I was only able to restore saves to functionality and do some medium heavy cleanup, but stuff like that is too arcane to catch and fix within the limited tools I have - I'd likely break more than I fix.

Very sorry about that!
Logged

SpirituMagno

  • Ensign
  • *
  • Posts: 7
    • View Profile
    • Email
Re: [0.95a] Industrial.Evolution 2.2.f - Campaign content expansion
« Reply #912 on: June 08, 2021, 02:23:34 PM »

it's possible that this planet is broken and lost due to that bug you encountered - I was only able to restore saves to functionality and do some medium heavy cleanup, but stuff like that is too arcane to catch and fix within the limited tools I have - I'd likely break more than I fix.

Very sorry about that!

No problem, bugs like this always happen, just wanted you to know about it. Have a nice day!
Logged

CrimsonPhalanx

  • Ensign
  • *
  • Posts: 45
    • View Profile
Re: [0.95a] Industrial.Evolution 2.2.f - Campaign content expansion
« Reply #913 on: June 08, 2021, 10:15:37 PM »

I have a question about an item, I'll put it in a spoiler just incase

Spoiler
It's about the item for the relays/military base, one of the effects says it allows construction of a relay without a military base right? But the odd thing is that I need a military base to install it in the first place, so I'm confused if I'm doing something wrong here
[close]

Logged

Yunru

  • Admiral
  • *****
  • Posts: 1559
    • View Profile
Re: [0.95a] Industrial.Evolution 2.2.f - Campaign content expansion
« Reply #914 on: June 08, 2021, 11:02:48 PM »

I have a question about an item, I'll put it in a spoiler just incase

Spoiler
It's about the item for the relays/military base, one of the effects says it allows construction of a relay without a military base right? But the odd thing is that I need a military base to install it in the first place, so I'm confused if I'm doing something wrong here
[close]
I too found that odd, because a regular patrol base (lowest version) will do it too.
Pages: 1 ... 59 60 [61] 62 63 ... 109