Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Pages: 1 ... 15 16 [17] 18 19 ... 80

Author Topic: [0.95.1a] Industrial.Evolution 2.2.h - Campaign content expansion  (Read 371563 times)

darkond2100

  • Ensign
  • *
  • Posts: 6
    • View Profile

Has anyone tried running this with Archean Order?
Logged

Bulldog

  • Ensign
  • *
  • Posts: 22
    • View Profile
    • Email

Hello, I'm facing a bit of an issue with the ambassador system.

I picked up an ambassador from Yuri Expedition but upon inaugurating them and letting the day pass, I immediately get the two messages that the ambassador was arrested for being compromised along with the message that (Yuri Expedition) agents can no longer track the ambassador and suspect that they are compromised.

I've tried picking up a new ambassador and installing them several times, but the above situation plays out again. It seems to be faction specific as when I tried picking up an ambassador from another faction(mayasura), they were inaugurated without any issues.
Logged

SirHartley

  • Captain
  • ****
  • Posts: 480
    • View Profile

Hello, I'm facing a bit of an issue with the ambassador system.

I picked up an ambassador from Yuri Expedition but upon inaugurating them and letting the day pass, I immediately get the two messages that the ambassador was arrested for being compromised along with the message that (Yuri Expedition) agents can no longer track the ambassador and suspect that they are compromised.

I've tried picking up a new ambassador and installing them several times, but the above situation plays out again. It seems to be faction specific as when I tried picking up an ambassador from another faction(mayasura), they were inaugurated without any issues.

oops, guess I didn't fix that issue after all. Did you update the mod with an ambassador in your inventory by any chance?

This is easily solvable by using console commands to run "addItem deconomics_amb_yrxp", and installing that item. It'll arrest him, and then the system will work again like you are used to.
By the way, do not try to cheat in any more ambassadors after that one, cause it'll break stuff in any case other than the one you have.
Logged

Bulldog

  • Ensign
  • *
  • Posts: 22
    • View Profile
    • Email

oops, guess I didn't fix that issue after all. Did you update the mod with an ambassador in your inventory by any chance?

This is easily solvable by using console commands to run "addItem deconomics_amb_yrxp", and installing that item. It'll arrest him, and then the system will work again like you are used to.
By the way, do not try to cheat in any more ambassadors after that one, cause it'll break stuff in any case other than the one you have.

Ah I see, I didn't update recently but I did homebrew in ambassador support for another faction that was lacking it while I had Yuri's ambassador in my inventory, that seems like what might have caused that issue. Thanks for the help. that solved it.
Logged

Vex2

  • Ensign
  • *
  • Posts: 15
    • View Profile

Had an interesting issue pop up with the military/interstellar relay building.

Initially built them on a couple of my planets and no issues, worked as intended.
Later upgraded the relay on my main military base of the system I occupied into an interstellar relay before wandering off around the sector.
When I came back to do some colony management discovered that the relay bonus was stacking off itself on my main fleet base resulting in over 1000% fleet power and 900%+ on the other colonies in the system with relays.

https://i.imgur.com/S6TGyj4.png
https://i.imgur.com/mOO8iLA.png

Logged

SirHartley

  • Captain
  • ****
  • Posts: 480
    • View Profile

thanks for that report, it's a known issue and has been fixed for the next version!
For now, there is sadly no real way around it.
Logged

SirHartley

  • Captain
  • ****
  • Posts: 480
    • View Profile

This just in - there is a way around it. Remove the Alpha core from the High command and it stops happening.
You might have to shut down the Interstellar Relay before that to avoid a crash, but that doesn't always happen.
Logged

Chikanuk

  • Lieutenant
  • **
  • Posts: 94
    • View Profile

Dunno this is a know bug or something new, but at some point my salvage yards become a new colony in colony screen. Even with their own administrator. And then i click on this new "colony" it send me to the colony where this structure locate.
Logged

SirHartley

  • Captain
  • ****
  • Posts: 480
    • View Profile

that's just how the salvage yards function, without that the Yards wouldn't work alongside heavy industry.
Logged

S7

  • Ensign
  • *
  • Posts: 4
    • View Profile

Hi, Im getting a NullPointerException when im in the abandoned terraforming platform in the Corvus system. I've turned off all of my mods except for this one and it still persists in the text. Does this affect anything?
Logged

SirHartley

  • Captain
  • ****
  • Posts: 480
    • View Profile

Hi, Im getting a NullPointerException when im in the abandoned terraforming platform in the Corvus system. I've turned off all of my mods except for this one and it still persists in the text. Does this affect anything?

that's fixed for the next version already, thanks for the report nonetheless.
it doesn't affect anything at all, you can safley ignore it.
Logged

Pelops

  • Ensign
  • *
  • Posts: 10
    • View Profile

Hello, I just updated some mods after Version Checker warning and unfortunately I can no longer start my game if I take Extratential Lanestate in my Mods' list...

Would you have any solution plz ??
Logged

Aposkus

  • Ensign
  • *
  • Posts: 2
    • View Profile

Hello,
I came here to thank you for this great mod, since I really like the colony/empire aspects of the game. However, I have a QoL question:
Is there a possibility to allow VPC be automatically installed(like the AI-cores consumption on the supercomputer)? Since I have a lot of the chips, but I usually travel far away from my system its hard to constantly put each and everyone of them after one is used up.
Once again thanks for the mod.
Logged

SirHartley

  • Captain
  • ****
  • Posts: 480
    • View Profile

Hello, I just updated some mods after Version Checker warning and unfortunately I can no longer start my game if I take Extratential Lanestate in my Mods' list...

Would you have any solution plz ??

Considering this is the Industrial Evolution Mod thread - no, sorry.

Hello,
I came here to thank you for this great mod, since I really like the colony/empire aspects of the game. However, I have a QoL question:
Is there a possibility to allow VPC be automatically installed(like the AI-cores consumption on the supercomputer)? Since I have a lot of the chips, but I usually travel far away from my system its hard to constantly put each and everyone of them after one is used up.
Once again thanks for the mod.

Thanks, always nice to hear.

Hm, I'll think on that. The main issue I am facing is that the next update brings even more Markets/Storage things, and we are reaching a level where the UI does not support it anymore on low res screens.
I might make a shared storage with the Supercomputer, but I really can't promise anything - sorry!
Logged

Vocation

  • Ensign
  • *
  • Posts: 14
    • View Profile

Has anyone tried running this with Archean Order?

Playing with it right now.
Logged
Pages: 1 ... 15 16 [17] 18 19 ... 80