Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95.1a is out! (12/10/21); Blog post: Hyperspace Topography (10/12/22)

Pages: [1] 2

Author Topic: Crash to Desktop while Saving (Error figuring out MIRV spec details? - Or not?)  (Read 3001 times)

cathar

  • Lieutenant
  • **
  • Posts: 55
  • ludd is bae
    • View Profile

This seems to be were it all falls apart:

Spoiler
37615 [Thread-4] WARN  com.fs.starfarer.loading.WeaponSpreadsheetLoader  - Error figuring out MIRV spec details
java.lang.NullPointerException
   at com.fs.starfarer.loading.WeaponSpreadsheetLoader.Ò00000(Unknown Source)
   at com.fs.starfarer.loading.WeaponSpreadsheetLoader.o00000(Unknown Source)
   at com.fs.starfarer.loading.WeaponSpreadsheetLoader.Ò00000(Unknown Source)
   at com.fs.starfarer.loading.SpecStore.ÒO0000(Unknown Source)
   at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
[close]

Here's my modlist:
Spoiler
{"enabledMods": [
  "$$$_lightshow",
  "anotherportraitpack",
  "raccoonarms",
  "lw_autosave",
  "blackrock_driveyards",
  "CAS",
  "CombatAnalytics",
  "chatter",
  "timid_commissioned_hull_mods",
  "lw_radar",
  "lw_console",
  "istl_dam",
  "diableavionics",
  "DisassembleReassemble",
  "edshipyard",
  "gates_awakened",
  "hullmod_expansion",
  "interestingportraitspack",
  "Imperium",
  "lw_lazylib",
  "leadingPip",
  "ArkLeg",
  "luddenhance",
  "MagicLib",
  "Mayasuran Navy",
  "sun_new_beginnings",
  "nexerelin",
  "ORA",
  "TAR",
  "roider",
  "sun_ruthless_sector",
  "sad",
  "SCY",
  "SEEKER",
  "shadow_ships",
  "swp",
  "bonomel_skilledup",
  "speedUp",
  "sun_starship_legends",
  "Boggled Station Construction",
  "Sylphon_RnD",
  "tahlan",
  "THI",
  "TS_Coalition",
  "underworld",
  "US",
  "URW",
  "lw_version_checker",
  "toggleWeapons",
  "audio_plus",
  "shaderLib"
]}
[close]


  • I did a clean reinstall of Starsector and all the mods
  • I have had this issue before but it usually goes away when I change some graphicslib settings for better performance
  • Changed graphiclibs settings for better perfomance, didn't help
  • Updated my graphiccard drivers
  • Tried disabling various mods that have made problems for me before or are new (ED, all of Vayra)

Not sure where to go from here.
« Last Edit: December 13, 2019, 06:58:32 AM by cathar »
Logged

cathar

  • Lieutenant
  • **
  • Posts: 55
  • ludd is bae
    • View Profile
Re: Crash to Desktop while Saving (Error figuring out MIRV spec details)
« Reply #1 on: December 10, 2019, 12:02:14 PM »

Can no one help with this? Have I not provided enough information or something?

Spent many hours disabling/enabling mods up and down my modlist but I can't figure it out
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 21017
    • View Profile
Re: Crash to Desktop while Saving (Error figuring out MIRV spec details)
« Reply #2 on: December 10, 2019, 01:52:50 PM »

This error looks like it's caused by a mod not being updated to how mirv missile definitions work in the latest version of the game. I'm not sure which mod that would be, but the only thing I can really suggest is disabling mods until it goes away and you can figure out what causes the problem.

Also: the title of your post says the crash occurs while saving, but the actual error you've pasted is from a crash while the application is starting up - so, hmm, there's some disconnect here.
Logged

cathar

  • Lieutenant
  • **
  • Posts: 55
  • ludd is bae
    • View Profile
Re: Crash to Desktop while Saving (Error figuring out MIRV spec details)
« Reply #3 on: December 11, 2019, 01:20:09 AM »

Hi Alex, thank you for the reply (and the amazing game you are creating for all of us)

I will continue my quest activating/deactivating tonight then.

Also: the title of your post says the crash occurs while saving, but the actual error you've pasted is from a crash while the application is starting up - so, hmm, there's some disconnect here.

Didn't know that, it is however the only Nullpointer Exception I could find in the log. I read that that's the only thing I should post when asking a question here.

Is there another part of the log I can copy here more relevant to the issue? Last 30 or so lines or something?
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 21017
    • View Profile
Re: Crash to Desktop while Saving (Error figuring out MIRV spec details)
« Reply #4 on: December 11, 2019, 08:34:58 AM »

Ah, got it. A stack trace gets printed to the log when there's a crash (well, for most types of crashes), so yeah, it's definitely useful, but only if it's near/at the end of the log file. Otherwise, chances are it's not related to the crash and was printed to the log earlier for another reason (or from another crash), if that makes sense.

There's also another type of crash that generates hs_err_pid<some numbers>.log files. They'd be either in the Starsector/ or the starsector-core folder.


If the issue is what I suspect it is (purely based on it crashing during saving), I'd recommend:
Setting processMessagesWhileSavingOrLoading  in data/config/settings.json to false
Turning off GraphicsLib via its config file

Also: if you haven't already increased your memory allocation (by editing vmparams) to something like 4-6 gb, given your modlist, then disregard all of the above and just do that :)
Logged

cathar

  • Lieutenant
  • **
  • Posts: 55
  • ludd is bae
    • View Profile
Re: Crash to Desktop while Saving (Error figuring out MIRV spec details)
« Reply #5 on: December 13, 2019, 06:58:11 AM »

Quote
Setting processMessagesWhileSavingOrLoading  in data/config/settings.json to false
Turning off GraphicsLib via its config file
Tried both of these, did not work unfortunately.

Quote
Also: if you haven't already increased your memory allocation (by editing vmparams) to something like 4-6 gb, given your modlist, then disregard all of the above and just do that
I've set -Xms, -Xmx and -Yss to 8192. My PC has 32gb RAM so I could even increase it if necessary.


I did manage to get a playable modlist somehow. Spent many more hours de/activating various mods one by one and ended up with the same mod list as before, except I disabled the following mods:
  • Kadur Remnant
  • Tiandong
  • Tyrador
  • Underworld
  • Vayra's Ship Pack

Activating ANY of these causes the crash. Activating ANY of these but then deactivating some other Faction mod will result in a stable game; therefore I infer that it's probably not these specific mods but just the amount of factions I have added. To be honest I have not tested all the possible combinations of factions cause I'd like to play the game sometime as well.

I know other people run with the same or even larger amounts of factions so not sure what I am doing differently.



I can reliable reproduce the issue by doing this:

  • Start a new game with Nexerelin with no changes to its settings
  • Join any faction (tested with random, then always with Hegemony to have the same test case
  • Game generates sector and first auto save works
  • Once everything is loaded I save.
  • If that save works, I go into the simulation and fight a ship. After that I try and save again.

The game will reliably crash during either step 4 or 5.

The MIRV nullpointer exception is still there but as Alex mentioned probably not the cause of any of this. Here's the bottom lines of my Log:

Spoiler
110669 [Thread-4] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Loading stage 9 (exception)
110669 [Thread-4] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Loading stage 10 (exception)
110669 [Thread-4] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Loading stage 11 (exception)
110669 [Thread-4] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Loading stage 12 (exception)
110669 [Thread-4] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Loading stage 13 (exception)
110669 [Thread-4] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Loading stage 14 (exception)
110669 [Thread-4] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Loading stage 15 (exception)
110669 [Thread-4] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Loading stage 16 (exception)
110810 [Thread-4] INFO  exerelin.plugins.ExerelinModPlugin  - After game save
110878 [Thread-4] INFO  com.fs.starfarer.api.impl.campaign.events.OfficerManagerEvent  - Added officer at vayra_gehenna_tortugamarket, 36 total available
110888 [Thread-4] INFO  com.fs.starfarer.api.impl.campaign.intel.ProcurementMissionIntel  - Created ProcurementMissionIntel: heavy_machinery to Udana Station
111291 [Thread-4] INFO  ruthless_sector.CampaignScript  - Reload Penalty: 0.0
114604 [Thread-4] INFO  org.histidine.chatter.combat.ChatterCombatPlugin  - Chatter plugin initialized
114604 [Thread-4] INFO  data.scripts.plugins.SKR_moduleRetreatCleaner  - Another module retreat cleaner already running, suspending plugin
116662 [Thread-10] INFO  sound.oo0O  - Creating streaming player for music with id [steel_rain.ogg]
116663 [Thread-10] INFO  sound.null  - Playing music with id [steel_rain.ogg]
147077 [Thread-8] INFO  sound.oo0O  - Cleaning up music with id [steel_rain.ogg]
147195 [Thread-10] INFO  sound.null  - Playing music with id [Ambush.ogg]
148719 [Thread-4] INFO  exerelin.plugins.ExerelinModPlugin  - Before game save
148726 [Thread-4] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Saving to ..\\saves/save_SecondFerguson_2227600941335726813...
148727 [Thread-4] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Saving stage 1
148728 [Thread-4] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Saving stage 2
148728 [Thread-4] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Saving stage 3
149192 [Thread-14] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Saving progress: 0.0
[close]

Also PC specs for good measure (I don't know hardware so apologies if these are written down in a dumb way):
Intel i5-3570k
32gb RAM
NVIDIA Geforce GTX 670
Windows x64

I can play - just not with all the mods I'd like. If anyone has any other suggestions I'd love to hear them.
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 21017
    • View Profile

I'm assuming by -Yss you mean -Xss? You don't want to change that one; it's a different type of thing and I'd suggest setting it back to 1024k.

What about the hs_err_pid files I mentioned earlier? Given what's in the log (i.e. nothing to indicate a crash) I suspect those are present.

I'd also try updating your graphics drivers, btw. Solid chance that might help.
Logged

cathar

  • Lieutenant
  • **
  • Posts: 55
  • ludd is bae
    • View Profile

I'm assuming by -Yss you mean -Xss? You don't want to change that one; it's a different type of thing and I'd suggest setting it back to 1024k.

What about the hs_err_pid files I mentioned earlier? Given what's in the log (i.e. nothing to indicate a crash) I suspect those are present.

I'd also try updating your graphics drivers, btw. Solid chance that might help.


Xss, yes, my bad for the typo. Okay, I'll turn it back.

No hs_err_pid files in either folder.

Graphics driver update was the very first thing I did when this happened.
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 21017
    • View Profile

Ah, that's right, you mentioned the drivers in the OP, my bad.

Hmm. Maybe check the windows event viewer for any errors/warnings at the same time as the crashes happen? I don't remember ever seeing a situation where there's 1) no error in the log and 2) no hs_err_pid* file, that's... very unusual.

(Another thing worth trying: running the game in admin mode, and/or in compatibility mode for windows 95, XP, or 7...)
Logged

cathar

  • Lieutenant
  • **
  • Posts: 55
  • ludd is bae
    • View Profile

Compatibility modes did not help.


Windows Event viewer did turn up with something, it does seem to be related to the graphics drivers after all:

The following error shows up exactly at time of crashing:
Spoiler
The NVIDIA OpenGL driver has not been able to initialize a connection with the GPU. This might be due to out of memory error, an exhaustion of system resources or too many graphical applications running. The application will not render correctly. (pid=74$
[close]


Now I did some googling and it looks like a lot of people have this issue with Windows 10 and other Java based games (namely Minecraft, which I will get and see if I have the same issue there)
For a lot of people with this issue, reinstalling their drivers did not help, same as me.

For example:
https://answers.microsoft.com/en-us/insider/forum/all/opengl-suddenly-stop-working-in-windows-10-build/5052165a-50ba-402a-9f6f-95c645ae1185


For now I want to use my limited game time to actually play, to be honest. I can live with a few less content mods. The whole thing is extremely perplexing to me, especially since I'm not really a hardware/tech person.
If I have time and energy I will try out other versions of the graphic card drivers and see where it goes.

Thank you for all the help so far, Alex!
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 21017
    • View Profile

Thank you for the additional info, that's good to know!

(The suggestion in that thread - about reinstalling graphics drivers in compatibility mode - seems like it *might* work (though I personally wouldn't bet on it), but, yeah, totally understand if that's more than you want to get into. Beyond that, I'm not sure what else either of us can do; this seems like it's fairly clearly a "Windows 10 + OpenGL + drivers" issue. But, as long as you're able to get around it by using fewer mods...)
Logged

cathar

  • Lieutenant
  • **
  • Posts: 55
  • ludd is bae
    • View Profile

I will definitely try this when I finish this run and go for the next, and I'll hopefully remember to update this thread so someone else can find a solution if I do.

Thanks again for your help.
Logged

MesoTroniK

  • Admiral
  • *****
  • Posts: 1720
  • I am going to destroy your ships
    • View Profile

That is a lot of mods for a GTX 670... Presuming it is the 2gb version of the card (which is *far* more common) and not the 4gb.

Have you checked VRAM usage?

cathar

  • Lieutenant
  • **
  • Posts: 55
  • ludd is bae
    • View Profile

Well I was hoping a machine that can run new games (Borderlands 3 the most recent) with medium-ish settings and a modded to hell and back Skyrim without issues could handle a few more spaceships but I admit that I don't really know how any of this works.

What I find curious is that there is such a clear cut off point. No matter which content mod I add, this is the cap. For example, I tried disabling Diable, which adds a lot of ships, fighters, weapons and systems and enabling Underworld, which has fewer ships and no systems and everything runs fine. Similar test I did was with DME and Kadur Remnant. DME has lots of ships and systems, Kadur a few ships. In my limited understanding, a larger content mod would have a larger impact than a smaller one?

Again, no clue how it works, but it seems strange to me. You'd assume the point of breakage would come based on number of assets in the game, not just the arbitrary number of content mods installed.

I will check which version of the graphics card I have, and VRAM usage, tonight.
Logged

cathar

  • Lieutenant
  • **
  • Posts: 55
  • ludd is bae
    • View Profile

The card is indeed 2gb version of the GTX 670.


GPU does seem to have this weird spike at the moment of saving the game. It is steady at maximum 20% usage before that.

[attachment deleted by admin]
Logged
Pages: [1] 2