Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21)

Pages: 1 [2]

Author Topic: [0.95a] Weapon Arcs 1.4.0  (Read 61043 times)

evilphish

  • Ensign
  • *
  • Posts: 8
    • View Profile
Re: [0.9a] Weapon Arcs 1.2.1
« Reply #15 on: December 17, 2018, 04:24:34 AM »

Small bug report regarding case mixups. Under Linux with a case sensitive filesystem your mod fails to load as it can not find the version file.

In your mod folder:
Code
weaponarcs.version
should be named
Code
WeaponArcs.version

cheers
Phishy

Logged

Archigo

  • Ensign
  • *
  • Posts: 14
    • View Profile
Re: [0.9a] Weapon Arcs 1.2.1
« Reply #16 on: December 17, 2018, 07:31:52 AM »

1. Automatically turn off/on vanilla weapon arcs, (even if hotkey is changed) and turn on/off modded ones, every battle.
2. Change and/or toggle transparency of modded arcs.
3. Make .cfg file for configuring those functions. Maybe also turning on arcs for each weapon group separately. Maybe make currently used arc less transparent while other stay transparent.
4. (Is it even possible) Show arcs for hostile/friendly ships with a hotkey for each group.

They're all possible, even number 4. I will probably not get around to doing these any time soon, but if you open a pull request on the github, I will happily merge your updates into the mod :)

I agree with you that the features of this mod would make a lot of sense to have as part of the base game.

Also implemented version checker support.

I'm on linux which has case sensitive filenames, and I encountered an error until I changed the filename "weaponarcs.version" to "WeaponArcs.version". Cheers!

Thanks for spotting that! :)
Logged

Thyrork

  • Ensign
  • *
  • Posts: 49
  • Give more then you take.
    • View Profile
Re: [0.9a] Weapon Arcs 1.3.0
« Reply #17 on: February 13, 2019, 08:31:38 AM »

Quote
696681 [Thread-4] INFO  org.histidine.chatter.combat.ChatterCombatPlugin  - Chatter plugin initialized
696681 [Thread-4] INFO  com.fs.starfarer.loading.LoadingUtils  - Loading JSON from [weapon-arcs-settings.json]
698906 [Thread-4] INFO  data.scripts.WeaponArcsPlugin  - Shipname: RSS Red Dwarf
699365 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
   at data.scripts.WeaponArcsPlugin.advance(WeaponArcsPlugin.java:96)
   at com.fs.starfarer.title.C.K$Oo.o00000(Unknown Source)
   at com.fs.starfarer.combat.super.OoOO.o00000(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advanceInner(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

Upon entering combat. Let me know if you need the full mod list. Repeatable crash upon entering the same combat. Ill make a backup of the save.
« Last Edit: February 13, 2019, 08:34:01 AM by Thyrork »
Logged
Bio engineering starship mods is extremely Safe. I did the math.

FreedomFighter

  • Commander
  • ***
  • Posts: 140
  • Cat girl can into space or die trying
    • View Profile
Re: [0.9a] Weapon Arcs 1.3.0
« Reply #18 on: February 13, 2019, 09:12:43 AM »

Having the same problem with 1.3.0. I was using the previous version and everything work fine until I updated it to the current one.
Logged
Broken English specialist

Archigo

  • Ensign
  • *
  • Posts: 14
    • View Profile
Re: [0.9a] Weapon Arcs 1.3.0
« Reply #19 on: February 13, 2019, 09:17:32 AM »

I just posted 1.3.1, where it should be fixed. Thanks for reporting.
Logged

Thyrork

  • Ensign
  • *
  • Posts: 49
  • Give more then you take.
    • View Profile
Re: [0.9a] Weapon Arcs 1.3.1
« Reply #20 on: February 13, 2019, 02:29:09 PM »

loaded the save and everything was fine.
Logged
Bio engineering starship mods is extremely Safe. I did the math.

Randall Hynes

  • Ensign
  • *
  • Posts: 7
    • View Profile
    • Email
Crash with Diable Avionics Ship System
« Reply #21 on: May 25, 2019, 07:04:45 AM »

Very often, I'll crash when using the Pocket Gust's ship system (Assume Wing Control) from Diable Avionics, and starsector.log shows this at the very bottom.

Spoiler
761917 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
    at data.scripts.WeaponArcsPlugin.advance(WeaponArcsPlugin.java:89)
    at com.fs.starfarer.title.Object.float$Oo.o00000(Unknown Source)
    at com.fs.starfarer.combat.oOOO.B.super(Unknown Source)
    at com.fs.starfarer.combat.CombatEngine.advanceInner(Unknown Source)
    at com.fs.starfarer.combat.CombatEngine.advance(Unknown Source)
    at com.fs.starfarer.combat.CombatState.traverse(Unknown Source)
    at com.fs.state.AppDriver.begin(Unknown Source)
    at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
    at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source
[close]

I tested this on a brand new campaign, without displaying any additional weapon groups, and it didn't crash in the simulator, but it did when in a real battle.

I've had it crash inside the simulator before, though, but I don't know if I was displaying weapon groups at the time.
Logged

Archigo

  • Ensign
  • *
  • Posts: 14
    • View Profile
Re: Crash with Diable Avionics Ship System
« Reply #22 on: March 30, 2021, 08:32:53 AM »

Very often, I'll crash when using the Pocket Gust's ship system (Assume Wing Control) from Diable Avionics, and starsector.log shows this at the very bottom.

Spoiler
761917 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
    at data.scripts.WeaponArcsPlugin.advance(WeaponArcsPlugin.java:89)
    at com.fs.starfarer.title.Object.float$Oo.o00000(Unknown Source)
    at com.fs.starfarer.combat.oOOO.B.super(Unknown Source)
    at com.fs.starfarer.combat.CombatEngine.advanceInner(Unknown Source)
    at com.fs.starfarer.combat.CombatEngine.advance(Unknown Source)
    at com.fs.starfarer.combat.CombatState.traverse(Unknown Source)
    at com.fs.state.AppDriver.begin(Unknown Source)
    at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
    at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source
[close]

I tested this on a brand new campaign, without displaying any additional weapon groups, and it didn't crash in the simulator, but it did when in a real battle.

I've had it crash inside the simulator before, though, but I don't know if I was displaying weapon groups at the time.

I realize it's been two years.. but hopefully this crash has been fixed in the new version 1.4.0 :)
Logged

ck68

  • Ensign
  • *
  • Posts: 2
    • View Profile
    • Email
Re: [0.95a] Weapon Arcs 1.4.0
« Reply #23 on: April 04, 2021, 08:47:12 PM »

Just to let you know download link needs to be updated, github version is up to date while download link is 1.3.1
Logged

Archigo

  • Ensign
  • *
  • Posts: 14
    • View Profile
Re: [0.95a] Weapon Arcs 1.4.0
« Reply #24 on: April 04, 2021, 11:24:53 PM »

Just to let you know download link needs to be updated, github version is up to date while download link is 1.3.1

The download is pointing to the master branch, and when I use it, I get 1.4.0.

Not sure how you're getting 1.3.1.
Logged

Lprsti99

  • Ensign
  • *
  • Posts: 14
    • View Profile
    • Email
Re: [0.95a] Weapon Arcs 1.4.0
« Reply #25 on: April 09, 2021, 03:12:17 PM »

Just to let you know download link needs to be updated, github version is up to date while download link is 1.3.1

The download is pointing to the master branch, and when I use it, I get 1.4.0.

Not sure how you're getting 1.3.1.

Mod_info.json correctly shows 1.4.0, but weaponarcs.version is still returning 1.3.1, causing version checker to think it's the old version. 
Logged

Archigo

  • Ensign
  • *
  • Posts: 14
    • View Profile
Re: [0.95a] Weapon Arcs 1.4.0
« Reply #26 on: April 09, 2021, 03:35:25 PM »

Mod_info.json correctly shows 1.4.0, but weaponarcs.version is still returning 1.3.1, causing version checker to think it's the old version. 

Should be fixed now
Logged
Pages: 1 [2]