Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.97a is out! (02/02/24); New blog post: Codex Overhaul (05/11/24)

Author Topic: Game won't start up anymore  (Read 1980 times)

jacobgr43

  • Ensign
  • *
  • Posts: 21
    • View Profile
Game won't start up anymore
« on: March 08, 2012, 06:23:38 AM »

i've downloaded the .51 update and now my game wont come on anymore, once the loading bar fills up it just displays this error.

Fatal: Error compiling [data.scripts.world.SectorGen]
Cause: compiling unit "data/scripts/world/SectorGen.java"
Check starfarer.log for more info

can anyone tell me whats wrong and how to fix it?
Logged

XpanD

  • Captain
  • ****
  • Posts: 380
    • View Profile
Re: Game won't start up anymore
« Reply #1 on: March 08, 2012, 06:27:00 AM »

Do you have any mods installed? Try disabling them one-by-one if so, as some mods will conflict with the new version. If that still doesn't fix it, try re-installing the game. And if that still fails, let me know and I'll put up a private download with the problematic files included for you. :P
Logged

jacobgr43

  • Ensign
  • *
  • Posts: 21
    • View Profile
Re: Game won't start up anymore
« Reply #2 on: March 08, 2012, 06:33:39 AM »

Thanks for the advice it seems my TT station mod was conflicting with the new version
Logged

Upgradecap

  • Admiral
  • *****
  • Posts: 5422
  • CEO of the TimCORP
    • View Profile
Re: Game won't start up anymore
« Reply #3 on: March 08, 2012, 06:34:50 AM »

This really is mod dependant, so tell which mods you have. The TimCORP mod and the junk pirates mod are NOT compatible with .51a
Logged

XpanD

  • Captain
  • ****
  • Posts: 380
    • View Profile
Re: Game won't start up anymore
« Reply #4 on: March 08, 2012, 06:37:40 AM »

Yeah, 0.51a now has a built in Tri-Tachyon station (and a Pirate one!). The original TT mod has now been turned into a full-on Gun Runners mod. :)

Anyways, good to hear it's working again. Have fun!
Logged