Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.97a is out! (02/02/24); New blog post: Planet Search Overhaul (07/13/24)

Pages: 1 ... 49 50 [51]

Author Topic: [0.96-RC8] Legacy of Arkgneisis 1.9.12 [5/12/23]  (Read 610860 times)

hidefreek

  • Commander
  • ***
  • Posts: 113
    • View Profile
Re: [0.96-RC8] Legacy of Arkgneisis 1.9.12 [5/12/23]
« Reply #750 on: May 24, 2024, 03:06:27 AM »

Another error is Index out.
This automatically occurs when try to click on "Weapon Groups" on any "Exodus initiative" ships.
Perharps the problem cause by me install three LoA mods at the same time.
:Legacy-of-Arkgneisis-DEV, Legacy of Arkgneisis bootleg, Legacy of Arkgneisis Alice blue

13805255 [Thread-2] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.ArrayIndexOutOfBoundsException: Index 7 out of bounds for length 7
java.lang.ArrayIndexOutOfBoundsException: Index 7 out of bounds for length 7
   at com.fs.starfarer.coreui.refit.wgd2.A.updateCheckboxes(Unknown Source) ~[port_obf.jar:?]
   at com.fs.starfarer.coreui.refit.wgd2.A.createRow(Unknown Source) ~[port_obf.jar:?]
   at com.fs.starfarer.coreui.refit.wgd2.A.<init>(Unknown Source) ~[port_obf.jar:?]
   at com.fs.starfarer.coreui.refit.wgd2.WeaponGroupDialogV2.<init>(Unknown Source) ~[port_obf.jar:?]
   at com.fs.starfarer.coreui.refit.S.actionPerformed(Unknown Source) ~[port_obf.jar:?]
   at com.fs.starfarer.ui.o0O0.buttonPressed(Unknown Source) ~[port_obf.jar:?]
   at com.fs.starfarer.ui.int.Ò00000(Unknown Source) ~[port_obf.jar:?]
   at com.fs.starfarer.ui.int.processInput(Unknown Source) ~[port_obf.jar:?]
   at com.fs.starfarer.ui.W.o00000(Unknown Source) ~[port_obf.jar:?]
   at com.fs.starfarer.BaseGameState.traverse(Unknown Source) ~[port_obf.jar:?]
   at com.fs.state.AppDriver.begin(Unknown Source) ~[port.common_obf.jar:?]
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source) ~[port_obf.jar:?]
   at com.fs.starfarer.StarfarerLauncher.super(Unknown Source) ~[port_obf.jar:?]
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source) ~[port_obf.jar:?]
   at java.base/java.lang.Thread.run(Thread.java:1575) [?:?]
Logged

A_Random_Dude

  • Captain
  • ****
  • Posts: 269
    • View Profile
Re: [0.96-RC8] Legacy of Arkgneisis 1.9.12 [5/12/23]
« Reply #751 on: May 24, 2024, 04:28:13 AM »

Told you it was a bad idea.
Logged

Axelord

  • Ensign
  • *
  • Posts: 23
  • Murderhobo In Space
    • View Profile
Re: [0.96-RC8] Legacy of Arkgneisis 1.9.12 [5/12/23]
« Reply #752 on: June 17, 2024, 11:41:54 PM »

God, I miss you!
The (P) Cruiser I forget the name of was always one of the early ships I vied for intensely. The unique BigMac was also a favorite flagship.
Logged
High Alpha Best Alpha - Can't die if all your enemies die in one salvo, and damn the poor tech who had his hand on a power conduit at that moment.

MnHebi

  • Ensign
  • *
  • Posts: 39
  • Updater of Mods, Seeker of Archives
    • View Profile
Re: [0.96-RC8] Legacy of Arkgneisis 1.9.12 [5/12/23]
« Reply #753 on: June 19, 2024, 04:51:48 AM »

Currently, LoA has some float ERROR.
Which triggers when installing AI core in any of its industries. (Especially, our beloved Void Extraction)
Histidine said the mod needs a proper update to the 0.97a version.
Until then, try not to put any AI core on it.
In reference to this, I recompiled the DEV update, and it according to testing by a user it seems to have fixed the issue, here is the replacement JAR for the DEV UPDATE.
https://drive.google.com/file/d/1fKZQenfSZxL8A4AjpTnR5pjrGyfgxFhx/view?usp=sharing
Simply updated all MagicLib includes(except in files that had AddTrailMemberAdvanced cause I can't figure out which one in the updated version is the right one)...also did a change around the administrator abilities in modplugin so it gives 2 IndEvo versions of administrator skills that no longer exist in Starsector that the original version called to be added to administrators.


here is a recompiled jar for the RELEASE VERSION, works just fine I tested, void extraction accepted AI core without crashing.
https://drive.google.com/file/d/1KRJuxKvI7d9HzQBuWUm5I5OwZlld6Bdc/view?usp=sharing

[EDIT]
IF YOU DOWNLOADED THESE BEFORE JUNE 25th 2024 please redownload, there was a typo in the admin skill names, also the mod used an potentially crash causing method of adding skills with certain mod combinations. Fixed for both DEV and RELEASE.
« Last Edit: June 25, 2024, 03:28:38 AM by MnHebi »
Logged

crash7ds

  • Ensign
  • *
  • Posts: 31
    • View Profile
Re: [0.96-RC8] Legacy of Arkgneisis 1.9.12 [5/12/23]
« Reply #754 on: July 15, 2024, 10:43:55 PM »

So assuming I have the 0.97a version of the game and download the LoA 1.9.12 from the OP, I just have to drop this aforementioned release version jar recompile in "jars" of the mod, overwrite, and the mod will work, or is there more I must do past that?
Logged
Pages: 1 ... 49 50 [51]