Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: Skill Changes, Part 2 (07/15/21)

Author Topic: UI Elements moving offscreen  (Read 1445 times)

Serenitis

  • Admiral
  • *****
  • Posts: 1138
    • View Profile
UI Elements moving offscreen
« on: May 21, 2017, 12:54:34 PM »

This is probably the weirdest thing I have seen SS do so far.
It is (or seems to be) specific to the Ex Vis system in the Interstellar Imperium mod.

When the player fleet arrives in the vicinity of either Jump Point Caelestis or Pulvis/Saltus Divinus, this happens:

Spoiler


[close]

All the UI elements are shunted off to the right, and mostly off the screen.
The outline for the radar display moves in a random direction each time.
Pressing <escape> to bring up the menu yields and empty box.

Spoiler
[close]

And yet, all the UI elements from the toolbar and escape menu are still fully functional. Just invisible.
All the other screens (intel/refit/etc.) seem unaffected.
The log shows no (obvious) errors.
Saving the game once the UI has moved will result in the UI being like that for the rest of the game, even if quit and re-loaded.
Quitting to the main menu and reloading from a point before entering Ex Vis will display normal behaviour.

Entering Ex Vis via any other jump point will behave normally, but the UI will derp as soon as you travel near enough to either Caelestis or Pulvis.
I have no idea if this is a problem with II or not, but no other system has displayed this behaviour.

I've backed up two separate saves of this happening, and have a clean log file of starting the game, breaking the UI then quitting. (If that's of any use.)

Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 18940
    • View Profile
Re: UI Elements moving offscreen
« Reply #1 on: May 21, 2017, 01:07:11 PM »

Thanks! This is a vanilla bug, should be fixed for .1. Not sure why it'd show up in an II system - had only seen it show up when moving outside the Sector in hyperspace - but in any case, *exactly* the same symptoms.
Logged

Serenitis

  • Admiral
  • *****
  • Posts: 1138
    • View Profile
Re: UI Elements moving offscreen
« Reply #2 on: May 21, 2017, 01:19:37 PM »

That's cool.
Weird as hell it would pick a very specific part of the same system, over two seperate games though.
(Sorry D.R, I'm not deliberately trying to give you palpitations with all these reports.)

This guy might have found the same problem: http://fractalsoftworks.com/forum/index.php?topic=12422.0
Logged

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2696
    • View Profile
    • Sc2Mafia
    • Email
Re: UI Elements moving offscreen
« Reply #3 on: May 21, 2017, 01:54:36 PM »

Ex Vis has a terrain feature that subclasses Hyperspace, so it's not a surprise.
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 18940
    • View Profile
Re: UI Elements moving offscreen
« Reply #4 on: May 21, 2017, 02:04:46 PM »

Ahh, that'd do it.
Logged

dogamusprime

  • Ensign
  • *
  • Posts: 25
    • View Profile
Re: UI Elements moving offscreen
« Reply #5 on: May 23, 2017, 03:02:45 PM »

Really glad to see this post as I was having the same issue.
Logged