Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: Skill Changes, Part 2 (07/15/21)

Author Topic: Crash with Starsector+  (Read 2430 times)

UsurpTheThrone

  • Ensign
  • *
  • Posts: 3
    • View Profile
    • Email
Crash with Starsector+
« on: July 05, 2016, 04:53:10 PM »

I've been playing alot of Starsector 7.0.2a lately and decided to download some Mods to expand the experience. I downloaded Nexerelin 0.7.5c, LazyLib 2.1, GraphisLib 1.0.2 which all work and a few Faction Mods to use, but Starsector+ 3.5.2 has been giving me a specific error while starting up.

Quote
22697 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Ship hull spec [ssp_alastor] not found!
java.lang.RuntimeException: Ship hull spec [ssp_alastor] not found!
   at com.fs.starfarer.loading.OO0O.o00000(Unknown Source)
   at com.fs.starfarer.loading.SpecStore.super(Unknown Source)
   at com.fs.starfarer.loading.ShipHullSpecLoader.Ò00000(Unknown Source)
   at com.fs.starfarer.loading.ShipHullSpecLoader.Ó00000(Unknown Source)
   at com.fs.starfarer.loading.SpecStore.ø00000(Unknown Source)
   at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

I know it can't find the Alastor ship hull spec file, but I have no idea why or whether I've just forgotten something or where to go from here.
Logged

Histidine

  • Admiral
  • *****
  • Posts: 3347
    • View Profile
    • Bitbucket profile
    • Email
Re: Crash with Starsector+
« Reply #1 on: July 05, 2016, 06:18:04 PM »

I can't say why the error is occurring here specifically, but load Ship & Weapons Pack (which has the Alastor) as well.
Logged

UsurpTheThrone

  • Ensign
  • *
  • Posts: 3
    • View Profile
    • Email
Re: Crash with Starsector+
« Reply #2 on: July 05, 2016, 06:26:32 PM »

Tried downloading the Ship and Weapons Packs and applying it along with Starsector+, but now it seems like there are some ship systems missing.

Quote
27907 [Thread-4] INFO  com.fs.starfarer.loading.SpecStore  - Applying data from ship_systems.csv to [shieldbreaker]
27907 [Thread-4] INFO  com.fs.starfarer.loading.SpecStore  - Applying data from ship_systems.csv to [phasetunneler]
27908 [Thread-4] INFO  com.fs.starfarer.loading.SpecStore  - Applying data from ship_systems.csv to [forceburst]
27908 [Thread-4] INFO  com.fs.starfarer.loading.SpecStore  - Applying data from ship_systems.csv to [forceimpeder]
27909 [Thread-4] INFO  com.fs.starfarer.loading.SpecStore  - Applying data from ship_systems.csv to [cristariumdrones]
27910 [Thread-4] INFO  com.fs.starfarer.loading.SpecStore  - Applying data from ship_systems.csv to [prismaticray]
27910 [Thread-4] INFO  com.fs.starfarer.loading.SpecStore  - Applying data from ship_systems.csv to [sonido]
27911 [Thread-4] INFO  com.fs.starfarer.loading.SpecStore  - Applying data from ship_systems.csv to [omegadrive]
27911 [Thread-4] ERROR com.fs.starfarer.loading.SpecStore  - Ship system [drone_lowetech_sensor] not found in ship_systems.csv
27912 [Thread-4] ERROR com.fs.starfarer.loading.SpecStore  - Ship system [drone_terminatorx2] not found in ship_systems.csv
27912 [Thread-4] ERROR com.fs.starfarer.loading.SpecStore  - Ship system [inferniumdrive] not found in ship_systems.csv
27912 [Thread-4] ERROR com.fs.starfarer.loading.SpecStore  - Ship system [drone_disco_ball] not found in ship_systems.csv
27913 [Thread-4] ERROR com.fs.starfarer.loading.SpecStore  - Ship system [piratecloak] not found in ship_systems.csv
28254 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Fatal: ship_systems.csv is missing systems
java.lang.RuntimeException: Fatal: ship_systems.csv is missing systems
   at com.fs.starfarer.loading.SpecStore.ÓO0000(Unknown Source)
   at com.fs.starfarer.loading.SpecStore.ø00000(Unknown Source)
   at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

Frustrating since all I wanted to do was expand my playtime and experience  :-\
Logged

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2700
    • View Profile
    • Sc2Mafia
    • Email
Re: Crash with Starsector+
« Reply #3 on: July 05, 2016, 08:52:55 PM »

You have an extremely messed up install of the game and/or mods.  Those errors should not be happening; SS+ doesn't include any references to those systems or hulls.

I suggest you delete everything and start over.
« Last Edit: July 05, 2016, 08:54:26 PM by Dark.Revenant »
Logged

UsurpTheThrone

  • Ensign
  • *
  • Posts: 3
    • View Profile
    • Email
Re: Crash with Starsector+
« Reply #4 on: July 06, 2016, 10:58:10 PM »

Yeah I probably will, annoying though. Thanks for your help guys!
Logged