Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: A Tale of Two Tech Levels (05/28/21)

Author Topic: Hiigarian Descendants, Bushi, and Kadur Theocracy 7.2a not working with nexrelin  (Read 2788 times)

samsaq

  • Ensign
  • *
  • Posts: 40
    • View Profile

Am using all faction mods for nexrelin and most general quality of life mods,(version checker, ect) as well as a couple misc mods such as autonomous ships or Steiner foundation.
When I launch the game with these three mods, which, as a homewolrd fan I very much want to use, I got this error on my starsector log, any ideas as to what I did wrong?
here it is:
117285 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
   at java.util.ArrayList.rangeCheck(Unknown Source)
   at java.util.ArrayList.get(Unknown Source)
   at com.fs.starfarer.loading.scripts.ScriptStore.new(Unknown Source)
   at com.fs.starfarer.settings.StarfarerSettings.super(Unknown Source)
   at com.fs.starfarer.launcher.ModManager.getEnabledModPlugins(Unknown Source)
   at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

As far as I can see the three mods I am trying to use, whose op is here: http://fractalsoftworks.com/forum/index.php?topic=10555.0
are compatible with nexrelin, and 0.7.2a, but are seemingly incompatible with one of the faction mods listed compatible with nexrelin, or another mod that I am using.
And, while I have some coding experience with java (relatively minimal) it seems like some sort of number error, or such, where something is breaking the logic, I just dunno what that would be in starsector.
Logged

Midnight Kitsune

  • Admiral
  • *****
  • Posts: 2784
  • Your Friendly Forum Friend
    • View Profile

Am using all faction mods for nexrelin and most general quality of life mods,(version checker, ect) as well as a couple misc mods such as autonomous ships or Steiner foundation.
When I launch the game with these three mods, which, as a homewolrd fan I very much want to use, I got this error on my starsector log, any ideas as to what I did wrong?
here it is:
117285 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
   at java.util.ArrayList.rangeCheck(Unknown Source)
   at java.util.ArrayList.get(Unknown Source)
   at com.fs.starfarer.loading.scripts.ScriptStore.new(Unknown Source)
   at com.fs.starfarer.settings.StarfarerSettings.super(Unknown Source)
   at com.fs.starfarer.launcher.ModManager.getEnabledModPlugins(Unknown Source)
   at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

As far as I can see the three mods I am trying to use, whose op is here: http://fractalsoftworks.com/forum/index.php?topic=10555.0
are compatible with nexrelin, and 0.7.2a, but are seemingly incompatible with one of the faction mods listed compatible with nexrelin, or another mod that I am using.
And, while I have some coding experience with java (relatively minimal) it seems like some sort of number error, or such, where something is breaking the logic, I just dunno what that would be in starsector.
Here is the solution: Go into your mods folder, find these three mods, delete them first from your computer and then from your memory. They are broken, OP s*** tier mods that don't stick to the source material (In the casr of Hiigarans), the author is about as helpful as Comcast or EA tech support, and they will never be supported by superior mods like Dynasector
Logged
Help out MesoTroniK, a modder in need

2021 is 2020 won
2022 is 2020 too

Drglord

  • Lieutenant
  • **
  • Posts: 79
    • View Profile

Yeah i second that . Guy told me they were compatible when they were crearly not mate...
Logged

samsaq

  • Ensign
  • *
  • Posts: 40
    • View Profile

According to a response I just got on the OP, you must use java 8 jre instead of java 7 that is typically used for the 2GB+ memory allocation fix, so if you want to play with these, do try that.(it also makes the game less stable apparently) I'll be trying it when my current nex campaign is over.
Logged