Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: A Tale of Two Tech Levels (05/28/21)

Author Topic: [solved] Fatal: Spec of class error.  (Read 1980 times)

Alphascrub

  • Commander
  • ***
  • Posts: 149
    • View Profile
    • Email
[solved] Fatal: Spec of class error.
« on: April 28, 2016, 12:08:51 AM »

Kind of stumped here. I attempted a fresh install and did all the proper alterations to memory and re-downloaded my mod files. I still seem to be getting this error message.

Fatal: Spec of class [come.fs.starfarer.loading.specs.Q] with id [moblie_headquarters] not found
Check starsector.log for more info.

log info

java.lang.RuntimeException: Spec of class [com.fs.starfarer.loading.specs.Q] with id [mobile_headquarters] not found
   at com.fs.starfarer.loading.SpecStore.super(Unknown Source)
   at com.fs.starfarer.loading.specs.HullVariantSpec.getAllMods(Unknown Source)
   at com.fs.starfarer.campaign.fleet.FleetMember.updateStats(Unknown Source)
   at com.fs.starfarer.campaign.fleet.FleetMember.init(Unknown Source)
   at com.fs.starfarer.campaign.fleet.FleetMember.<init>(Unknown Source)
   at com.fs.starfarer.campaign.fleet.FleetMember.<init>(Unknown Source)
   at com.fs.starfarer.campaign.CampaignEngine.createFleetMember(Unknown Source)
   at com.fs.starfarer.api.impl.campaign.fleets.FleetFactoryV2.addToFleet(FleetFactoryV2.java:622)
   at com.fs.starfarer.api.impl.campaign.fleets.FleetFactoryV2.addRandomShips(FleetFactoryV2.java:583)
   at com.fs.starfarer.api.impl.campaign.fleets.FleetFactoryV2.createFleet(FleetFactoryV2.java:101)
   at com.fs.starfarer.api.impl.campaign.fleets.EconomyFleetManager.createTradeFleet(EconomyFleetManager.java:747)
   at com.fs.starfarer.api.impl.campaign.fleets.EconomyFleetManager.advance(EconomyFleetManager.java:515)
   at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
   at com.fs.starfarer.campaign.save.CampaignGameManager.o00000(Unknown Source)
   at com.fs.starfarer.title.TitleScreenState.dialogDismissed(Unknown Source)
   at com.fs.starfarer.ui.M.dismiss(Unknown Source)
   at com.fs.starfarer.ui.impl.I.dismiss(Unknown Source)
   at com.fs.starfarer.campaign.save.if.actionPerformed(Unknown Source)
   at com.fs.starfarer.ui.interfacesuper.o00000(Unknown Source)
   at com.fs.starfarer.ui.H.processInput(Unknown Source)
   at com.fs.starfarer.ui.U.super(Unknown Source)
   at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)


I think there might be a conflict somewhere... I don't know.
I also wonder if this might have something to do with the fact that for some reason whenever I edit vamprams I have to use the batch file to start the game. Sorry I really kind of lack knowledge about this stuff and Im not having any luck with basic google searches.


Herp derp stickie pretty much tells me whats wrong in the comments. NGO conflict with dynasector.
« Last Edit: April 28, 2016, 12:18:37 AM by Alphascrub »
Logged