Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Pages: 1 ... 9 10 [11] 12 13 ... 16

Author Topic: [0.95.1a] GraphicsLib 1.6.1  (Read 416874 times)

Reavenant

  • Ensign
  • *
  • Posts: 19
    • View Profile
Re: [0.95a] GraphicsLib 1.5.0
« Reply #150 on: March 29, 2021, 03:29:19 AM »

With the newest Graphicslib activated I receive the following crash at startup:

55581 [Thread-3] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Error loading [data/lights/config/modFiles/TADA_light_data.csv] resource, not found in [D:\Games\Starsector\starsector-core\..\mods\Lightshow,D:\Games\Starsector\starsector-core\..\mods\SS-armaa-1.4.3b,D:\Games\Starsector\starsector-core\..\mods\Autosave,D:\Games\Starsector\starsector-core\..\mods\Better Colonies,D:\Games\Starsector\starsector-core\..\mods\CaptureCrew,D:\Games\Starsector\starsector-core\..\mods\Caymon's Ship Pack,D:\Games\Starsector\starsector-core\..\mods\Combat Chatter,D:\Games\Starsector\starsector-core\..\mods\Commissioned Crews,D:\Games\Starsector\starsector-core\..\mods\DIABLEAVIONICS,D:\Games\Starsector\starsector-core\..\mods\Hegemony Expeditionary Auxiliary,D:\Games\Starsector\starsector-core\..\mods\HTE,D:\Games\Starsector\starsector-core\..\mods\Kadur Remnant,D:\Games\Starsector\starsector-core\..\mods\LazyLib,D:\Games\Starsector\starsector-core\..\mods\Leading Pip,D:\Games\Starsector\starsector-core\..\mods\MagicLib,D:\Games\Starsector\starsector-core\..\mods\OldHyperion,D:\Games\Starsector\starsector-core\..\mods\ORA,D:\Games\Starsector\starsector-core\..\mods\Persean-Chronicles-2.0.1,D:\Games\Starsector\starsector-core\..\mods\tahlan-scalartech,D:\Games\Starsector\starsector-core\..\mods\SCY,D:\Games\Starsector\starsector-core\..\mods\SEEKER_UC,D:\Games\Starsector\starsector-core\..\mods\SpeedUp,D:\Games\Starsector\starsector-core\..\mods\Supply Forging,D:\Games\Starsector\starsector-core\..\mods\tahlan,D:\Games\Starsector\starsector-core\..\mods\Exalted,D:\Games\Starsector\starsector-core\..\mods\FED,D:\Games\Starsector\starsector-core\..\mods\Torchships,D:\Games\Starsector\starsector-core\..\mods\Transfer All Items,D:\Games\Starsector\starsector-core\..\mods\UnknownSkies,D:\Games\Starsector\starsector-core\..\mods\UpgradedRotaryWeapons,D:\Games\Starsector\starsector-core\..\mods\Vayra's Ship Pack,D:\Games\Starsector\starsector-core\..\mods\XhanEmpire,D:\Games\Starsector\starsector-core\..\mods\Audio Plus,D:\Games\Starsector\starsector-core\..\mods\prv Starworks,D:\Games\Starsector\starsector-core\..\mods\GraphicsLib,../starfarer.res/res,CLASSPATH]
java.lang.RuntimeException: Error loading [data/lights/config/modFiles/TADA_light_data.csv] resource, not found in [D:\Games\Starsector\starsector-core\..\mods\Lightshow,D:\Games\Starsector\starsector-core\..\mods\SS-armaa-1.4.3b,D:\Games\Starsector\starsector-core\..\mods\Autosave,D:\Games\Starsector\starsector-core\..\mods\Better Colonies,D:\Games\Starsector\starsector-core\..\mods\CaptureCrew,D:\Games\Starsector\starsector-core\..\mods\Caymon's Ship Pack,D:\Games\Starsector\starsector-core\..\mods\Combat Chatter,D:\Games\Starsector\starsector-core\..\mods\Commissioned Crews,D:\Games\Starsector\starsector-core\..\mods\DIABLEAVIONICS,D:\Games\Starsector\starsector-core\..\mods\Hegemony Expeditionary Auxiliary,D:\Games\Starsector\starsector-core\..\mods\HTE,D:\Games\Starsector\starsector-core\..\mods\Kadur Remnant,D:\Games\Starsector\starsector-core\..\mods\LazyLib,D:\Games\Starsector\starsector-core\..\mods\Leading Pip,D:\Games\Starsector\starsector-core\..\mods\MagicLib,D:\Games\Starsector\starsector-core\..\mods\OldHyperion,D:\Games\Starsector\starsector-core\..\mods\ORA,D:\Games\Starsector\starsector-core\..\mods\Persean-Chronicles-2.0.1,D:\Games\Starsector\starsector-core\..\mods\tahlan-scalartech,D:\Games\Starsector\starsector-core\..\mods\SCY,D:\Games\Starsector\starsector-core\..\mods\SEEKER_UC,D:\Games\Starsector\starsector-core\..\mods\SpeedUp,D:\Games\Starsector\starsector-core\..\mods\Supply Forging,D:\Games\Starsector\starsector-core\..\mods\tahlan,D:\Games\Starsector\starsector-core\..\mods\Exalted,D:\Games\Starsector\starsector-core\..\mods\FED,D:\Games\Starsector\starsector-core\..\mods\Torchships,D:\Games\Starsector\starsector-core\..\mods\Transfer All Items,D:\Games\Starsector\starsector-core\..\mods\UnknownSkies,D:\Games\Starsector\starsector-core\..\mods\UpgradedRotaryWeapons,D:\Games\Starsector\starsector-core\..\mods\Vayra's Ship Pack,D:\Games\Starsector\starsector-core\..\mods\XhanEmpire,D:\Games\Starsector\starsector-core\..\mods\Audio Plus,D:\Games\Starsector\starsector-core\..\mods\prv Starworks,D:\Games\Starsector\starsector-core\..\mods\GraphicsLib,../starfarer.res/res,CLASSPATH]
   at com.fs.util.C.Ó00000(Unknown Source)
   at com.fs.util.C.String(Unknown Source)
   at com.fs.starfarer.loading.LoadingUtils.return(Unknown Source)
   at com.fs.starfarer.loading.LoadingUtils.o00000(Unknown Source)
   at com.fs.starfarer.settings.StarfarerSettings$1.loadCSV(Unknown Source)
   at org.dark.shaders.light.LightData.readLightDataCSV(LightData.java:54)
   at data.scripts.TADA_modPlugin.onApplicationLoad(TADA_modPlugin.java:69)
   at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)


Looks like maybe a conflict with Lightshow or Tartiflette's Torchships And Deadly Armaments but there's so much to unpack there. Not sure if it matters but I have a RTX2060 Super with the latest Geforce drivers.

I can confirm, that disabling TADA will stop the CTD :(
Logged

Icchan

  • Ensign
  • *
  • Posts: 11
    • View Profile
Re: [0.95a] GraphicsLib 1.5.0
« Reply #151 on: March 29, 2021, 12:07:31 PM »

Can confirm, loading the game with lazylib, magiclib and graphicslib works fine, add TADA to the mix and instant crash.
Spoiler
Code
15691 [Thread-3] INFO  com.fs.starfarer.loading.LoadingUtils  - Loading JSON from [lazylib_settings.json]
15695 [Thread-3] INFO  com.fs.starfarer.loading.LoadingUtils  - Loading JSON from [mod_info.json]
15696 [Thread-3] INFO  org.lazywizard.lazylib.LazyLib  - Running LazyLib v2.6, built for Starsector 0.95a-RC9
15696 [Thread-3] INFO  com.fs.starfarer.loading.LoadingUtils  - Loading JSON from [DIRECTORY: C:\Games\Starsector\starsector-core\..\mods\MagicLib (data/config/modSettings.json)]
15697 [Thread-3] ERROR data.scripts.plugins.MagicAutoTrails  - unable to read data/trails/trail_data.csv
15697 [Thread-3] ERROR data.scripts.plugins.MagicAutoTrails  - java.lang.RuntimeException: Error loading [data/trails/trail_data.csv] resource, not found in [C:\Games\Starsector\starsector-core\..\mods\LazyLib,C:\Games\Starsector\starsector-core\..\mods\MagicLib,C:\Games\Starsector\starsector-core\..\mods\Torchships,C:\Games\Starsector\starsector-core\..\mods\GraphicsLib,../starfarer.res/res,CLASSPATH]
15697 [Thread-3] INFO  com.fs.starfarer.loading.LoadingUtils  - Loading CSV data from [DIRECTORY: C:\Games\Starsector\starsector-core\..\mods\MagicLib]
15698 [Thread-3] INFO  com.fs.starfarer.loading.LoadingUtils  - Loading CSV data from [DIRECTORY: C:\Games\Starsector\starsector-core\..\mods\Torchships]
15700 [Thread-3] INFO  com.fs.starfarer.loading.LoadingUtils  - Loading JSON from [GRAPHICS_OPTIONS.ini]
15775 [Thread-3] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Error loading [data/lights/config/modFiles/TADA_light_data.csv] resource, not found in [C:\Games\Starsector\starsector-core\..\mods\LazyLib,C:\Games\Starsector\starsector-core\..\mods\MagicLib,C:\Games\Starsector\starsector-core\..\mods\Torchships,C:\Games\Starsector\starsector-core\..\mods\GraphicsLib,../starfarer.res/res,CLASSPATH]
java.lang.RuntimeException: Error loading [data/lights/config/modFiles/TADA_light_data.csv] resource, not found in [C:\Games\Starsector\starsector-core\..\mods\LazyLib,C:\Games\Starsector\starsector-core\..\mods\MagicLib,C:\Games\Starsector\starsector-core\..\mods\Torchships,C:\Games\Starsector\starsector-core\..\mods\GraphicsLib,../starfarer.res/res,CLASSPATH]
at com.fs.util.Object.Ó00000(Unknown Source)
at com.fs.util.Object.Ô00000(Unknown Source)
at com.fs.starfarer.loading.LoadingUtils.return(Unknown Source)
at com.fs.starfarer.loading.LoadingUtils.o00000(Unknown Source)
at com.fs.starfarer.settings.StarfarerSettings$1.loadCSV(Unknown Source)
at org.dark.shaders.light.LightData.readLightDataCSV(LightData.java:54)
at data.scripts.TADA_modPlugin.onApplicationLoad(TADA_modPlugin.java:69)
at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
at com.fs.state.AppDriver.begin(Unknown Source)
at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
[close]

EDIT: Nvm, TADA fixed the problem with an update.
« Last Edit: March 29, 2021, 07:32:53 PM by Icchan »
Logged

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2736
    • View Profile
    • Sc2Mafia
    • Email
[0.95a] GraphicsLib 1.5.1
« Reply #152 on: March 30, 2021, 04:31:26 AM »

Compromises ahoy!


Download GraphicsLib 1.5.1
Also known as ShaderLib.
Download Mirror
(Requires LazyLib 2.6)

Edit GRAPHICS_OPTIONS.ini to enable or disable GraphicsLib features!



We also recommend Version Checker to notify you when an update is ready.

Warning: Make sure Starsector is GPU-Accelerated!
Mobile or integrated chipsets are known to have serious graphical artifacts!

Warning: Antialiasing is mostly not supported when using shaders!

Having problems?  Visit the Mod Troubleshooting Guide!



Change Log
Version 1.5.1:
- Made sun-generated lights less extreme when multiple stars are in system
- Insignia icons are scaled to the new range of officer levels
  * Tier 1: Level 1-2 (freshly hired officers)
  * Tier 2: Level 3-4
  * Tier 3: Level 5-6 (max for trainable/mercenary/NPC officers)
  * Tier 4: Level 7+ (max for procgen officers, NPC commanders, and AI or unique officers)
- Added "aaCompatMode" to GRAPHICS_OPTIONS.ini
  * Prevents GraphicsLib from crashing out at the start if you have antialiasing enabled
  * Disables the second pass of the post processing shader
  * You'll have antialiased sharpness in the campaign and the combat interface, but the actual in-battle ships/weapons/effects will be as blurry as if you weren't using antialiasing
Logged

Achilles42x

  • Ensign
  • *
  • Posts: 21
    • View Profile
    • Email
Re: [0.95a] GraphicsLib 1.5.1
« Reply #153 on: April 04, 2021, 01:26:45 PM »

Also crashing on load with TADA.

Question- does GraphicsLib do anything if it isn't being used as a prereq for a mod?
Like does it improve the graphics of the game? Edit: If I'm reading correctly, it does.
Logged

Mordodrukow

  • Captain
  • ****
  • Posts: 256
    • View Profile
Re: [0.95a] GraphicsLib 1.5.1
« Reply #154 on: April 05, 2021, 04:11:48 PM »

Have 2GB VRAM, but getting this message, and the game slows down sometimes.


I m playing 9.5 RC9. Will it help if i update to the latest version?
Logged
Spoiler
[close]

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2736
    • View Profile
    • Sc2Mafia
    • Email
Re: [0.95a] GraphicsLib 1.5.1
« Reply #155 on: April 06, 2021, 11:47:36 AM »

You'll have to adjust GraphicsLib settings.  There's not much else you can do in that situation.
Logged

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email
Re: [0.95a] GraphicsLib 1.5.1
« Reply #156 on: April 16, 2021, 03:30:25 AM »

Hey man your mod Underworld uses graphicslib 1.5.0 but underworld is still on 0.91a does that mean graphics lib for 0.95a is compatible with 0.91a? im confused and this might explain my crashes with remnant fleet and my cabal fleet.

325851 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NoSuchMethodError: com.fs.starfarer.api.combat.CombatEngineAPI.spawnEmpArc(Lcom/fs/starfarer/api/combat/ShipAPI;Lorg/lwjgl/util/vector/Vector2f;Lcom/fs/starfarer/api/combat/CombatEntityAPI;Lcom/fs/starfarer/api/combat/CombatEntityAPI;Lcom/fs/starfarer/api/combat/DamageType;FFFLjava/lang/String;FLjava/awt/Color;Ljava/awt/Color;)Lcom/fs/starfarer/api/combat/EmpArcEntityAPI;
java.lang.NoSuchMethodError: com.fs.starfarer.api.combat.CombatEngineAPI.spawnEmpArc(Lcom/fs/starfarer/api/combat/ShipAPI;Lorg/lwjgl/util/vector/Vector2f;Lcom/fs/starfarer/api/combat/CombatEntityAPI;Lcom/fs/starfarer/api/combat/CombatEntityAPI;Lcom/fs/starfarer/api/combat/DamageType;FFFLjava/lang/String;FLjava/awt/Color;Ljava/awt/Color;)Lcom/fs/starfarer/api/combat/EmpArcEntityAPI;
   at data.weapons.drgArcEmitterSmallWeapon.advance(drgArcEmitterSmallWeapon.java:108)
   at com.fs.starfarer.combat.entities.ship.A.if.advance(Unknown Source)
   at com.fs.starfarer.combat.systems.oOoO.super(Unknown Source)
   at com.fs.starfarer.combat.systems.oOoO.advance(Unknown Source)
   at com.fs.starfarer.combat.entities.Ship.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advanceInner(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

Im using Graphics Lib 1.4.5 with newest underworld.
Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email
Re: [0.95a] GraphicsLib 1.5.1
« Reply #157 on: April 16, 2021, 03:43:07 AM »

i just updated to 1.5.1 and lazylib 2.6 (per requirement) and i crash before i even load the game

112363 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NoSuchMethodError: com.fs.starfarer.api.SettingsAPI.getScreenWidthPixels()F
java.lang.NoSuchMethodError: com.fs.starfarer.api.SettingsAPI.getScreenWidthPixels()F
   at org.dark.shaders.util.ShaderLib.init(ShaderLib.java:544)
   at data.scripts.AEmodplugin.onApplicationLoad(AEmodplugin.java:125)
   at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

before i was able to atleast load my game into the campaign and only crash in combat.

which version of Underworld is compatible with 1.4.5? because im a little confused why Underworld that is 0.91a requires a mod lib that is 0.95a?
Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.

Bagpipe

  • Ensign
  • *
  • Posts: 5
    • View Profile
Re: [0.95a] GraphicsLib 1.5.1
« Reply #158 on: April 16, 2021, 03:50:00 AM »

I have enabled this mod but it crashes due to AA at startup.

I used the compat mode in the .ini but the texturing looks terrible now.

I don't see any AA options in the launcher either though the error message advises to change them here?

How do you get this mod to work and make the game look better exactly?

Logged

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email
Re: [0.95a] GraphicsLib 1.5.1
« Reply #159 on: April 16, 2021, 04:04:19 AM »

233858 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.AbstractMethodError: data.weapons.proj.drgKneecapperBombletOnHitEffect.onHit(Lcom/fs/starfarer/api/combat/DamagingProjectileAPI;Lcom/fs/starfarer/api/combat/CombatEntityAPI;Lorg/lwjgl/util/vector/Vector2f;ZLcom/fs/starfarer/api/combat/CombatEngineAPI;)V
java.lang.AbstractMethodError: data.weapons.proj.drgKneecapperBombletOnHitEffect.onHit(Lcom/fs/starfarer/api/combat/DamagingProjectileAPI;Lcom/fs/starfarer/api/combat/CombatEntityAPI;Lorg/lwjgl/util/vector/Vector2f;ZLcom/fs/starfarer/api/combat/CombatEngineAPI;)V
   at com.fs.starfarer.combat.entities.Missile.notifyDealtDamage(Unknown Source)
   at com.fs.starfarer.combat.E.A.O0OO.super(Unknown Source)
   at com.fs.starfarer.combat.E.A.super(Unknown Source)
   at com.fs.starfarer.combat.E.A.super(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advanceInner(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

Reverted back to 1.4.5 everything works again including with the new 2.6 lazylib I have on seems to make no difference I still have a crash in combat, unfortunately. any oversights on mod dependencies?

{"enabledMods": [
  "Adjusted Sector",
  "raccoonarms",
  "blackrock_driveyards",
  "HMI_brighton",
  "capturecrew",
  "clearCommands",
  "chatter",
  "lw_radar",
  "COPS",
  "lw_console",
  "diableavionics",
  "DisassembleReassemble",
  "edshipyard",
  "sun_fuel_siphoning",
  "galmart",
  "hte",
  "hostileIntercept",
  "hypernet",
  "IndEvo",
  "interestingportraitspack",
  "Imperium",
  "kadur_remnant",
  "lw_lazylib",
  "ArkLeg",
  "MagicLib",
  "missingships",
  "Neutrino",
  "nexerelin",
  "playerflagpackex",
  "SEEKER",
  "shabro",
  "shadow_ships",
  "swp",
  "bonomel_skilledup",
  "speedUp",
  "stellics",
  "timid_supply_forging",
  "Sylphon_RnD",
  "tahlan",
  "Terraforming and Station Construction",
  "THI",
  "underworld",
  "US",
  "vayrasector",
  "vayrashippack",
  "lw_version_checker",
  "XhanEmpire",
  "audio_plus",
  "shaderLib",
  "prv"
]}
Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.

lolghurt

  • Ensign
  • *
  • Posts: 28
    • View Profile
Re: [0.95a] GraphicsLib 1.5.1
« Reply #160 on: April 16, 2021, 04:29:19 AM »

233858 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.AbstractMethodError: data.weapons.proj.drgKneecapperBombletOnHitEffect.onHit(Lcom/fs/starfarer/api/combat/DamagingProjectileAPI;Lcom/fs/starfarer/api/combat/CombatEntityAPI;Lorg/lwjgl/util/vector/Vector2f;ZLcom/fs/starfarer/api/combat/CombatEngineAPI;)V
java.lang.AbstractMethodError: data.weapons.proj.drgKneecapperBombletOnHitEffect.onHit(Lcom/fs/starfarer/api/combat/DamagingProjectileAPI;Lcom/fs/starfarer/api/combat/CombatEntityAPI;Lorg/lwjgl/util/vector/Vector2f;ZLcom/fs/starfarer/api/combat/CombatEngineAPI;)V
Your crash is the kneecapper from HTE. Did you grab the wrong version of HTE for your version of starsector?
Logged

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2736
    • View Profile
    • Sc2Mafia
    • Email
Re: [0.95a] GraphicsLib 1.5.1
« Reply #161 on: April 16, 2021, 04:43:00 AM »

I have enabled this mod but it crashes due to AA at startup.

I used the compat mode in the .ini but the texturing looks terrible now.

I don't see any AA options in the launcher either though the error message advises to change them here?

How do you get this mod to work and make the game look better exactly?

You'll have to turn off screen scaling and anti-aliasing if you want a sharper image with GraphicsLib.  The settings are in the launcher; click "Options...".

Reverted back to 1.4.5 everything works again including with the new 2.6 lazylib I have on seems to make no difference I still have a crash in combat, unfortunately. any oversights on mod dependencies?

Mods for 0.95a do not work with Starsector 0.9.1a.  Mods for 0.9.1a do not work with Starsector 0.95a.
Logged

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email
Re: [0.95a] GraphicsLib 1.5.1
« Reply #162 on: April 16, 2021, 04:52:26 AM »

I have enabled this mod but it crashes due to AA at startup.

I used the compat mode in the .ini but the texturing looks terrible now.

I don't see any AA options in the launcher either though the error message advises to change them here?

How do you get this mod to work and make the game look better exactly?

You'll have to turn off screen scaling and anti-aliasing if you want a sharper image with GraphicsLib.  The settings are in the launcher; click "Options...".

Reverted back to 1.4.5 everything works again including with the new 2.6 lazylib I have on seems to make no difference I still have a crash in combat, unfortunately. any oversights on mod dependencies?

Mods for 0.95a do not work with Starsector 0.9.1a.  Mods for 0.9.1a do not work with Starsector 0.95a.

So in reality underworld 1.5.0 is only compatible with 1.4.5 graphics lib. got confused with the requirement headline on the main page my apologies!
Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email
Re: [0.95a] GraphicsLib 1.5.1
« Reply #163 on: April 16, 2021, 04:54:41 AM »

233858 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.AbstractMethodError: data.weapons.proj.drgKneecapperBombletOnHitEffect.onHit(Lcom/fs/starfarer/api/combat/DamagingProjectileAPI;Lcom/fs/starfarer/api/combat/CombatEntityAPI;Lorg/lwjgl/util/vector/Vector2f;ZLcom/fs/starfarer/api/combat/CombatEngineAPI;)V
java.lang.AbstractMethodError: data.weapons.proj.drgKneecapperBombletOnHitEffect.onHit(Lcom/fs/starfarer/api/combat/DamagingProjectileAPI;Lcom/fs/starfarer/api/combat/CombatEntityAPI;Lorg/lwjgl/util/vector/Vector2f;ZLcom/fs/starfarer/api/combat/CombatEngineAPI;)V
Your crash is the kneecapper from HTE. Did you grab the wrong version of HTE for your version of starsector?

I had been using 1.3.0 of HTE for a while so it surprised me when updating it to 1.3.0b fixed this very odd but thank you so much figured it out just before you replied! Sorry to post this on here I was pretty sure it was because of the underworld and its odd version requirements on the main page
Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.

Flacman3000

  • Commander
  • ***
  • Posts: 188
  • A man cannot put his shaft into the unknown.
    • View Profile
    • Email
Re: [0.95a] GraphicsLib 1.5.1
« Reply #164 on: April 16, 2021, 04:59:33 AM »

I hope you can understand why I was confused on your update post you had mentioned 1.5.0 graphics lib was required for underworld 1.5.0 which is still on version 0.91a of star sector unlike 1.5.0 of graphics lib which is for 0.95a. Was this an oversight?
Logged
Ryzen 7 2700x, 1080ti, 16GB DDR4 RAM and playing SS on a SSD - Always stay ahead because when you're ahead you're rear anatomy is open to interpretation.
Pages: 1 ... 9 10 [11] 12 13 ... 16