Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Pages: 1 ... 6 7 [8] 9 10 11

Author Topic: Mod Troubleshooting Guide (Read BEFORE posting!)  (Read 119198 times)

nubbinownz

  • Ensign
  • *
  • Posts: 2
    • View Profile
Re: Mod Troubleshooting Guide (Read BEFORE posting!)
« Reply #105 on: December 29, 2021, 09:44:03 PM »

I'd try a clean redownload and reinstall of GraphicsLib (1.6.0 for latest Starsector version, but if you're on an older Starsector version get an appropriate GLib version)

Yep that was the first thing I tried.  Unless I'm missing something here, that just means deleting the graphicslib folder out of the mod folder and downloading a new one to pop in there ?

That's what I did first. No difference unfortunately :(
Logged

Histidine

  • Admiral
  • *****
  • Posts: 4124
    • View Profile
    • Bitbucket profile
Re: Mod Troubleshooting Guide (Read BEFORE posting!)
« Reply #106 on: December 30, 2021, 12:17:04 AM »

Odd.

Manual fix: Search for all copies of data/lights/core_texture_data.csv in the mods you're using.
Look for any row that says graphics/shaders/material/ships/hyperion_ff_material.png and delete it, or maybe edit it to point to a file that does exist.
Logged

nalatas

  • Ensign
  • *
  • Posts: 1
    • View Profile
Re: Mod Troubleshooting Guide (Read BEFORE posting!)
« Reply #107 on: January 17, 2022, 12:15:19 PM »

here is my mod list  they are all up to date

console commands
DIY planets
detailed combat results
fleet action history
high tech expansion
hyperdrive
industrial evolution
lazylib
machine void shipyards
magiclib
new beginings
nexerlin
superweapons arsenal
vic
graphics lib







34377 [Thread-3] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Hullmod with id [phase_anchor] not found
java.lang.RuntimeException: Hullmod with id [phase_anchor] not found
   at com.fs.starfarer.loading.specs.O00oOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.isDHull(Unknown Source)
   at com.fs.starfarer.codex.CodexData.Ô00000(Unknown Source)
   at com.fs.starfarer.codex.CodexData.<init>(Unknown Source)
   at com.fs.starfarer.codex.A.<init>(Unknown Source)
   at com.fs.starfarer.codex.A.Ô00000(Unknown Source)
   at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
 ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NoClassDefFoundError: com/fs/starfarer/api/campaign/CustomVisualDialogDelegate
java.lang.NoClassDefFoundError: com/fs/starfarer/api/campaign/CustomVisualDialogDelegate
   at java.lang.Class.getDeclaredConstructors0(Native Method)
   at java.lang.Class.privateGetDeclaredConstructors(Unknown Source)
   at java.lang.Class.getConstructor0(Unknown Source)
   at java.lang.Class.newInstance(Unknown Source)
   at com.fs.starfarer.campaign.rules.super.getCommandClass(Unknown Source)
   at com.fs.starfarer.campaign.rules.super.<init>(Unknown Source)
   at com.fs.starfarer.campaign.rules.Rules.o00000(Unknown Source)
   at com.fs.starfarer.loading.SpecStore.public(Unknown Source)
   at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: com.fs.starfarer.api.campaign.CustomVisualDialogDelegate
   at java.net.URLClassLoader$1.run(Unknown Source)
   at java.net.URLClassLoader$1.run(Unknown Source)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.net.URLClassLoader.findClass(Unknown Source)
   at java.lang.ClassLoader.loadClass(Unknown Source)
   at java.lang.ClassLoader.loadClass(Unknown Source)
ERROR LOG
eption: Hullmod with id [rugged] not found
   at com.fs.starfarer.loading.specs.O00oOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.isDHull(Unknown Source)
   at com.fs.starfarer.codex.CodexData.Ô00000(Unknown Source)
   at com.fs.starfarer.codex.CodexData.<init>(Unknown Source)
   at com.fs.starfarer.codex.A.<init>(Unknown Source)
   at com.fs.starfarer.codex.A.Ô00000(Unknown Source)
   at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
Logged

Histidine

  • Admiral
  • *****
  • Posts: 4124
    • View Profile
    • Bitbucket profile
Re: Mod Troubleshooting Guide (Read BEFORE posting!)
« Reply #108 on: January 19, 2022, 08:24:41 AM »

Update your Starsector (latest is 0.95.1a-RC6).
Logged

Argonautis

  • Ensign
  • *
  • Posts: 11
    • View Profile
Re: Mod Troubleshooting Guide (Read BEFORE posting!)
« Reply #109 on: February 04, 2022, 02:02:10 AM »

Hey captains, wanted to ask. Can I update to a new version to an existing save that has NEX activated already? Obviously I dont expect the 'New Game' features to work.
Logged

Histidine

  • Admiral
  • *****
  • Posts: 4124
    • View Profile
    • Bitbucket profile
Re: Mod Troubleshooting Guide (Read BEFORE posting!)
« Reply #110 on: February 05, 2022, 12:14:36 AM »

Hey captains, wanted to ask. Can I update to a new version to an existing save that has NEX activated already? Obviously I dont expect the 'New Game' features to work.
As in add/update Nexerelin to an existing save? That will work.
Updating Starsector from 0.95a to 0.95.1a will also work (although Nex will need to be updated with it).
Logged

Maxifier

  • Ensign
  • *
  • Posts: 7
    • View Profile
Re: Mod Troubleshooting Guide (Read BEFORE posting!)
« Reply #111 on: March 13, 2022, 07:49:13 AM »

Hey.

I'm having issues with startup, getting Fatal: Problem loading class data.hullmods.SKR_PlagueLPC
Cause: null

This is the error part from the log. Could anyone point me in the right direction on how to fix this?
Thanks

197466 [Thread-3] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Problem loading class [data.hullmods.SKR_plagueLPC]
java.lang.RuntimeException: Problem loading class [data.hullmods.SKR_plagueLPC]
   at com.fs.starfarer.loading.scripts.ScriptStore.Object(Unknown Source)
   at com.fs.starfarer.loading.specs.private.getEffect(Unknown Source)
   at org.sutopia.starsector.mod.concord.adv.ConcordAssembly.onApplicationLoad(ConcordAssembly.java:43)
   at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NullPointerException
   at data.hullmods.SKR_plagueLPC.<init>(SKR_plagueLPC.java:19)
   at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
   at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
   at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
   at java.lang.reflect.Constructor.newInstance(Unknown Source)
   at java.lang.Class.newInstance(Unknown Source)
   ... 9 more
Logged

Maxifier

  • Ensign
  • *
  • Posts: 7
    • View Profile
Re: Mod Troubleshooting Guide (Read BEFORE posting!)
« Reply #112 on: March 13, 2022, 07:50:27 AM »

And yeah sorry.

Here's my mod list

{"enabledMods": [
  "yunrutechmining",
  "$$$_lightshow",
  "$$$_trailermoments",
  "Ex7s",
  "pantera_ANewLevel40",
  "advanced_gunnery_control_dbeaa06e",
  "anotherportraitpack",
  "apex_design",
  "armaa",
  "raccoonarms",
  "AttunedDriveField",
  "automatedcommands",
  "lw_autosave",
  "battletechportraitpack",
  "BSC - Drone Refits",
  "timid_admins",
  "beyondthesector",
  "BSC",
  "BSC_Submod",
  "CWSP",
  "CaptainsLog",
  "capturecrew",
  "Csp",
  "CSP",
  "CAS",
  "chatter",
  "timid_commissioned_hull_mods",
  "su_Concord",
  "lw_console",
  "domain_mship_controllable",
  "diyplanets",
  "istl_dassaultmikoyan",
  "hm_flagpack",
  "DetailedCombatResults",
  "diableavionics_sunrise",
  "diableavionics",
  "dronelib",
  "edshipyard",
  "Everybody loves KoC",
  "XLU",
  "fast_engine_rendering",
  "HHE",
  "fleethistory",
  "fluffships",
  "sun_flux_reticle",
  "forge_production",
  "sun_fuel_siphoning",
  "gladiatorsociety",
  "GrandColonies",
  "gundam_uc",
  "HMI",
  "gunnyhegexpeditionary",
  "HexShields",
  "hte",
  "HIVER",
  "hostileIntercept",
  "sun_hyperdrive",
  "immersionFriendlyPortraitPack",
  "IndEvo",
  "internalaffairs",
  "Imperium",
  "timid_xiv",
  "jaa",
  "JYD",
  "kadur_remnant",
  "kazeron",
  "keruvim_shipyards",
  "kingdomofterra",
  "kyeltziv",
  "LTA",
  "lw_lazylib",
  "ArkLeg",
  "lockedAndLoaded",
  "logisticsNotifications",
  "luddenhance",
  "idx_magnetar",
  "exshippack",
  "mag_protect",
  "MagicLib",
  "Mayasuran Navy",
  "missingships",
  "su_CarrierHullmod",
  "more_hullmods",
  "ness_saw",
  "sun_new_beginnings",
  "nexerelin",
  "kayse_phaseships",
  "ORA_irradiated",
  "OcuA",
  "Ocutek",
  "JYDR",
  "oas",
  "ORA",
  "pn",
  "wisp_perseanchronicles",
  "planet_search",
  "TAR",
  "PulseIndustry",
  "pt_qolpack",
  "yunru_pilot_radiant",
  "repdec",
  "roider",
  "rotcesrats",
  "sanguinary_autonomist_defectors",
  "tahlan_scalartech",
  "SCY",
  "Seafood",
  "SEEKER",
  "shadow_ships",
  "PT_ShipDirectionMarker",
  "swp",
  "simpleplayerflags",
  "speedUp",
  "sun_starship_legends",
  "stelnet",
  "StopGapMeasures3",
  "superweapons",
  "timid_supply_forging",
  "Terraforming & Station Construction",
  "exalted",
  "star_federation",
  "TORCHSHIPS",
  "transfer_all_items",
  "underworld",
  "UNSC",
  "US",
  "URW",
  "vic",
  "vanidad",
  "vayrashippack",
  "weftinships",
  "XhanEmpire",
  "unpackblueprints",
  "yunrucore",
  "audio_plus",
  "astroidships",
  "prv",
  "shaderLib"
]}
Logged

Maxifier

  • Ensign
  • *
  • Posts: 7
    • View Profile
Re: Mod Troubleshooting Guide (Read BEFORE posting!)
« Reply #113 on: March 13, 2022, 08:19:59 AM »

Alright so I've narrowed it down, Its Seeker thats causing the issue.
the mod says it need an older version of magiclib, tried using the molder version but it still crashes.
I'll reach out to the mod creator.
Logged

Sundog

  • Admiral
  • *****
  • Posts: 1495
    • View Profile
Re: Mod Troubleshooting Guide (Read BEFORE posting!)
« Reply #114 on: March 13, 2022, 08:42:36 AM »

Alright so I've narrowed it down, Its Seeker thats causing the issue.
the mod says it need an older version of magiclib, tried using the molder version but it still crashes.
I'll reach out to the mod creator.
I think it's actually an incompatibility between Concord and Seeker. It looks like Concord is trying to do something with SKR_plagueLPC when the game loads that causes the crash:
   at org.sutopia.starsector.mod.concord.adv.ConcordAssembly.onApplicationLoad(ConcordAssembly.java:43)

Sutopia

  • Admiral
  • *****
  • Posts: 1005
    • View Profile
Re: Mod Troubleshooting Guide (Read BEFORE posting!)
« Reply #115 on: March 13, 2022, 08:51:20 AM »

Alright so I've narrowed it down, Its Seeker thats causing the issue.
the mod says it need an older version of magiclib, tried using the molder version but it still crashes.
I'll reach out to the mod creator.
I think it's actually an incompatibility between Concord and Seeker. It looks like Concord is trying to do something with SKR_plagueLPC when the game loads that causes the crash:
   at org.sutopia.starsector.mod.concord.adv.ConcordAssembly.onApplicationLoad(ConcordAssembly.java:43)
Plague LPC has bad implementation using a variable not initialized. I fixed it on concord side but it's seeker's code problem. It will be triggered by any mod trying to loop through hullmod spec and inspecting get effect.
Logged


Since all my mods have poor reputation, I deem my efforts unworthy thus no more updates will be made.

Maxifier

  • Ensign
  • *
  • Posts: 7
    • View Profile
Re: Mod Troubleshooting Guide (Read BEFORE posting!)
« Reply #116 on: March 14, 2022, 06:37:52 AM »

Alright so I've narrowed it down, Its Seeker thats causing the issue.
the mod says it need an older version of magiclib, tried using the molder version but it still crashes.
I'll reach out to the mod creator.
I think it's actually an incompatibility between Concord and Seeker. It looks like Concord is trying to do something with SKR_plagueLPC when the game loads that causes the crash:
   at org.sutopia.starsector.mod.concord.adv.ConcordAssembly.onApplicationLoad(ConcordAssembly.java:43)
Plague LPC has bad implementation using a variable not initialized. I fixed it on concord side but it's seeker's code problem. It will be triggered by any mod trying to loop through hullmod spec and inspecting get effect.



Yoooo I updated concord with the files you dropped in yesterday. It works now. Massive thanks for the effort put in. You've made my day
Logged

spauch

  • Ensign
  • *
  • Posts: 2
    • View Profile
Re: Mod Troubleshooting Guide (Read BEFORE posting!)
« Reply #117 on: March 15, 2022, 01:16:46 PM »

I'm trying to run just Lazylib, Magiclib and Nexerelin. when I run just lazylib the game will open, when I run Magiclib I get a "Fatal: java.lang.RuntimeExeption: Command [AddBarEvent] notfound" with a list of various packages. Then when I run both with Nexerelin I get a "Fatal: JSONObject["id"] not found." I have tried reinstalling all the mods and Starsector, Its come back with the same error messages every time. I'm not sure what I am missing. here is my log https://pastebin.com/4796haau
Logged

LordKhorne

  • Ensign
  • *
  • Posts: 14
    • View Profile
Re: Mod Troubleshooting Guide (Read BEFORE posting!)
« Reply #118 on: May 10, 2022, 02:03:43 PM »

you lib is causing my game to crash everytime a ship explodes due to not being able to find the explosion animation.
Logged

Ruddygreat

  • Captain
  • ****
  • Posts: 319
  • Seals :^)
    • View Profile
Re: Mod Troubleshooting Guide (Read BEFORE posting!)
« Reply #119 on: May 10, 2022, 03:30:11 PM »

you lib is causing my game to crash everytime a ship explodes due to not being able to find the explosion animation.

update your game, you can get the latest version here
Pages: 1 ... 6 7 [8] 9 10 11