Fractal Softworks Forum

Please login or register.

Login with username, password and session length

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - fjc130

Pages: [1]
1
Bug Reports & Support (modded) / Re: Game CTD
« on: July 24, 2021, 08:18:24 AM »
Actually, i have simply no idea why or how but i just kept trying and the errors simply went away by themselves lmao.
Like, after this happened, i tried to start a new game again and the sector generation worked so that error went away, but as soon as the game started it crashed and gave me another error, i restarted starsector and tried a new game and sector generation worked and the game didnt crash after starting, it was pretty weird but i found it funny, the errors simply fixed themselves without me doing anything.  ;D

2
Mods / Re: [0.95a] Console Commands v2021.04.10
« on: July 24, 2021, 08:08:39 AM »
Is there a way to copy something on the console to the clipboard? for example if i listed all ships could i copy it all to my clipboard?

3
Bug Reports & Support / Re: Maximize Window
« on: July 22, 2021, 02:41:17 PM »
I guess i will have to stick with that, but, i would still prefer alot being able to see the task bar while playing the game in a maximized window, if this is not possible however, i will have to stick with your solution, thanks alot for the quick answer!

4
Bug Reports & Support / Maximize Window
« on: July 22, 2021, 02:32:11 PM »
Is there any way to play Starsector windowed but maximize it so it fills the whole screen like you can do with a chrome tab or an explorer tab? when i play fullscreen my computer takes quite a while to minimize starsector and move to another window (discord for example) and when i play windowed the game doesnt maximize which makes the lower tabs simply not appear, i noticed the maximize button is greyed out however so i wanted to know if there was any way to maximize the window?

5
Bug Reports & Support (modded) / Game CTD
« on: July 22, 2021, 10:12:25 AM »
My game crashed when i tried to make a new game, more specifically it crashed when generating the sector.

Here's the error in the log

1067877 [Thread-3] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
   at com.fs.starfarer.campaign.CharacterStats.refreshCharacterStatsEffects(Unknown Source)
   at com.fs.starfarer.api.impl.campaign.fleets.FleetFactoryV3.addCommanderSkills(FleetFactoryV3.java:1276)
   at com.fs.starfarer.api.impl.campaign.fleets.FleetFactoryV3.addCommanderAndOfficer sV2(FleetFactoryV3.java:1147)
   at com.fs.starfarer.api.impl.campaign.fleets.FleetFactoryV3.addCommanderAndOfficer s(FleetFactoryV3.java:852)
   at com.fs.starfarer.api.impl.campaign.fleets.FleetFactoryV3.createFleet(FleetFactoryV3.java:411)
   at com.fs.starfarer.api.impl.campaign.intel.PersonBountyIntel.spawnFleet(PersonBountyIntel.java:608)
   at com.fs.starfarer.api.impl.campaign.intel.PersonBountyIntel.<init>(PersonBountyIntel.java:112)
   at com.fs.starfarer.api.impl.campaign.intel.PersonBountyManager.createEvent(PersonBountyManager.java:42)
   at com.fs.starfarer.api.impl.campaign.intel.BaseEventManager.advance(BaseEventManager.java:141)
   at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
   at com.fs.starfarer.campaign.save.CampaignGameManager.o00000(Unknown Source)
   at com.fs.starfarer.title.TitleScreenState.dialogDismissed(Unknown Source)
   at com.fs.starfarer.ui.Oo0O.dismiss(Unknown Source)
   at com.fs.starfarer.ui.impl.o0oO.dismiss(Unknown Source)
   at com.fs.starfarer.campaign.save.J.actionPerformed(Unknown Source)
   at com.fs.starfarer.ui.newnew.buttonPressed(Unknown Source)
   at com.fs.starfarer.ui.I.Ò00000(Unknown Source)
   at com.fs.starfarer.ui.I.processInput(Unknown Source)
   at com.fs.starfarer.ui.Stringsuper.super(Unknown Source)
   at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

And my modlist:

{"enabledMods": [
  "pantera_ANewLevel40R",
  "Adjusted Sector",
  "anotherportraitpack",
  "armaa",
  "automatedcommands",
  "timid_admins",
  "CWSP",
  "chatter",
  "domain_mship_controllable",
  "diyplanets",
  "DetailedCombatResults",
  "diableavionics",
  "dynamictariffs",
  "HHE",
  "fluffships",
  "sun_fuel_siphoning",
  "GrandColonies",
  "HMI",
  "hte",
  "hiigaran_descendants",
  "sun_hyperdrive",
  "IndEvo",
  "kadur_remnant",
  "lw_lazylib",
  "ArkLeg",
  "logisticsNotifications",
  "mag_protect",
  "MagicLib",
  "Mayasuran Navy",
  "su_CarrierHullmod",
  "su_CarrierHullmod_Rebalance",
  "more_hullmods",
  "nexerelin",
  "old_hyperion",
  "PulseIndustry",
  "tahlan_scalartech",
  "SCY",
  "SEEKER",
  "speedUp",
  "sw",
  "sun_starship_legends",
  "stelnet",
  "StopGapMeasures3",
  "timid_supply_forging",
  "tahlan",
  "Terraforming and Station Construction",
  "star_federation",
  "underworld",
  "US",
  "vic",
  "vayrashippack",
  "XhanEmpire",
  "shaderLib"
]}

More context:

Just updated Starsector, i had been waiting a while for the mods that i normally use to be updated to the new version, i uninstalled the game and reinstalled from a fresh installer (because i wanted to make sure nothing wrong happens since i always seem to mess up something when related to modding/updating games), after the game was isntalled i extracted the mods into the mod folder and booted the game, then when i was making a new game the game crashed in the sector generation part.
Any help is much appreciated, thanks.

Pages: [1]