Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: Skill Changes, Part 2 (07/15/21)

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - harmonica2150

Pages: [1]
1
Modding / Re: Loading Error
« on: April 22, 2020, 09:29:01 AM »
It would help to know your mod list as well but... Looks like you are using a mod that requires GraphicsLib, and are not running said lib.


Thank you so much! I was going through the mods, trying to figure out which ones was making the game crash. You've saved me a lot of time!

2
Modding / Re: Loading Error
« on: April 20, 2020, 09:42:56 PM »
I believe this also happens if you don't have the required library mods installed. Do you have lazylib enabled?

Yup lazylib and magiclib are installed.

3
Modding / Loading Error
« on: April 20, 2020, 08:04:39 PM »
Hi Guys,

I'm getting a similar error loading Starsector to here: https://fractalsoftworks.com/forum/index.php?topic=15573.0

The error: Failed to find script of class [exerlerin.plugins.nexcorelifecycleplugin]

I've removed nexelerin, and have tried a whole bunch of other mod combinations but no luck, and also downloaded a fresh copy of Starsector.

Do you guys know how how I can find what's going on?



4
Mods / Re: [0.65.2a] Starsector+ Vanilla Enhancement Mod 2.7.5
« on: April 03, 2015, 05:25:39 PM »
If you have a graphic card go in the drivers options and force the GPU acceleration for Starsector, that should do it. Sometimes the drivers limit the use of the card to save battery and switch to the motherboard's integrated chip instead.

Okay, just finished a couple battles and no issues after doing what you said. Thanks so much!

5
Mods / Re: [0.65.2a] Starsector+ Vanilla Enhancement Mod 2.7.5
« on: April 03, 2015, 04:40:44 PM »
Yep, classic shaderlib glitch if you don't have drivers up to date or are using an integrated gpu on a laptop. Try either updating your drivers, force on the graphic card if you have any or disable shaderlib in the mod's settings (you have to load it for other mods to function, but it won't do anything and won't mess your display)

Thanks. I do have a laptop graphics card. Geforce 640m... so basically I can't use shaderlib? I just updated the drivers but no dice.


6
Mods / Re: [0.65.2a] Starsector+ Vanilla Enhancement Mod 2.7.5
« on: April 03, 2015, 03:48:45 PM »
Hi,

Great Mod, but I have some serious graphics issues. It stutters and repeats, and the graphics don't refresh, just piles on each other. It does this regularly, then fixes itself.

Just installed this mod with the following ones:

Blackrock, Drive Yards, Citadel, Common Radar, Interstellar Imperium, JP_RC,  LazyLib, mayorate-0.8.1, MusicLib, Nexerelin, ShaderLib, Starsector Plus, Templars

I have also installed the newest version of starsector, and everything has been downloaded today. I did the Java thing in the bat file also, so I have enough memory for sure. Also, I can play Ironclads no problem....

Do you guys have any ideas?


7
Mods / Re: Project Ironclads TC 8.5 (20/01/2015) [0.65.1a] new aliens
« on: February 01, 2015, 12:33:19 PM »
THAT is what I was looking for. Thank your so much!


This stickied thread should help - it's over in the "bug reports and support" section of the forum.

8
Mods / Re: Project Ironclads TC 8.5 (20/01/2015) [0.65.1a] new aliens
« on: February 01, 2015, 11:37:10 AM »
Okim,

Thanks for the quick reply. I'm on a 64bit system with windows 8.

I remember there was a page here somewhere that mentioned deleting the first bit of text in the batch file and replacing it with just 'java'. Do you know where I can find that? I can't find it for the life of me.

If you are using 32 bit system there is no workaround if IIRC other than to wait for the next vanilla update. It is supposed to do something with save game size which i hope will remove these memory issues that large saves have.


9
Mods / Re: Project Ironclads TC 8.5 (20/01/2015) [0.65.1a] new aliens
« on: February 01, 2015, 09:46:49 AM »
I've been having a lot of trouble getting starsector to run. Its to do with JAVA, and I don't know how to remedy it. The problem is I can't load saved games. Every time I get a java error.

I've gone to your links OKIM, to change the memory, installed the most up to date versions of your mod and starsector. Also tried using Java 7 and 8, changing the 'JRE' file in starsector to the java7 or 8 file.

Is there somewhere I can look to find some information on this? I had this game running before, and I'm sure I'm just missing something simple, but I don't know what it is!


10
Mods / Re: Project Ironclads TC 8.3 (12/12/2014) [0.65.1a compatible]
« on: December 23, 2014, 12:27:33 PM »
Hi,

Great mod. A few suggestions:

1. I think that there needs to be more incentive to go attack a faction's enemy (say RSF vs. ISA). Right now, the bounties only work close to the systems themselves so you don't get anything for going out of your way to murder some ISA. Also, I think they should be doing much more raiding on each other. Its hard to collect a bounty from RSF period, (at least in my game), let alone make a profit between getting scanned all the time, plus the cost of supplies and fuel.

2. There should be a way to gain favour with factions that hate you.

3. Currently the best way to make cash is lobster running. This needs to be more dangerous to do.

4. Pirates need to be ultra rampant to make this more interesting, and to actually collect on bounties.

5. The taxes are too high. When you have a big fleet and get hit with a few scans that take away more than 30k each, you start to think of your lobster running days.

6. Alien hunting should be more profitable. Killing the rock fly should yield more than 5 brights.

Thanks for the great mod!

Pages: [1]