Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: Of Slipstreams and Sensor Ghosts (09/24/21)

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Orloth

Pages: [1]
1
Bug Reports & Support (modded) / Crash to desktop Null error
« on: February 24, 2019, 08:51:59 PM »
Started doing this on saved game so I even restarted a new game in case it was due to a mod removing or changing content. No dice, still crashes.


1818862 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
   at com.fs.starfarer.api.impl.campaign.fleets.DefaultFleetInflater.inflate(DefaultFleetInflater.java:258)
   at com.fs.starfarer.campaign.fleet.CampaignFleet.inflateIfNeeded(Unknown Source)
   at com.fs.starfarer.ui.impl.StandardTooltipV2.createFleetTooltip(Unknown Source)
   at com.fs.starfarer.campaign.C.super(Unknown Source)
   at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
   at com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
   at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

2
Bug Reports & Support (modded) / Crash to desktop Null error
« on: February 11, 2019, 08:06:30 PM »
This only happens to me after I take over colony or station. Once taken I can play for a few minutes, then it crashes to desktop with a null error.

Beyond this I have had no problems. I can play normally without issues as long as I do not take over a station and claim it for myself.

Sorry if this has been addressed already.

3
Bug Reports & Support (modded) / Java SE error when saving
« on: January 29, 2017, 07:41:59 AM »
I have had repeated Java SE binary errors when I save games. Generally happens later on in a play through. This corrupts the save sadly. I have found a thread on how to go back and get the save before that running, (thank you to the individual posting on removing the .bak), but I still lose all progress made. I have upped the memory in vramp to the 4mg threshold so the game has memory for the mods so I am unsure what can be causing this. Is this fixable on my end or is it a Java/Starsector compatability issue that will work out as both get new updates? Using the latest java and SS 7.2

Thank you in advance for any information on this.

4
General Discussion / Java memory question
« on: January 14, 2017, 03:16:34 PM »
I have watched the video on how increase the memory, but I noticed a discrepancy in my vmparams file and the one he has in video.  On the specific line where we are changing memory his shows:
 -Xms1024m -Xmx1024m

My file has extra characters not in his video:
-Xms1024m -Xmx1024m -Xss1024k


That -Xss bit has me stumped as it is not in the video. I can easily change the memory as instructed, but don't know what to do with that last bit.
Any words of wisdom on this would be appreciated.

Thanks in advance

Pages: [1]