Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: Skill Changes, Part 2 (07/15/21)

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - Sonomon

Pages: [1]
1
Mods / Re: [0.9.1a] Console Commands v3.0 WIP 7.6 (released 2018-12-07)
« on: August 23, 2019, 12:24:47 PM »
Quote
Hmm. You're on Starsector 0.9.1a-RC8, correct? Could you post screenshots of your mods/ folder, mods/LazyLib and mods/Console Commands?

Hey, that's all the pictures and the original starsector folder just incase, thank for the reply.

https://imgur.com/a/9wUj40B

You downloaded the repository, which contains the source code needed to build the mod, not the mod itself. You want the link below that labeled "dev build", rurrently this one.

Omg thank you lmao, I was so confused so thanks for clearing it up for me.

2
Mods / Re: [0.9.1a] Console Commands v3.0 WIP 7.6 (released 2018-12-07)
« on: August 22, 2019, 11:55:41 AM »
Quote
Hmm. You're on Starsector 0.9.1a-RC8, correct? Could you post screenshots of your mods/ folder, mods/LazyLib and mods/Console Commands?

Hey, that's all the pictures and the original starsector folder just incase, thank for the reply.

https://imgur.com/a/9wUj40B

3
Mods / Re: [0.9.1a] Console Commands v3.0 WIP 7.6 (released 2018-12-07)
« on: August 20, 2019, 02:46:50 PM »
Hey, so for some reason after extracting both LazyLib and the Command Console mod, neither will appear in the mods list in game (I made sure the folder led directly to the contents aswell). The outdated version of the mod shows up, but when I run it I get the same problem the guy before me got which was

Code
12769 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Failed to find script of class [com.fs.starfarer.api.impl.campaign.CoreLifecyclePluginImpl]
java.lang.RuntimeException: Failed to find script of class [com.fs.starfarer.api.impl.campaign.CoreLifecyclePluginImpl]
at com.fs.starfarer.loading.scripts.ScriptStore.new(Unknown Source)
at com.fs.starfarer.settings.StarfarerSettings.OO0000(Unknown Source)
at com.fs.starfarer.launcher.ModManager.getEnabledModPlugins(Unknown Source)
at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
at com.fs.state.AppDriver.begin(Unknown Source)
at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

So I combined the old version with the new LazyLib and still got the same error, I don't know if I'm supposed to check LazyLib aswell but it won't show up.

Pages: [1]