Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.97a is out! (02/02/24); New blog post: New music for Galatia Academy (06/12/24)

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - Gorshiro

Pages: [1]
1
Bug Reports & Support (modded) / Slowdown after Large or Medium battles
« on: November 16, 2021, 03:01:29 PM »
I really love this game, and as much as I suck at the combat, I've been really enjoying it lately.

The only problem is that in "medium" battles that have at least 4 cruiser-sized vessels, or larger, after I complete that battle I start to get stutters in systems and my fps tanks in hyperspace. I could reload the game and it fixes it but it happens after only one battle which means loading all the mods again just to play one battle and do it all over again.

I am playing with adjusted sector but my computer is able to handle it with no-noticeable slowdowns or stutters before a battle of medium size, even in hyperspace. I already allocated 6 GB of ram to the game and have 16 GB in total, so I should have more than enough ram to run the game. I've also assigned the game to use my GTX 1070 and in-system pre-battle, my CPU is almost 70% idle. It suffers in hyperspace but is still always around 60 fps with 6% idle. So I know my computer can run the game fine as is. I'm utterly confused as to why a single battle is the cause of my slowdown and don't really know why.

I also seem to have enough vram free, I've checked in-game using the console commands debug and it seems that I still have 5 GB of VRAM free (along with it showing in-game that the memory is still being used effectively by starsector.)

Smaller battles have no impact on performance and I can do as many as those as I want without a drop in performance, but as soon as I get into a medium-sized battle the fps tanks in the over-world after it's over and stutters make it annoying to play.

I would be grateful for anyone who can happen to help me. I've attached my Computer Specs from DXDiag and a screenshot of my Mod List. I tried to dump my starsector-log but it was too massive for pastebin. Thank you.

[attachment deleted by admin]

Pages: [1]