Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - xescape

Pages: [1]
1
I see, I didn't realize they had that kind of objectives. Thanks for the info!

2
Hello everyone,

I'm play a game where I'm trying to be friendly to the remnants through the faction quests from Midnight Dissonant in Prism. I've got the reputation to about +20. However, when I go into a high-danger system, some of the remnant fleets are hostile, while a few others are friendly. Meeting a hostile fleet would result in me having to fight them or use story point to disengage. Fighting them, however, would reset my remnant faction reputation, which misses the point of this playthrough. The story is also available in pictures: https://imgur.com/a/iRE3SSF

Any help in identifying why this is happening, and how to remedy/prevent is appreciated. I suspect the cause lies somewhere between Second Wave Options and Nexerelin? I've only added Second Wave Options in this playthrough, and I've previously been able to be friendly with remnants.

Thank you!

Installed mods:
Adjustable Automated Ships 1.0.0
Adjusted Sector 0.3.3
Console Commands 2021.4.10
Detailed Combat Results 5.1.2
High Tech Expansion 1.4.5
Industrial Evolution 2.2.f
LazyLib 2.6
MagicLib 0.34
Nexerelin 0.10.2c
Second Wave Options 0.6.5
Terraforming and Station Construction 7.1.3
Modified Industry Requirements

3
General Discussion / Re: Anti-Phase system and equipment needed
« on: June 08, 2021, 05:12:06 PM »
I find phase lance / tachyon lance on turreted mounts to be effective against phase ships. There's a 2 second cool down on phase cloaks, and the ships themselves have lighter weapons. So if you trick the AI into uncloaking in your range, you can quickly kill it. They also cost around double DP compared to ships of the same class with relatively little firepower (except doom), so you can either devote a larger ship to them, fighter strike as above poster mentioned, or ignore them to fight the non-phase guys. 

The only phase fleet I've had trouble with in vanilla is a particular triple-doom fleet.. but those aren't commonly seen.

4
General Discussion / Re: I'm having a blast!
« on: June 08, 2021, 04:59:15 PM »
There really isn't as much positive feedback on here as the game deserves. Ever since getting it a couple of months ago, Starsector has become my go-to game and I'm really enjoying it as well. A big shoutout to Alex and all the modders!

5
Bug Reports & Support (modded) / Re: Fleet quality won't improve
« on: June 06, 2021, 07:18:03 AM »
I had the same problem, and fixed by updating industrial evolution.

It basically didn't think my heavy industry existed and has the cross faction penalty as well as no bonuses from nanoforge.

6
As a quick update:

After going around and doing more stuff, I eventually came back and was able to approach the station. The station spawned two Hegemony special task forces with multiple triple S-mod ships each. I'm not sure what caused such a jump in ship quality tbh, since the rest of their fleets were regular or D-mod.

So I guess I'm personally past this hurdle, but since I'm not sure what caused it maybe it can happen again.

7
Thanks for the reply! Here's a link to the save files, since they're too big to attach here: https://mega.nz/file/YGRzDaJJ#bV5O4uJ0tmlFCIeyFQ1T-bNzTHzUpjRJV9TJgj1jFBc


I haven't been noticing many S-mods from fleets. It's about 3 cycles into the game, and most of the settings are default.

8
I'm playing the derelict empire scenario with Nexerelin. I've played regular games with the same mod set before with no problems, so I think it might be something related to derelict empire.

I got a bounty quest from the remnant quest giver at Prism for a Hegemony planet that was conquered from the Derelicts. When I approach the station, this crash occurs.

I've tried waiting a bit or going by a different route, but it always crashes when I get maybe a screen and a half away. Sometimes I see a hegemony fleet spawning just before the crash, which might be related to the error message.

Thanks for any help!

Crash log:
Code
249397 [Thread-3] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.ArrayIndexOutOfBoundsException: -1
java.lang.ArrayIndexOutOfBoundsException: -1
at java.util.ArrayList.elementData(Unknown Source)
at java.util.ArrayList.get(Unknown Source)
at com.fs.starfarer.api.plugins.impl.CoreAutofitPlugin.doFit(CoreAutofitPlugin.java:464)
at com.fs.starfarer.api.impl.campaign.fleets.DefaultFleetInflater.inflate(DefaultFleetInflater.java:422)
at com.fs.starfarer.campaign.fleet.CampaignFleet.inflateIfNeeded(Unknown Source)
at com.fs.starfarer.campaign.ai.TacticalModule.hasEnoughStuffAround(Unknown Source)
at com.fs.starfarer.campaign.ai.TacticalModule.advance(Unknown Source)
at com.fs.starfarer.campaign.ai.ModularFleetAI.advance(Unknown Source)
at com.fs.starfarer.campaign.fleet.CampaignFleet.advance(Unknown Source)
at com.fs.starfarer.campaign.BaseLocation.advance(Unknown Source)
at com.fs.starfarer.campaign.StarSystem.advance(Unknown Source)
at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
at com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
at com.fs.state.AppDriver.begin(Unknown Source)
at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Enabled Mods:
Adjustable Automated Ships 1.0.0
Adjusted Sector 0.3.3
Console Commands 2021.4.10
Detailed Combat Results 5.1.2
High Tech Expansion 1.4.3
Industrial Evolution 2.2.d
LazyLib 2.6
MagicLib 0.34
Nexerelin 0.10.2b
Terraforming and Station Construction 7.1.3
ZZ_Modified Industry Requirements - editable


Pages: [1]