Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.95a is out! (03/26/21); Blog post: Skill Changes, Part 2 (07/15/21)

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - onychannel

Pages: [1]
1
Hey, just wanted to drop this error I received for RS - didn't crash the game though:

3739005 [Thread-4] ERROR ruthless_sector.ModPlugin  - null
    com.fs.starfarer.api.impl.campaign.fleets.DefaultFleetInflater.inflate(DefaultFleetInflater.java:296)
    com.fs.starfarer.campaign.fleet.CampaignFleet.inflateIfNeeded(Unknown Source)
    ruthless_sector.CampaignScript.advance(CampaignScript.java:65)
    com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
    com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
    com.fs.starfarer.BaseGameState.traverse(Unknown Source)
    com.fs.state.AppDriver.begin(Unknown Source)
    com.fs.starfarer.combat.CombatMain.main(Unknown Source)
    com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
    java.lang.Thread.run(Thread.java:748)

3739016 [Thread-4] ERROR ruthless_sector.ModPlugin  - null
    com.fs.starfarer.api.impl.campaign.fleets.DefaultFleetInflater.inflate(DefaultFleetInflater.java:296)
    com.fs.starfarer.campaign.fleet.CampaignFleet.inflateIfNeeded(Unknown Source)
    ruthless_sector.CampaignScript.advance(CampaignScript.java:65)
    com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
    com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
    com.fs.starfarer.BaseGameState.traverse(Unknown Source)
    com.fs.state.AppDriver.begin(Unknown Source)
    com.fs.starfarer.combat.CombatMain.main(Unknown Source)
    com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
    java.lang.Thread.run(Thread.java:748)

3739029 [Thread-4] ERROR ruthless_sector.ModPlugin  - null
    com.fs.starfarer.api.impl.campaign.fleets.DefaultFleetInflater.inflate(DefaultFleetInflater.java:296)
    com.fs.starfarer.campaign.fleet.CampaignFleet.inflateIfNeeded(Unknown Source)
    ruthless_sector.CampaignScript.advance(CampaignScript.java:65)
    com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
    com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
    com.fs.starfarer.BaseGameState.traverse(Unknown Source)
    com.fs.state.AppDriver.begin(Unknown Source)
    com.fs.starfarer.combat.CombatMain.main(Unknown Source)
    com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
    java.lang.Thread.run(Thread.java:748)

3739040 [Thread-4] ERROR ruthless_sector.ModPlugin  - null
    com.fs.starfarer.api.impl.campaign.fleets.DefaultFleetInflater.inflate(DefaultFleetInflater.java:296)
    com.fs.starfarer.campaign.fleet.CampaignFleet.inflateIfNeeded(Unknown Source)
    ruthless_sector.CampaignScript.advance(CampaignScript.java:65)
    com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
    com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
    com.fs.starfarer.BaseGameState.traverse(Unknown Source)
    com.fs.state.AppDriver.begin(Unknown Source)
    com.fs.starfarer.combat.CombatMain.main(Unknown Source)
    com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
    java.lang.Thread.run(Thread.java:748)

3739053 [Thread-4] ERROR ruthless_sector.ModPlugin  - null
    com.fs.starfarer.api.impl.campaign.fleets.DefaultFleetInflater.inflate(DefaultFleetInflater.java:296)
    com.fs.starfarer.campaign.fleet.CampaignFleet.inflateIfNeeded(Unknown Source)
    ruthless_sector.CampaignScript.advance(CampaignScript.java:65)
    com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
    com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
    com.fs.starfarer.BaseGameState.traverse(Unknown Source)
    com.fs.state.AppDriver.begin(Unknown Source)
    com.fs.starfarer.combat.CombatMain.main(Unknown Source)
    com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
    java.lang.Thread.run(Thread.java:748)

3739066 [Thread-4] ERROR ruthless_sector.ModPlugin  - null
    com.fs.starfarer.api.impl.campaign.fleets.DefaultFleetInflater.inflate(DefaultFleetInflater.java:296)
    com.fs.starfarer.campaign.fleet.CampaignFleet.inflateIfNeeded(Unknown Source)
    ruthless_sector.CampaignScript.advance(CampaignScript.java:65)
    com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
    com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
    com.fs.starfarer.BaseGameState.traverse(Unknown Source)
    com.fs.state.AppDriver.begin(Unknown Source)
    com.fs.starfarer.combat.CombatMain.main(Unknown Source)
    com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
    java.lang.Thread.run(Thread.java:748)

2
Mods / Re: [0.9.1a] Kingdom of Terra (v0.10) - The hiatus-slaying update
« on: August 26, 2020, 12:43:48 PM »
also, can integral density be stacked on, say the quetz to have a silly amount of hullmass?

3
Mods / Re: [0.9.1a] More HullMods 1.3.0
« on: August 25, 2020, 07:54:28 PM »
is it intended for unstable shields to be flat better on ships with worse than 1.25 shield efficiency?, conquest for example with 1.4. just thinking about balance for certain ships like the conq or the scy lion

4
Mods / Re: [0.9.1a] Kingdom of Terra (v0.10) - The hiatus-slaying update
« on: August 25, 2020, 07:52:17 PM »
just want to ask real quick. when piloting the quetz is it 'intended' to be able to coil and launch yourself like a bowling ball at 500-600 speed?

5
Mods / Re: [0.9.1a] prv Starworks v17 (2020-07-10)
« on: August 14, 2020, 12:06:06 PM »
I encountered an issue with the Valljud in the most recent update, it appears to create the old disruption mine instead of the disruption zone. I checked the ships.csv and it is listed and the disruption mine. not sure what other info to provide atm

6
I'm encountering an issue where one of my two variable assemblers is not creating the heavy machinery it should.
I have 2 colonies, one i colonised myself, one is a pirate base I bought.
The pirate base is my default deposit with a variable manufactory, beta core and the marines/arms VPC, which is working just fine.
The other is a Variable Assembler with a beta core and the heavy machinery VPC, and says it produces 0, but afaik there is no disruption to the required supplies for the assembler. It is supposedly also delivering 0 to my other colony.

I'm not sure whether this is an issue with the fact that the pirate base is not technically mine because i bought it, or something else. The two colonies are in different systems.

Luddic Church wanted to satbomb the heresy out of me so i no longer have the 2nd colony to check whether it would still be an issue when upgraded to a manufactory

7
Mods / Re: [0.9.1a] Terraforming and Station Construction (v5.4.0)
« on: July 24, 2020, 06:11:14 PM »
>The variable assembler is from the Industrial Evolution mod, not this one. You'll probably have better luck sorting this out by asking in the thread for that mod.

Apologies, too many mods.


8
Mods / Re: [0.9.1a] Terraforming and Station Construction (v5.4.0)
« on: July 24, 2020, 04:32:38 PM »
Also I should clarify that the two colonies are not in the same constellation (approax 4ly away)

9
Shield bypass, from my experience, doesn't seem to be designed to work when you add a makeshift shield generator or any shield upgrades, which makes sense. This probably applies to the imported shields too.

I had a feeling it would work this way but I wanted to ask regardless, cheers.

10
Mods / Re: [0.9.1a] Terraforming and Station Construction (v5.4.0)
« on: July 24, 2020, 04:29:50 PM »
I'm encountering an issue where one of my two variable assemblers is not creating the heavy machinery it should.
I have 2 colonies, one i colonised myself, one is a pirate base I bought.
The pirate base is my default deposit with a variable manufactory, beta core and the marines/arms VPC, which is working just fine.
The other is a Variable Assembler with a beta core and the heavy machinery VPC, and says it produces 0, but afaik there is no disruption to the required supplies for the assembler. It is supposedly also delivering 0 to my other colony.

I'm not sure whether this is an issue with the fact that the pirate base is not technically mine because i bought it, or something else.


11
>Iirc, Shield Bypass won't work if the ship doesn't have a shield to begin with? I'm not so sure, it's been a long time.

Shine ray has a shield through a hullmod [imported shield generator], i assume that the shield being a hullmod is the reason this doesn't work


12
The Shine ray does not benefit from the Yuri Void Warfare Doctrine additional missile effect, I think it's because the Halo Drone Frigates it can launch count as Common rather than Yuri.

Additionally, the Yuri Void Warfare Doctrine for me states:
"... As such, this ship can store Makeshift Shield Generator more missile ammo ..."

As far as I can tell, there is no indicator that Yuri ships cannot mount Shield Bypass from SWP.

Also, what IS the Targeting Laser for?

Edit: Also to clarify I am not using the Commissioned Crew mod.

Pages: [1]