Fractal Softworks Forum

Starsector => Bug Reports & Support => Topic started by: dogigy on February 19, 2015, 05:15:48 PM

Title: null? error
Post by: dogigy on February 19, 2015, 05:15:48 PM
my mods are [0.65.2a] Starsector+ Vanilla Enhancement Mod 2.6.1 and all the mods compatible which are Download Interstellar Imperium 1.7 (Updated!)
Download The Knights Templar 0.9.4 (Updated!)
Download Blackrock Drive Yards 0.7.1 (Updated!)
Download Exigency Incorporated 0.7 (Updated!)

Spoiler
436686 [Thread-5] INFO  data.scripts.world.fleets.SSP_MercAndPirateFleetManager  - Maximum number of 4 pirate/merc fleets already in play for market [Perinthus]
436765 [Thread-5] INFO  com.fs.starfarer.api.impl.campaign.shared.MarketConnectionActivityData  - Updating connection: [port_tse_ii_aleria_market]: trade (s: 1, l: 1), smuggling: (s: 0, l: 0)
437321 [Thread-5] ERROR com.fs.starfarer.combat.D  - java.util.ConcurrentModificationException
java.util.ConcurrentModificationException
   at java.util.ArrayList$Itr.checkForComodification(Unknown Source)
   at java.util.ArrayList$Itr.next(Unknown Source)
   at data.scripts.campaign.events.II_SiegeEvent$MarketDamage.advance(II_SiegeEvent.java:523)
   at com.fs.starfarer.campaign.BaseCampaignEntity.advance(Unknown Source)
   at com.fs.starfarer.campaign.CampaignPlanet.advance(Unknown Source)
   at com.fs.starfarer.campaign.BaseLocation.advance(Unknown Source)
   at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
   at com.fs.starfarer.campaign.ooOO.super(Unknown Source)
   at com.fs.starfarer.new.Òôo000(Unknown Source)
   at com.fs.oOOO.oOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.Ò00000(Unknown Source)
   at com.fs.starfarer.combat.D.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$2.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
437465 [Thread-11] INFO  sound.O  - Creating streaming player for music with id [Unknown.ogg]
437465 [Thread-11] INFO  sound.OooOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOO  - Playing music with id [Unknown.ogg]
[close]
Title: Re: null? error
Post by: MesoTroniK on February 19, 2015, 05:31:28 PM
You need to update the Interstellar Imperium mod, it had a hotfix to correct that crash.
Title: Re: null? error
Post by: dogigy on February 19, 2015, 06:29:22 PM
that fixed it thanks