Fractal Softworks Forum
September 22, 2017, 10:41:46 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New blog post: Economy & Outposts (9/19/17); Starsector 0.8.1a is out!
 
   Home   Help Search Login Register  
Pages: 1 ... 83 84 [85] 86 87 ... 103
  Print  
Author Topic: [0.8.1a] Nexerelin v0.8.2c "Pillage, then Burn" (hotfix2 2017-09-17)  (Read 361750 times)
DrakonST
Commander
***
Posts: 194


Lizard-Wizard


View Profile
« Reply #1260 on: March 27, 2017, 10:42:07 PM »

It seems it is an error of it mod.
Code:
9045312 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
at com.fs.starfarer.campaign.ui.trade.CargoItemStack.readResolve(Unknown Source)
at com.fs.starfarer.campaign.ui.trade.CargoItemStack.<init>(Unknown Source)
at com.fs.starfarer.campaign.fleet.CargoData.addItems(Unknown Source)
at com.fs.starfarer.campaign.fleet.CargoData.addWeapons(Unknown Source)
at data.scripts.campaign.submarkets.DS_SubmarketUtils.addWeaponsForRolePicks(DS_SubmarketUtils.java:147)
at data.scripts.campaign.submarkets.DS_SubmarketUtils.addBlackMarketWeapons(DS_SubmarketUtils.java:178)
at data.scripts.campaign.submarkets.DS_BlackMarketPlugin.updateCargoPrePlayerInteraction(DS_BlackMarketPlugin.java:105)
at exerelin.utilities.ExerelinUtilsMarket.refreshMarket(ExerelinUtilsMarket.java:173)
at exerelin.campaign.InvasionRound.AttackMarket(InvasionRound.java:342)
at exerelin.world.InvasionFleetAI.advance(InvasionFleetAI.java:140)
at com.fs.starfarer.campaign.BaseCampaignEntity.runScripts(Unknown Source)
at com.fs.starfarer.campaign.BaseCampaignEntity.advance(Unknown Source)
at com.fs.starfarer.campaign.fleet.CampaignFleet.advance(Unknown Source)
at com.fs.starfarer.campaign.BaseLocation.advance(Unknown Source)
at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
at com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
at com.fs.state.AppDriver.begin(Unknown Source)
at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Logged

I a Russian. And i communicate with the help of Promt Translate. And I am a color-blind person.
Midnight Kitsune
Admiral
*****
Posts: 2095


Your Friendly Forum Furry!


View Profile
« Reply #1261 on: March 27, 2017, 11:37:34 PM »

It seems it is an error of it mod.
Code:
9045312 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
at com.fs.starfarer.campaign.ui.trade.CargoItemStack.readResolve(Unknown Source)
at com.fs.starfarer.campaign.ui.trade.CargoItemStack.<init>(Unknown Source)
at com.fs.starfarer.campaign.fleet.CargoData.addItems(Unknown Source)
at com.fs.starfarer.campaign.fleet.CargoData.addWeapons(Unknown Source)
at data.scripts.campaign.submarkets.DS_SubmarketUtils.addWeaponsForRolePicks(DS_SubmarketUtils.java:147)
at data.scripts.campaign.submarkets.DS_SubmarketUtils.addBlackMarketWeapons(DS_SubmarketUtils.java:178)
at data.scripts.campaign.submarkets.DS_BlackMarketPlugin.updateCargoPrePlayerInteraction(DS_BlackMarketPlugin.java:105)
at exerelin.utilities.ExerelinUtilsMarket.refreshMarket(ExerelinUtilsMarket.java:173)
at exerelin.campaign.InvasionRound.AttackMarket(InvasionRound.java:342)
at exerelin.world.InvasionFleetAI.advance(InvasionFleetAI.java:140)
at com.fs.starfarer.campaign.BaseCampaignEntity.runScripts(Unknown Source)
at com.fs.starfarer.campaign.BaseCampaignEntity.advance(Unknown Source)
at com.fs.starfarer.campaign.fleet.CampaignFleet.advance(Unknown Source)
at com.fs.starfarer.campaign.BaseLocation.advance(Unknown Source)
at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
at com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
at com.fs.state.AppDriver.begin(Unknown Source)
at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
mod list?
Logged

Stop trying to balance the game around a few minmaxers...
Programming is like sex:
One mistake and you have to support it for the rest of your life.

Tired of having your game crash because of out of date mods? Then click here!
Get Version Checker today! Now with 90% less hassle! Simply toss it into your mod folder, activate the mod like a normal one and BINGO you will now be informed of any and all updates when you start SS campaign up!
DrakonST
Commander
***
Posts: 194


Lizard-Wizard


View Profile
« Reply #1262 on: March 28, 2017, 12:30:11 AM »

It seems it is an error of it mod.
Code:
9045312 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.NullPointerException
java.lang.NullPointerException
at com.fs.starfarer.campaign.ui.trade.CargoItemStack.readResolve(Unknown Source)
at com.fs.starfarer.campaign.ui.trade.CargoItemStack.<init>(Unknown Source)
at com.fs.starfarer.campaign.fleet.CargoData.addItems(Unknown Source)
at com.fs.starfarer.campaign.fleet.CargoData.addWeapons(Unknown Source)
at data.scripts.campaign.submarkets.DS_SubmarketUtils.addWeaponsForRolePicks(DS_SubmarketUtils.java:147)
at data.scripts.campaign.submarkets.DS_SubmarketUtils.addBlackMarketWeapons(DS_SubmarketUtils.java:178)
at data.scripts.campaign.submarkets.DS_BlackMarketPlugin.updateCargoPrePlayerInteraction(DS_BlackMarketPlugin.java:105)
at exerelin.utilities.ExerelinUtilsMarket.refreshMarket(ExerelinUtilsMarket.java:173)
at exerelin.campaign.InvasionRound.AttackMarket(InvasionRound.java:342)
at exerelin.world.InvasionFleetAI.advance(InvasionFleetAI.java:140)
at com.fs.starfarer.campaign.BaseCampaignEntity.runScripts(Unknown Source)
at com.fs.starfarer.campaign.BaseCampaignEntity.advance(Unknown Source)
at com.fs.starfarer.campaign.fleet.CampaignFleet.advance(Unknown Source)
at com.fs.starfarer.campaign.BaseLocation.advance(Unknown Source)
at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
at com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
at com.fs.state.AppDriver.begin(Unknown Source)
at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
mod list?
- DynaSector 1.0.7
- Exigency 0.7.2
- GraphicsLib 1.0.2
- Interstellar Imperium 1.15.0
- LazyLib 2.1
- Nexerelin 0.7.7
- Extra Salvage/Boarding 1.43
- Ship and Weapon Pack 1.1.4
- Starsector Plus 3.6.0
- Templars 0.9.6b
- TORCHSHIPS 1.0
- Underworld 1.0.5
Logged

I a Russian. And i communicate with the help of Promt Translate. And I am a color-blind person.
Orikson
Captain
****
Posts: 276

Always Seen on Discord


View Profile Email
« Reply #1263 on: March 28, 2017, 05:08:37 AM »

Your GraphicsLibs, LazyLib and Starsector+ are outdated (current version of GraphicsLib is 1.0.4), (current version of LazyLib is 2.1b), (current version of Starsector+ is 3.6.1).

I'm not sure, but Extra Salvage/Boarding might also be causing problems.
« Last Edit: March 28, 2017, 05:11:02 AM by Orikson » Logged

"A story teller and a trader. Tell me your tales and I'll tell you no lies."

Come join the Starsector Fan Chat! It's decently active.

Link: https://discord.gg/eb5UC
Sy
Admiral
*****
Posts: 1069



View Profile Email
« Reply #1264 on: March 28, 2017, 05:21:19 AM »

@DrakonST: use Version Checker, then you won't have problems with missing mod updates.
Logged
DrakonST
Commander
***
Posts: 194


Lizard-Wizard


View Profile
« Reply #1265 on: March 28, 2017, 05:36:14 AM »

All right. I will go to download the updated fashion. But "Version Checker" to me it isn't necessary. It is too much fuss.
Logged

I a Russian. And i communicate with the help of Promt Translate. And I am a color-blind person.
Midnight Kitsune
Admiral
*****
Posts: 2095


Your Friendly Forum Furry!


View Profile
« Reply #1266 on: March 28, 2017, 06:27:27 AM »

All right. I will go to download the updated fashion. But "Version Checker" to me it isn't necessary. It is too much fuss.
What do you mean? If you mean how you needed to change the VMPRAMS file before, you don't now. It works like any other mod now
Logged

Stop trying to balance the game around a few minmaxers...
Programming is like sex:
One mistake and you have to support it for the rest of your life.

Tired of having your game crash because of out of date mods? Then click here!
Get Version Checker today! Now with 90% less hassle! Simply toss it into your mod folder, activate the mod like a normal one and BINGO you will now be informed of any and all updates when you start SS campaign up!
Sy
Admiral
*****
Posts: 1069



View Profile Email
« Reply #1267 on: March 28, 2017, 11:44:54 AM »

just using Version Checker to know when to update your mods would've been a fraction of the effort of having your game crash and ask for help here. Tongue
Logged
DrakonST
Commander
***
Posts: 194


Lizard-Wizard


View Profile
« Reply #1268 on: March 28, 2017, 01:15:37 PM »

All right. I will go to download the updated fashion. But "Version Checker" to me it isn't necessary. It is too much fuss.
What do you mean? If you mean how you needed to change the VMPRAMS file before, you don't now. It works like any other mod now
The Internet for his work is necessary. And he will constantly report about outdated mods(like "Valkyrians", my portraits mod or redacted version "Starsector+") which he isn't outdated.
« Last Edit: March 28, 2017, 01:17:36 PM by DrakonST » Logged

I a Russian. And i communicate with the help of Promt Translate. And I am a color-blind person.
Probe1
Ensign
*
Posts: 7


View Profile
« Reply #1269 on: April 05, 2017, 08:45:24 AM »

Thank  you for your diligent and explanatory commenting in the code.  It is extremely appreciated.
Logged
Blaze
Commander
***
Posts: 219


View Profile
« Reply #1270 on: April 05, 2017, 06:35:51 PM »

Not sure if it's Nexerelin or Knights Templar but...

Logged
DrakonST
Commander
***
Posts: 194


Lizard-Wizard


View Profile
« Reply #1271 on: April 08, 2017, 09:15:58 AM »

Incorrect text. It is displayed on followers planets if consists in alliance.
Logged

I a Russian. And i communicate with the help of Promt Translate. And I am a color-blind person.
Histidine
Admiral
*****
Posts: 1614



View Profile WWW Email
« Reply #1272 on: April 08, 2017, 07:51:58 PM »

Found and fixed both issues, thanks!
Logged

DrakonST
Commander
***
Posts: 194


Lizard-Wizard


View Profile
« Reply #1273 on: April 09, 2017, 05:20:38 AM »

Maybe it is worth returning an old method drop prisoners? It seems to me them it is given too much. From 5 to 40 for fight. Just look how many them I have received for the company.
But I have organized a party on this money.
Logged

I a Russian. And i communicate with the help of Promt Translate. And I am a color-blind person.
Histidine
Admiral
*****
Posts: 1614



View Profile WWW Email
« Reply #1274 on: April 11, 2017, 05:54:54 AM »

Early update for DynaSector compatibility.


Changelog
Code:
v0.7.7b
* Compatibility update for new DynaSector version
* Add Frankenstein IBB to Prism ship list
* Lower prisoner drop rate from officers in enemy fleet (less than half overall)
* Templar invasion point mult 0.4 -> 0.3
* Scrolling notification messages on war/peace state change between the player and another faction/alliance
* More specificity on which diplomacy events pirates can use
* Prism: Fix IBB renewal config option; fix handling of IBB fighter wings
* Fix Exigency mysterious_contact handling
* Fix a possible crash with broken faction configs
* Fix SetRelationship not working when player-aligned faction is passed as an arg
* Some text fixes/cleanups
Logged

Pages: 1 ... 83 84 [85] 86 87 ... 103
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines
Simple Audio Video Embedder
Valid XHTML 1.0! Valid CSS!