Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.9.1a is out! (05/10/19); Blog post: Skills and Story Points (07/08/19)

Pages: 1 ... 75 76 [77] 78 79 ... 83

Author Topic: [0.9.1a] Scy V1.57 (2019/09/04)  (Read 559994 times)

Tartiflette

  • Admiral
  • *****
  • Posts: 2758
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.9.0a] Scy V1.53 (2019/01/05)
« Reply #1140 on: January 05, 2019, 08:39:05 AM »



Preemptive update for Nexerelin, also includes some minor balancing tweaks as well as some redundant content culling. THIS UPDATE WILL BREAK SAVES!

Download link in the first post.

Changelog:
Spoiler
1.53

 - Updated compatibility with Nexerelin.

REMOVED CONTENT to reduce clutter:
 - Rocket pods mk 1 - 2 - 3
 - Cluster torpedo Rack (pod stays)
 - Coasting missile Rack (pod stays)
 - Light flak gun
 - Oscillating beam
 - Defense Autonailer
 - Beehive Nailer
 - Geryon (H) (was unused)
Variants adjusted using vanilla weapons.

BALANCING:
 - Eris interceptor OP cost raised to 2 from 0.
 - Akhlys wing role is now SUPPORT from INTERCEPTOR.
 - All fighters got the "no_weapon_flux" hullmod like vanilla, flux stats adjusted accordingly.
 - Minimal Preparation hullmod now incompatible with Militarized Subsystems and Efficiency Overhaul.
 - Large weapons costs reduced (still on the expensive side).

BUGFIXES/IMPROVEMENTS:
 - Shuffled some blueprints, neither package contains any capital ship like the vanilla packages.
 - Deactivated the "material maps" for GraphicLib, that had only a minor visual impact but significantly increased VRam usage.
[close]
Logged
 

FERNANDOHYDE

  • Ensign
  • *
  • Posts: 4
    • View Profile
Re: [0.9.0a] Scy V1.53 (2019/01/05)
« Reply #1141 on: January 05, 2019, 09:58:33 AM »

I think the prism freeport is still looking for the weapons you removed.  If I try to go to acheron's domain I get an error that the nailer can't be found and then a CTD after jumping in. Here's the log:

Quote
136097 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Weapon spec [SCY_nailer] not found!
java.lang.RuntimeException: Weapon spec [SCY_nailer] not found!
   at com.fs.starfarer.loading.Q.Ô00000(Unknown Source)
   at com.fs.starfarer.loading.SpecStore.o00000(Unknown Source)
   at com.fs.starfarer.loading.SpecStore.o00000(Unknown Source)
   at com.fs.starfarer.settings.StarfarerSettings$1.getWeaponSpec(Unknown Source)
   at com.fs.starfarer.api.impl.campaign.fleets.DefaultFleetInflater.inflate(DefaultFleetInflater.java:232)
   at com.fs.starfarer.campaign.fleet.CampaignFleet.inflateIfNeeded(Unknown Source)
   at com.fs.starfarer.ui.impl.StandardTooltipV2.createFleetTooltip(Unknown Source)
   at com.fs.starfarer.campaign.C.super(Unknown Source)
   at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
   at com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
   at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

As for adding factions to Prism's stock via prism_factions_whitelist.csv, I've managed to add sylphon but can't get others working.  For example adding 'dassault', 'dassault-mikoyan', 'dassaultmikoyan', 'DM', and  'DME' all fail to add Dassault-Mikoyan Engineering ships. Do I need to dig through the respective mod folder to find what I need?
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 2758
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.9.0a] Scy V1.53 (2019/01/05)
« Reply #1142 on: January 05, 2019, 10:23:46 AM »

Redownload Scy to fix the crash. As for Prism, check the ID in the data/world/factions files
Logged
 

FERNANDOHYDE

  • Ensign
  • *
  • Posts: 4
    • View Profile
Re: [0.9.0a] Scy V1.53 (2019/01/05)
« Reply #1143 on: January 05, 2019, 11:06:31 AM »

I re-downloaded but I am still getting the same crash and error, just delayed. Best I can tell it happens when a SCY fleet spawns in.
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 2758
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.9.0a] Scy V1.53 (2019/01/05)
« Reply #1144 on: January 05, 2019, 11:08:02 AM »

On a new save?
Logged
 

FERNANDOHYDE

  • Ensign
  • *
  • Posts: 4
    • View Profile
Re: [0.9.0a] Scy V1.53 (2019/01/05)
« Reply #1145 on: January 05, 2019, 11:38:33 AM »

I'm dumb, I didn't try a new save after redownloading. Everything seems to work now, thanks
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 2758
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.9.0a] Scy V1.53 (2019/01/05)
« Reply #1146 on: January 05, 2019, 12:09:02 PM »

I'm just glad that's sorted out. Enjoy the update!
Logged
 

grinningsphinx

  • Captain
  • ****
  • Posts: 256
    • View Profile
    • Email
Re: [0.9.0a] Scy V1.53 (2019/01/05)
« Reply #1147 on: January 06, 2019, 12:31:42 AM »

I'm just glad that's sorted out. Enjoy the update!


Run error:

   at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.RuntimeException: Weapon spec [SCY_rocket1] not found!
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 2758
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.9.0a] Scy V1.53 (2019/01/05)
« Reply #1148 on: January 06, 2019, 12:56:09 AM »

That lacks context to be sure but it really seems like the same bug: You are either not using the hotfixed version, or using a save from before that hotfix.
Logged
 

veinless

  • Ensign
  • *
  • Posts: 2
    • View Profile
    • Email
Re: [0.9.0a] Scy V1.53 (2019/01/05)
« Reply #1149 on: January 27, 2019, 08:58:59 AM »

Running the latest version, received this error when hovering over a fleet:

5967708 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Weapon spec [SCY_oscillating] not found!
java.lang.RuntimeException: Weapon spec [SCY_oscillating] not found!
   at com.fs.starfarer.loading.Q.Ô00000(Unknown Source)
   at com.fs.starfarer.loading.SpecStore.o00000(Unknown Source)
   at com.fs.starfarer.loading.SpecStore.o00000(Unknown Source)
   at com.fs.starfarer.settings.StarfarerSettings$1.getWeaponSpec(Unknown Source)
   at com.fs.starfarer.api.impl.campaign.fleets.DefaultFleetInflater.inflate(DefaultFleetInflater.java:232)
   at com.fs.starfarer.campaign.fleet.CampaignFleet.inflateIfNeeded(Unknown Source)
   at com.fs.starfarer.ui.impl.StandardTooltipV2.createFleetTooltip(Unknown Source)
   at com.fs.starfarer.campaign.C.super(Unknown Source)
   at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
   at com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
   at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
Logged

Avanitia

  • Lieutenant
  • **
  • Posts: 56
    • View Profile
Re: [0.9.0a] Scy V1.53 (2019/01/05)
« Reply #1150 on: January 27, 2019, 09:25:39 AM »

Spoiler
Running the latest version, received this error when hovering over a fleet:

5967708 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.RuntimeException: Weapon spec [SCY_oscillating] not found!
java.lang.RuntimeException: Weapon spec [SCY_oscillating] not found!
   at com.fs.starfarer.loading.Q.Ô00000(Unknown Source)
   at com.fs.starfarer.loading.SpecStore.o00000(Unknown Source)
   at com.fs.starfarer.loading.SpecStore.o00000(Unknown Source)
   at com.fs.starfarer.settings.StarfarerSettings$1.getWeaponSpec(Unknown Source)
   at com.fs.starfarer.api.impl.campaign.fleets.DefaultFleetInflater.inflate(DefaultFleetInflater.java:232)
   at com.fs.starfarer.campaign.fleet.CampaignFleet.inflateIfNeeded(Unknown Source)
   at com.fs.starfarer.ui.impl.StandardTooltipV2.createFleetTooltip(Unknown Source)
   at com.fs.starfarer.campaign.C.super(Unknown Source)
   at com.fs.starfarer.campaign.CampaignEngine.advance(Unknown Source)
   at com.fs.starfarer.campaign.CampaignState.advance(Unknown Source)
   at com.fs.starfarer.BaseGameState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

[close]

If you started a save before 1.53 version of SCY and updated the mod, it's going to happen.
1.53 update removed a bunch of weapons from SCY arsenal:

Spoiler
1.53

 - Updated compatibility with Nexerelin.

REMOVED CONTENT to reduce clutter:
 - Rocket pods mk 1 - 2 - 3
 - Cluster torpedo Rack (pod stays)
 - Coasting missile Rack (pod stays)
 - Light flak gun
 - Oscillating beam
 - Defense Autonailer
 - Beehive Nailer
 - Geryon (H) (was unused)
Variants adjusted using vanilla weapons.
[close]

You have 2 options now:
1. Start a new run
2. Get 1.52 version of SCY and use it in this run, update after you finish this run
Logged

veinless

  • Ensign
  • *
  • Posts: 2
    • View Profile
    • Email
Re: [0.9.0a] Scy V1.53 (2019/01/05)
« Reply #1151 on: January 27, 2019, 04:07:37 PM »

Awesome, thank you for the help!
Logged

Toranet

  • Ensign
  • *
  • Posts: 24
    • View Profile
    • Email
Re: [0.9.0a] Scy V1.53 (2019/01/05)
« Reply #1152 on: February 04, 2019, 06:41:33 AM »

Hey there, had somewhat similar issue with Inferno launchers lately so was able to figuire it out easier. There is an issue with Phase torpedo launcher, or the torpedoes actualy, when they unfase they crash the game. Here is the log:
 java.lang.NullPointerException
   at com.fs.starfarer.Object.int.o00000(Unknown Source)
   at com.fs.starfarer.combat.ai.missile.MirvAI.checkSplit(Unknown Source)
   at com.fs.starfarer.combat.ai.missile.MirvAI.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advanceInner(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatState.traverse(Unknown Source)
   at com.fs.state.AppDriver.begin(Unknown Source)
   at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
 Didnt know what launcher was used by that pirate station so took a bunch of them and was testing them one by one on atlas in simulation untill it crashed on phase torpedo.

 Same thing apparently happens with Ship/Weapon Pack inferno MIRV's and was in the past with Disassemble/Reassemble's Swift Burst Launcher on some PC's. I fixed the crash issue the same way by adding ["splitSound":"hurricane_mirv_fire",] to the "behaviorSpec" section of the weapon's .proj(SCY_phasedS.proj) file as Morathar told me in Ship/Weapon Pack thread but the torpedo itself is now broken as it stops doing anything as soon as it enters split range.
 I hope it will help)
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 2758
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.9.0a] Scy V1.53 (2019/01/05)
« Reply #1153 on: February 04, 2019, 09:45:15 AM »

Pretty sure that's because you have an outdated version of Starsector (current version is 0.9 RC10).
Logged
 

Harpuea

  • Ensign
  • *
  • Posts: 21
    • View Profile
Re: [0.9.0a] Scy V1.53 (2019/01/05)
« Reply #1154 on: February 24, 2019, 08:54:12 AM »

I would like to request a dedicated salvage ship and a troops transport with ground support package from the Scy Admiralty. Having to use other factions troop transports and salvage ship just ruins the scy fleet stealth signatures and speed.
Logged
Pages: 1 ... 75 76 [77] 78 79 ... 83