Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.9.1a is out! (05/10/19); Blog post: Skills and Story Points (07/08/19)

Pages: 1 ... 25 26 [27] 28 29 ... 83

Author Topic: [0.9.1a] Scy V1.57 (2019/09/04)  (Read 568334 times)

DefiasOne

  • Commander
  • ***
  • Posts: 199
    • View Profile
Re: [0.65.2a] Scy V0.88 Compatibility Update (13/02/2015)
« Reply #390 on: February 17, 2015, 06:36:34 AM »

Does it play nice with other mods as well, like Blackrock and such ? Maybe even Starsector+ ?
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 2782
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.65.2a] Scy V0.88 Compatibility Update (13/02/2015)
« Reply #391 on: February 17, 2015, 07:17:45 AM »

It sure does! I never play without either myself.
Logged
 

DefiasOne

  • Commander
  • ***
  • Posts: 199
    • View Profile
Re: [0.65.2a] Scy V0.88 Compatibility Update (13/02/2015)
« Reply #392 on: February 17, 2015, 07:25:30 AM »

Sweet, currently I'm trying to get the game to run with SCY, Blackrock, and Neutrino., but so far it keeps crashing. I have the latest shaderlib and lazylib. So thats why I ask :)

Not sure where to post this so might as well post it here:
91 [Thread-5] ERROR com.fs.starfarer.combat.O0OO  - java.lang.NoSuchMethodError: com.fs.starfarer.api.combat.CombatEngineAPI.getCustomData()Ljava/util/Map;
java.lang.NoSuchMethodError: com.fs.starfarer.api.combat.CombatEngineAPI.getCustomData()Ljava/util/Map;
   at org.dark.shaders.light.LightShader.initCombat(LightShader.java:604)
   at org.dark.shaders.util.ShaderHook.init(ShaderHook.java:93)
   at com.fs.starfarer.title.ooOO.float$Oo.o00000(Unknown Source)
   at com.fs.starfarer.combat.super.B.null(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.init(Unknown Source)
   at com.fs.starfarer.title.OoOO.Oöo000(Unknown Source)
   at com.fs.starfarer.B.null.class$super(Unknown Source)
   at com.fs.super.A.new(Unknown Source)
   at com.fs.starfarer.combat.O0OO.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$2.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

LE: Switching back to ShaderLib 1.03 from 1.04 fixed it.
« Last Edit: February 17, 2015, 07:28:43 AM by DefiasOne »
Logged

Dark.Revenant

  • Admiral
  • *****
  • Posts: 2537
    • View Profile
    • Sc2Mafia
    • Email
Re: [0.65.2a] Scy V0.88 Compatibility Update (13/02/2015)
« Reply #393 on: February 17, 2015, 09:13:03 AM »

You have to update the game to the hotfix that was released yesterday.
Logged

DefiasOne

  • Commander
  • ***
  • Posts: 199
    • View Profile
Re: [0.65.2a] Scy V0.88 Compatibility Update (13/02/2015)
« Reply #394 on: February 17, 2015, 09:43:02 AM »

Oh, didn't notice that hotfix  ::)

LE: Now I'm getting out of memory errors... :(
« Last Edit: February 17, 2015, 11:15:53 AM by DefiasOne »
Logged

Midnight Kitsune

  • Admiral
  • *****
  • Posts: 2642
  • Your Friendly Forum Friend
    • View Profile
Re: [0.65.2a] Scy V0.88 Compatibility Update (13/02/2015)
« Reply #395 on: February 17, 2015, 11:26:27 AM »

Oh, didn't notice that hotfix  ::)

LE: Now I'm getting out of memory errors... :(
Did you change your vmparams/ .bat file to their needed settings?
Logged
Stop trying to balance the game around a few minmaxers...
Programming is like sex:
One mistake and you have to support it for the rest of your life.

Tired of having your game crash because of out of date mods? Then click here!
Spoiler
Get Version Checker today! Now with 90% less hassle! Simply toss it into your mod folder, activate the mod like a normal one and BINGO you will now be informed of any and all updates when you start SS campaign up!
[close]

DefiasOne

  • Commander
  • ***
  • Posts: 199
    • View Profile
Re: [0.65.2a] Scy V0.88 Compatibility Update (13/02/2015)
« Reply #396 on: February 17, 2015, 11:29:52 AM »

Anything larger than 1024 for the xms and xmx settings results in the game refusing to start. Guess 4 gigs of ram just isn't enough o.O....
« Last Edit: February 17, 2015, 11:33:24 AM by DefiasOne »
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 2782
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.65.2a] Scy V0.88 Compatibility Update (13/02/2015)
« Reply #397 on: February 17, 2015, 11:49:44 AM »

If it crashes above 1024MB on launch, that means you aren't using Java 64bits. There is a stickied thread in the support section with the instructions.
Logged
 

DefiasOne

  • Commander
  • ***
  • Posts: 199
    • View Profile
Re: [0.65.2a] Scy V0.88 Compatibility Update (13/02/2015)
« Reply #398 on: February 17, 2015, 11:52:34 AM »

Yeah... forgot about the x64 issue ::), haven't played SS for a while now. Replaced the jre folder with 64bit version and now it runs  ;D Thanks.
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 2782
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.65.2a] Scy V0.88 Compatibility Update (13/02/2015)
« Reply #399 on: February 17, 2015, 05:41:27 PM »

Require Debido's TwigLib.
Require LazyWizzard's LazyLib.
Compatible with LazyWizzard's Version Checker.
Play nicely with other mods including Dark.Revenant's Starsector+

An even smaller update, only stuff to stay consistent with vanilla:
- No ammo on standard weapons.
- Clips on special weapons, usually small but with a decent regeneration. In other words, they are weaker in slugfest but are just the same with hit 'n run tactics.
- Some very special weapons still have a hard ammo cap, namely the Siren Main Gun and the ORION Artillery.
- The weapon that changed most is the Small Autonailer: it now has a small clip loading half as fast as it is depleted, but gain a significant range boost.

Changelog
Spoiler
Code
V0.89
18/02/2015
Further tweaks to ammo due to the HotPatch
The basic weapons are now unlimited
The advanced ones keep their clips, though now they have much less ammo stack and more ammo regen
Some very special ones (ORION artillery, Siren Main Gun) still have a hard limit on ammo.

The weapon that changed most is the Small Autonailer: it now has a small clip loading half as fast as it is depleted, but gain a significant range boost.
[close]
« Last Edit: February 18, 2015, 01:38:10 AM by Tartiflette »
Logged
 

Sleeeper

  • Ensign
  • *
  • Posts: 23
    • View Profile
Re: [0.65.2aRC2] Scy V0.89 Compatibility Update... Again (18/02/2015)
« Reply #400 on: February 17, 2015, 09:00:52 PM »

Some case mismatches in Linux crashing game :P

[sounds/SCY/sfx_weapons/SCY_KBeam_arcs.ogg]
[sounds/SCY/sfx_weapons/SCY_KBeam_loop.ogg]
[sounds/SCY/sfx_weapons/SCY_KBeam_intro.ogg]

.json has 'KBeam' and files have 'Kbeam'
« Last Edit: February 17, 2015, 09:04:01 PM by Sleeeper »
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 2782
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.65.2aRC2] Scy V0.89 Compatibility Update... Again (18/02/2015)
« Reply #401 on: February 18, 2015, 12:39:56 AM »

Aw COME ON! Again? Why the hell bittbucket don't upload the renamed files? It does that every single update with those!
[edit] sneakily uploaded a corrected version (I hope)
« Last Edit: February 18, 2015, 01:38:51 AM by Tartiflette »
Logged
 

TartarusMkII

  • Commander
  • ***
  • Posts: 164
    • View Profile
    • Email
Re: [0.65.2a] Scy V0.89 Compatibility Update... Again (18/02/2015)
« Reply #402 on: February 18, 2015, 03:07:42 AM »

Hey, having an issue: I am using SS+ as well as pretty much all of the faction mods that are up to date for 65.2a-rc2 (which is not many.)

I started my game as Tachyon and then raided my way around some vanilla systems until I got to Acheron. I went into Acheron, killed a bounty, then went to Tartarus. It seems to work fine, the system is alive and well, but when I try to view the trade screen of Elysee, I just get a blank screen, and I can't get out of the menu.
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 2782
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.65.2a] Scy V0.89 Compatibility Update... Again (18/02/2015)
« Reply #403 on: February 18, 2015, 05:10:39 AM »

That's weird! You can't trade with Elysee directly, you have to dock to Hephaistos for that, but you should have the option to leave. I don't know what to say, it works fine with everyone else...
Logged
 

Toxcity

  • Admiral
  • *****
  • Posts: 541
    • View Profile
Re: [0.65.2a] Scy V0.89 Compatibility Update... Again (18/02/2015)
« Reply #404 on: February 18, 2015, 07:58:56 AM »

Thanks for the update. One thing though is that when I use the loadsave command, a lamia prototype is loaded into my fleet.
Logged
Pages: 1 ... 25 26 [27] 28 29 ... 83