Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.9.1a is out! (05/10/19); Blog post: Skills and Story Points (07/08/19)

Pages: 1 ... 16 17 [18] 19 20 ... 83

Author Topic: [0.9.1a] Scy V1.57 (2019/09/04)  (Read 560570 times)

Tartiflette

  • Admiral
  • *****
  • Posts: 2759
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.65.1a] Scy V0.86 (01/12) Hotfix
« Reply #255 on: December 01, 2014, 07:58:10 AM »

Tartiflette, any chance we'll see fighter's trails again?
Not without some help from Alex, whether he makes them vanilla or allow us to spawn object that are ignored by the AI: the trail were invisible fake missiles placed on top of the engines when the fighter were accelerating and removed otherwise. Problem is, the Point Defense weapons went crazy when those missiles kept appearing and vanishing at close range. They switched targets all the time to face the "new threat" and never actually fired.

And here is something I think I didn't understand about Khalkotauroi's hull parts. What is this?
That's because each pod is it's own wing. I wanted them to have their own sprite with the number and the blue stripe that span the whole ship. It they were part of the same wing they would have the same sprite.

Come to think of it, what do the Accelerator Pods do?
I keep getting them smashed to pieces when I deploy the Khal-really-long-name, but I dont see any obvious drop in the power of the laser.
Really???


Logged
 

jupjupy

  • Commander
  • ***
  • Posts: 122
    • View Profile
    • Email
Re: [0.65.1a] Scy V0.86 (01/12) Hotfix
« Reply #256 on: December 01, 2014, 11:54:58 AM »

Really???

Hmm, this is certainly interesting. Might be because I was playing back when the pods were still weapons on the ship (ie without TwigLib). Dont know if it worked then, but since they used to be able to be repaired in-battle that might have been the reason.
Logged
You see, Araragi-san, in a way, the supernatural is what's behind the curtain.
Normally, you only need to see what's happening on stage. That's how reality works.

TartarusMkII

  • Commander
  • ***
  • Posts: 164
    • View Profile
    • Email
Re: [0.65.1a] Scy V0.86 (01/12) Hotfix
« Reply #257 on: December 07, 2014, 01:23:45 AM »

I was *** around, and found that even on a fresh new game, trying to spawn a Nemean Lion-class Elite Battle Fortress in the simulator causes an instant crash as soon as I tab-out to begin fighting. The errors I get in the .log are "unable to spawn nodes", NullPointerExceptions, involving NemeanRootShip. Also SCY_ArmorPlating.advanceInCombat. If you need more info, I can move the .log file to the right PC to add it to this post.

I am also using the Simulator Overhaul 1.0 mod with Star Sector + (they conflict, but only in functionality, not in any fatal way.)

After disabling the overhaul mod, I still crash in the same way when doing the same thing.

Is this known / intentional? Thanks.
Logged

Nanao-kun

  • Admiral
  • *****
  • Posts: 816
    • View Profile
    • Email
Re: [0.65.1a] Scy V0.86 (01/12) Hotfix
« Reply #258 on: December 07, 2014, 01:36:43 AM »

I was *** around, and found that even on a fresh new game, trying to spawn a Nemean Lion-class Elite Battle Fortress in the simulator causes an instant crash as soon as I tab-out to begin fighting. The errors I get in the .log are "unable to spawn nodes", NullPointerExceptions, involving NemeanRootShip. Also SCY_ArmorPlating.advanceInCombat. If you need more info, I can move the .log file to the right PC to add it to this post.

I am also using the Simulator Overhaul 1.0 mod with Star Sector + (they conflict, but only in functionality, not in any fatal way.)

After disabling the overhaul mod, I still crash in the same way when doing the same thing.

Is this known / intentional? Thanks.
You probably don't have TwigLib.

http://fractalsoftworks.com/forum/index.php?topic=8266.0
Logged

TartarusMkII

  • Commander
  • ***
  • Posts: 164
    • View Profile
    • Email
Re: [0.65.1a] Scy V0.86 (01/12) Hotfix
« Reply #259 on: December 07, 2014, 01:40:15 AM »

Hi again Nanao-Kun!

By checking the mod loading section, I see that I do indeed have TwigLib 0.6.5p, the current version.
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 2759
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.65.1a] Scy V0.86 (01/12) Hotfix
« Reply #260 on: December 07, 2014, 02:08:12 AM »

Also,you probably are still using Scy 0.85: In 0.86 you now get a warning when trying to launch the mod without LazyLib or TwigLib (unfortunately, it comes at the end of the loading).
[edit] Version Checker is really useful for that, if a bit more complicated to instal than your average mod.
« Last Edit: December 07, 2014, 02:24:11 AM by Tartiflette »
Logged
 

TartarusMkII

  • Commander
  • ***
  • Posts: 164
    • View Profile
    • Email
Re: [0.65.1a] Scy V0.86 (01/12) Hotfix
« Reply #261 on: December 07, 2014, 02:16:52 AM »

Ah, I noticed I am still using SCY v0.8. I'll update and try it again, then update this post.

I used the link on the first post of this thread which is graphically titled SCY 0.86. In the mod loader, it is listed as Scy 0.8. Either way, trying to load the Nemean causes a crash all the same.
« Last Edit: December 07, 2014, 02:22:47 AM by TartarusMkII »
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 2759
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.65.1a] Scy V0.86 (01/12) Hotfix
« Reply #262 on: December 07, 2014, 02:30:44 AM »

Oooookay, that's a problem! Works fine here, so I'll need you to post the error end in the end of the log plus a few lines, to inspect what's going on (for the number in the loader, that's just something I forgot to change, no worries, I'll take care of that after your problem)
Logged
 

TartarusMkII

  • Commander
  • ***
  • Posts: 164
    • View Profile
    • Email
Re: [0.65.1a] Scy V0.86 (01/12) Hotfix
« Reply #263 on: December 07, 2014, 02:32:24 AM »

Okay, I am glad to help. I actually just shut down my gaming PC for the night; I'll gladly generate the error again tomorrow when I wake up. Have a good day! =P
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 2759
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.65.1a] Scy V0.86 (01/12) Hotfix
« Reply #264 on: December 07, 2014, 02:54:09 AM »

Nope, no luck, I tried all combinations with and without StarSector+ and Simulator overhaul and it works like a charm, as long as you have the latest TwigLib active.

...

Say...

When you updated Scy and TwigLib, did you removed them before? Because that could definitively explain your error!
As a general rule, never override a mod when updating: remove them before extracting the new version.
Logged
 

Wriath

  • Captain
  • ****
  • Posts: 279
    • View Profile
    • Email
Re: [0.65.1a] Scy V0.86 (01/12) Hotfix
« Reply #265 on: December 07, 2014, 11:27:11 AM »

Not without some help from Alex, whether he makes them vanilla or allow us to spawn object that are ignored by the AI: the trail were invisible fake missiles placed on top of the engines when the fighter were accelerating and removed otherwise. Problem is, the Point Defense weapons went crazy when those missiles kept appearing and vanishing at close range. They switched targets all the time to face the "new threat" and never actually fired.


Sounds like a mechanic that could be used as like... some sort of ecm target jamming... crap. Maybe use those trails as a ship system?

MesoTroniK

  • Admiral
  • *****
  • Posts: 1371
  • I am going to destroy your ships
    • View Profile
Re: [0.65.1a] Scy V0.86 (01/12) Hotfix
« Reply #266 on: December 07, 2014, 11:47:53 AM »

Sounds like a mechanic that could be used as like... some sort of ecm target jamming... crap. Maybe use those trails as a ship system?

Not a good idea to do it that way, it is far too powerful and infallible because it is literally a really nasty bug.

You could make a scripted target jammer that would have "rules" in place to keep it fair with complex mechanics.
Logged

TartarusMkII

  • Commander
  • ***
  • Posts: 164
    • View Profile
    • Email
Re: [0.65.1a] Scy V0.86 (01/12) Hotfix
« Reply #267 on: December 07, 2014, 12:14:52 PM »

Hello again,

I always update mods by removing them completely and replacing them. To be sure, I did this again just now; I removed SCY and the Twiglib, and replaced them with new versions (They were not out dated).

I started up the save game I have going (was not new), and tried to spawn the Nemean in the simulator, and crashed the same as usual. The end of the log is below. I can't post the whole thing.

Spoiler
117997 [Thread-5] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Loading stage 37
117997 [Thread-5] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Loading stage 38
117998 [Thread-5] INFO  com.fs.starfarer.campaign.save.CampaignGameManager  - Loading stage 39 - last
119654 [Thread-5] DEBUG com.fs.graphics.TextureLoader  - Loading image graphics/SCY/backgrounds/SCY_background1.jpg into existing tex id 424
119944 [Thread-5] DEBUG com.fs.graphics.TextureLoader  - Loaded 937.77 MB of texture data so far
119945 [Thread-5] INFO  com.fs.graphics.TextureLoader  - Cleaned buffer for texture graphics/SCY/backgrounds/SCY_background1.jpg (using cast)
157834 [Thread-5] DEBUG com.fs.graphics.TextureLoader  - Loading image graphics/backgrounds/background4.jpg into existing tex id 424
158060 [Thread-5] DEBUG com.fs.graphics.TextureLoader  - Loaded 949.77 MB of texture data so far
158061 [Thread-5] INFO  com.fs.graphics.TextureLoader  - Cleaned buffer for texture graphics/backgrounds/background4.jpg (using cast)
158062 [Thread-5] INFO  com.fs.starfarer.combat.CombatEngine  - FP1: 18, FP2: 2598, maxFP1: 160, maxFP2: 240
158063 [Thread-5] INFO  org.lazywizard.newsim.SimCombatPlugin  - Using sim_opponents.csv: true
158090 [Thread-5] DEBUG com.fs.graphics.TextureLoader  - Loading image graphics/SCY/backgrounds/SCY_background1.jpg into existing tex id 424
158338 [Thread-5] DEBUG com.fs.graphics.TextureLoader  - Loaded 961.77 MB of texture data so far
158339 [Thread-5] INFO  com.fs.graphics.TextureLoader  - Cleaned buffer for texture graphics/SCY/backgrounds/SCY_background1.jpg (using cast)
169002 [Thread-5] FATAL scy.twig.nemean.SCY_NemeanRootShip  - Unable to spawn nodes
java.lang.NullPointerException
   at scy.twig.nemean.SCY_NemeanRootShip.initHost(SCY_NemeanRootShip.java:92)
   at scy.twig.nemean.SCY_NemeanRootShip.advance(SCY_NemeanRootShip.java:156)
   at com.fs.starfarer.combat.entities.ship.A.G.advance(Unknown Source)
   at com.fs.starfarer.combat.entities.Ship.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advance(Unknown Source)
   at com.fs.starfarer.combat.void.void.class$super(Unknown Source)
   at com.fs.A.oOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOO.Ò00000(Unknown Source)
   at com.fs.starfarer.combat.O0OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.super(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$2.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
169135 [Thread-5] ERROR com.fs.starfarer.combat.O0OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO  - java.lang.NullPointerException
java.lang.NullPointerException
   at data.hullmods.SCY_ArmorPlating.advanceInCombat(SCY_ArmorPlating.java:58)
   at com.fs.starfarer.combat.entities.Ship.advance(Unknown Source)
   at com.fs.starfarer.combat.CombatEngine.advance(Unknown Source)
   at com.fs.starfarer.combat.void.void.class$super(Unknown Source)
   at com.fs.A.oOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOO.Ò00000(Unknown Source)
   at com.fs.starfarer.combat.O0OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.super(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$2.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
[close]
Logged

Tartiflette

  • Admiral
  • *****
  • Posts: 2759
  • Kickstarter is NOT a magic spring of free money!
    • View Profile
Re: [0.65.1a] Scy V0.86 (01/12) Hotfix
« Reply #268 on: December 07, 2014, 12:42:44 PM »

Wait, you used a Scy 0.8 save with Scy 0.86? That's the answer, 0.85 broke the saves! (only 0.86 is compatible with 0.85, everything before is broken)
Logged
 

TartarusMkII

  • Commander
  • ***
  • Posts: 164
    • View Profile
    • Email
Re: [0.65.1a] Scy V0.86 (01/12) Hotfix
« Reply #269 on: December 07, 2014, 12:51:19 PM »

No no, remember mate, you said that in the mod loader it still says .8 because you did not change it's title. I just re-downloaded it directly from the website. The game was already up to date. My save game works just fine, lol. That error is generated when I try to load the simulator with a nemean in it.
Logged
Pages: 1 ... 16 17 [18] 19 20 ... 83