Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.9.1a is out! (05/10/19); Blog post: Painting the Stars (02/07/20)

Author Topic: [Solved] Could not choose GLX13 config on Fedora 16 x86_64  (Read 7150 times)

Ghoti

  • Captain
  • ****
  • Posts: 283
    • View Profile
    • Email
[Solved] Could not choose GLX13 config on Fedora 16 x86_64
« on: February 15, 2012, 06:45:28 AM »

error crops up when attempting to launch Starfarer from configuration screen.

Here is Starfarer's logs:

*clip*
366  [main] INFO  com.fs.starfarer.StarfarerLauncher  - Found display mode: 1600x900, 50Hz, 24bpp
2235 [Thread-6] INFO  com.fs.starfarer.StarfarerLauncher  - Running vanilla game with no mods.
2235 [Thread-6] INFO  com.fs.starfarer.settings.StarfarerSettings  - Loading settings
2296 [Thread-6] ERROR com.fs.graphics.L  - Exiting - exception in LWJGL initialization
org.lwjgl.LWJGLException: Could not choose GLX13 config
   at org.lwjgl.opengl.LinuxDisplayPeerInfo.initDefaultPeerInfo(Native Method)
   at org.lwjgl.opengl.LinuxDisplayPeerInfo.<init>(LinuxDisplayPeerInfo.java:52)
   at org.lwjgl.opengl.LinuxDisplay.createPeerInfo(LinuxDisplay.java:717)
   at org.lwjgl.opengl.Display.create(Display.java:855)
   at org.lwjgl.opengl.Display.create(Display.java:785)
   at com.fs.graphics.L.ô00000(Unknown Source)
   at com.fs.starfarer.combat.String.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$2.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
2297 [Thread-6] ERROR com.fs.starfarer.combat.String  - java.lang.RuntimeException: Exiting - exception in LWJGL initialization
java.lang.RuntimeException: Exiting - exception in LWJGL initialization
   at com.fs.graphics.L.ô00000(Unknown Source)
   at com.fs.starfarer.combat.String.o00000(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher$2.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
Caused by: org.lwjgl.LWJGLException: Could not choose GLX13 config
   at org.lwjgl.opengl.LinuxDisplayPeerInfo.initDefaultPeerInfo(Native Method)
   at org.lwjgl.opengl.LinuxDisplayPeerInfo.<init>(LinuxDisplayPeerInfo.java:52)
   at org.lwjgl.opengl.LinuxDisplay.createPeerInfo(LinuxDisplay.java:717)
   at org.lwjgl.opengl.Display.create(Display.java:855)
   at org.lwjgl.opengl.Display.create(Display.java:785)
   ... 4 more
3360 [Thread-6] INFO  com.fs.profiler.Profiler  - ID     Calls   Duration    Percent
3361 [Thread-6] INFO  com.fs.profiler.Profiler  - --------------------------------

This is likely relating to being the wrong architecture of java, or some library I don't have that I don't know Starfarer needs because it's on every system by default except for x86_64 and it's not reporting that it needs it.

This is after I downloaded a heap of i686 libraries, I'm thinking maybe I missed a few?

I don't suppose I could convince you to make a 64bit build? It would make me happy!
« Last Edit: February 16, 2012, 09:21:55 AM by Ghoti »
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 16012
    • View Profile
Re: Could not choose GLX13 config on Fedora 16 x86_64
« Reply #1 on: February 15, 2012, 07:50:20 AM »

Hi - would you mind trying to run with your system's Java? Just change starfarer.sh to use it instead of the JRE bundled with the game.
Logged

Ghoti

  • Captain
  • ****
  • Posts: 283
    • View Profile
    • Email
Re: Could not choose GLX13 config on Fedora 16 x86_64
« Reply #2 on: February 15, 2012, 09:51:31 AM »

Hi Alex, I saw your pinned topic, and I did try that!

I got this error:

0    [main] INFO  com.fs.starfarer.StarfarerLauncher  - Starting Starfarer 0.5a Preview launcher
3    [main] INFO  com.fs.starfarer.StarfarerLauncher  - OS: Linux 3.2.5-3.fc16.x86_64
3    [main] INFO  com.fs.starfarer.StarfarerLauncher  - Java version: 1.7.0_b147-icedtea
1069 [main] ERROR com.fs.starfarer.StarfarerLauncher  - java.lang.UnsatisfiedLinkError: /home/Ghoti/starfarer/native/linux/liblwjgl.so: /home/Ghoti/starfarer/native/linux/liblwjgl.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
java.lang.UnsatisfiedLinkError: /home/Ghoti/starfarer/native/linux/liblwjgl.so: /home/Ghoti/starfarer/native/linux/liblwjgl.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
   at java.lang.ClassLoader$NativeLibrary.load(Native Method)
   at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1928)
   at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1854)
   at java.lang.Runtime.loadLibrary0(Runtime.java:845)
   at java.lang.System.loadLibrary(System.java:1084)
   at org.lwjgl.Sys$1.run(Sys.java:73)
   at java.security.AccessController.doPrivileged(Native Method)
   at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
   at org.lwjgl.Sys.loadLibrary(Sys.java:82)
   at org.lwjgl.Sys.<clinit>(Sys.java:99)
   at org.lwjgl.opengl.Display.<clinit>(Display.java:130)
   at com.fs.graphics.DisplayManager.Ò00000(Unknown Source)
   at com.fs.starfarer.launcher.StarfarerLauncherUI.void(Unknown Source)
   at com.fs.starfarer.launcher.StarfarerLauncherUI.if(Unknown Source)
   at com.fs.starfarer.launcher.StarfarerLauncherUI$Oo.<init>(Unknown Source)
   at com.fs.starfarer.launcher.StarfarerLauncherUI.super(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher.<init>(Unknown Source)
   at com.fs.starfarer.StarfarerLauncher.main(Unknown Source)

which is WEIRD, because that library exists in ./native/linux/

I tried symlinking liblwjgl to liblwjgl64, but that didn't work either... Rumor has it SELinux doesn't like libraries in writable owned directories, but usually it pops up with an alert if it prevents an action from happening...

Mystery. MYSTERY.
Logged

BlackRazor

  • Ensign
  • *
  • Posts: 2
    • View Profile
Re: Could not choose GLX13 config on Fedora 16 x86_64
« Reply #3 on: February 16, 2012, 12:46:55 AM »

I also have the same problem on Ubuntu 64-bits, AFAIK it is a common problem to many games like Minecraft that use the same "setup" (Java + some specific libraries).
In order to solve the problem you have to modify the "starfarer.sh" script and set the LD_LIBRARY_PATH environmental variable so that it points to the correct directory; on my system (Ubuntu 11.10 64 bits + OpenJDK 7) this directory is "/usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64".
So my "starfarer.sh" looks like this:

Code
export LD_LIBRARY_PATH="/usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64"
java -server -XX:CompilerThreadPriority=1 -XX:+CompilerThreadHintNoPreempt -Djava.library.path=./native/linux -Xms256m -Xmx256m -classpath janino.jar:commons-compiler.jar:commons-compiler-jdk.jar:starfarer.api.jar:starfarer_obf.jar:jogg-0.0.7.jar:jorbis-0.0.15.jar:json.jar:lwjgl.jar:jinput.jar:log4j-1.2.9.jar:lwjgl_util.jar:fs.sound_obf.jar:fs.common_obf.jar:xstream-1.4.2.jar -Dcom.fs.starfarer.settings.paths.saves=./saves -Dcom.fs.starfarer.settings.paths.screenshots=./screenshots -Dcom.fs.starfarer.settings.paths.mods=./mods -Dcom.fs.starfarer.settings.paths.logs=. com.fs.starfarer.StarfarerLauncher

This is the listing of the "/usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64" directory on my system to help you locate it on Fedora:
Quote
drwxr-xr-x 2 root root 4,0K 2012-01-20 21:03 headless/
drwxr-xr-x 2 root root 4,0K 2012-01-20 21:06 jamvm/
drwxr-xr-x 2 root root 4,0K 2012-01-20 21:03 jli/
lrwxrwxrwx 1 root root   33 2011-10-22 00:32 jvm.cfg -> /etc/java-7-openjdk/jvm-amd64.cfg
-rw-r--r-- 1 root root  278 2011-10-22 00:32 jvm.cfg-default
-rw-r--r-- 1 root root  15K 2011-10-22 00:33 libattach.so
-rw-r--r-- 1 root root 693K 2011-10-22 00:33 libawt.so
-rw-r--r-- 1 root root  19K 2011-10-22 00:33 libdt_socket.so
-rw-r--r-- 1 root root 244K 2011-10-22 00:33 libfontmanager.so
-rw-r--r-- 1 root root 167K 2011-10-22 00:33 libhprof.so
-rw-r--r-- 1 root root  43K 2011-10-22 00:33 libinstrument.so
-rw-r--r-- 1 root root  39K 2011-10-22 00:33 libj2gss.so
-rw-r--r-- 1 root root  15K 2011-10-22 00:33 libj2pcsc.so
-rw-r--r-- 1 root root  67K 2011-10-22 00:33 libj2pkcs11.so
-rw-r--r-- 1 root root 6,0K 2011-10-22 00:33 libjaas_unix.so
-rw-r--r-- 1 root root  23K 2011-10-22 00:33 libjava_crw_demo.so
-rw-r--r-- 1 root root  39K 2011-10-22 00:33 libjavajpeg.so
-rw-r--r-- 1 root root  19K 2011-10-22 00:33 libjavalcms.so
-rw-r--r-- 1 root root 171K 2011-10-22 00:33 libjava.so
-rw-r--r-- 1 root root 6,0K 2011-10-22 00:33 libjawt.so
-rw-r--r-- 1 root root 236K 2011-10-22 00:33 libjdwp.so
-rw-r--r-- 1 root root  11K 2011-10-22 00:33 libjsdt.so
-rw-r--r-- 1 root root  11K 2011-10-22 00:33 libjsig.so
-rw-r--r-- 1 root root  64K 2011-10-22 00:33 libjsoundalsa.so
-rw-r--r-- 1 root root 6,1K 2011-10-22 00:33 libjsound.so
-rw-r--r-- 1 root root  35K 2011-10-22 00:33 libmanagement.so
-rw-r--r-- 1 root root 839K 2011-10-22 00:33 libmlib_image.so
-rw-r--r-- 1 root root  91K 2011-10-22 00:33 libnet.so
-rw-r--r-- 1 root root  68K 2011-10-22 00:33 libnio.so
-rw-r--r-- 1 root root  15K 2011-10-22 00:33 libnpt.so
-rw-r--r-- 1 root root  47K 2011-10-22 00:33 libpulse-java.so
-rw-r--r-- 1 root root 6,0K 2011-10-22 00:33 librmi.so
-rw-r--r-- 1 root root  43K 2011-10-22 00:33 libsaproc.so
-rw-r--r-- 1 root root  23K 2011-10-22 00:33 libsctp.so
-rw-r--r-- 1 root root  43K 2011-10-22 00:33 libsplashscreen.so
-rw-r--r-- 1 root root  82K 2011-10-22 00:33 libunpack.so
-rw-r--r-- 1 root root  63K 2011-10-22 00:33 libverify.so
-rw-r--r-- 1 root root  35K 2011-10-22 00:33 libzip.so
drwxr-xr-x 2 root root 4,0K 2012-01-20 21:03 server/
drwxr-xr-x 2 root root 4,0K 2012-01-20 21:05 xawt/
Logged

Ghoti

  • Captain
  • ****
  • Posts: 283
    • View Profile
    • Email
Re: Could not choose GLX13 config on Fedora 16 x86_64
« Reply #4 on: February 16, 2012, 09:21:39 AM »

deargoditworks

oh by the way.
On fedora 16 x86_64 export is
export LD_LIBRARY_PATH="/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.1.x86_64/jre/lib/amd64/"
« Last Edit: February 16, 2012, 09:27:06 AM by Ghoti »
Logged

BlackRazor

  • Ensign
  • *
  • Posts: 2
    • View Profile
Re: [Solved] Could not choose GLX13 config on Fedora 16 x86_64
« Reply #5 on: February 20, 2012, 06:13:38 AM »

Quick update on an issue I have noticed with Minecraft but that also happens with Starfarer: the solution above could cause problems because it overwrites the original value of the LD_LIBRARY_PATH environmental variable; in particular if the above solution is used with Bumblebee on a Laptop with nVidia Optimus it causes the game to crash on startup because the nVidia libraries can no longer be found.

The correct solution is to preserve the original value of the variable like this:
Code
export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64"

Just an FYI for everybody with this problem ;)
Logged