Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Starsector 0.9.1a is out! (05/10/19); Blog post: Painting the Stars (02/07/20); Updated the Forum Rules and Guidelines (02/29/20)

Author Topic: Freighter Behavior (Pirate Plunder Fleet)  (Read 874 times)

StahnAileron

  • Commander
  • ***
  • Posts: 178
    • View Profile
Freighter Behavior (Pirate Plunder Fleet)
« on: September 22, 2013, 01:12:35 PM »

I'm finding that with Pirate Plunder Fleets, the AI thinks the Freighters are combat ready, so they try to Engage even if they are the only CR-viable ships left. This is usually the case after a fight since the AI keeps them in reserve during the initial battle phase. However, when I re-engage the Freighter-only fleet (along with the mothballed ships it's transporting), the AI doesn't deploy ANY ships at all. I have to deploy at least one combat capable ship to get the "Enemy Defeated" message (sadly, tugs don't count.) They will continue to do this on engagement unless I leave or I harry the reserves after each engagement until their CR rating is below deployable levels. This is a waste of my fleet's CR rating since I have to deploy a ship to harry them low enough to actually fight them. Letting them go and intercepting them again produces the ENGAGE > NO DEPLOY > DEFEATED > HARRY cycle again.

On a somewhat related note, I've noticed that sometimes, freighter CR ratings aren't displayed at the dialogue screen. I'm not sure if this is a bug or if their CR rating is so low that it takes 2-3 harry's before their actual CR rating falls below their max CR.

Both cases involve the Tarsus freighter, if that helps.
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 16226
    • View Profile
Re: Freighter Behavior (Pirate Plunder Fleet)
« Reply #1 on: September 22, 2013, 01:14:35 PM »

Thanks - reported a while ago and fixed :)

On a somewhat related note, I've noticed that sometimes, freighter CR ratings aren't displayed at the dialogue screen. I'm not sure if this is a bug or if their CR rating is so low that it takes 2-3 harry's before their actual CR rating falls below their max CR.

Both cases involve the Tarsus freighter, if that helps.

The CR bar isn't displayed if the CR is above the ship's maximum. That's not quite right, though, it should also be shown when it's getting low even if the maximum is 0/very low. Will tweak that.

Thanks for the reports!
Logged