Fractal Softworks Forum
November 19, 2017, 04:25:33 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New blog post: Economy & Outposts (9/19/17); Starsector 0.8.1a is out!
 
   Home   Help Search Login Register  
Pages: 1 ... 20 21 [22] 23 24 25
  Print  
Author Topic: [0.7.2a] Exigency v0.7.2 - Updated 3/19/17  (Read 171749 times)
Midnight Kitsune
Admiral
*****
Posts: 2126


Your Friendly Forum Furry!


View Profile
« Reply #315 on: March 19, 2017, 09:34:06 PM »

First of all you might want to run Version Checker and see if any files need updates. And maybe just redownload the full Nexe mod.

Appo, Citadel, Hiigarans, Kadur, NGO, Valks
Yeah... I can see why you could end up with an error. These are VERY low quality mods that are buggy (and OP as all hell) and many times are not cared for by their modders.
I would remove these and see if you can run the game with Exi. If not you might want to add Torn Up Plenty, Mayorate to the list of excluded mods as well. If this fixes it, try finding the mod that creates issues with Exi and tell us here.
While the game might work with these mods without Exi running, they might have scripts or conflicts with Exi.

Another issue that could be causing this error is the using JRE 8. JRE is so buggy that Alex switched back to 7 after a brief use of 8. HOWEVER, this means that some of your mods will crash. Mainly Hiigarans and Kadur. Raccoon arms might crash as well
« Last Edit: March 19, 2017, 09:38:29 PM by Midnight Kitsune » Logged

Stop trying to balance the game around a few minmaxers...
Programming is like sex:
One mistake and you have to support it for the rest of your life.

Tired of having your game crash because of out of date mods? Then click here!
Get Version Checker today! Now with 90% less hassle! Simply toss it into your mod folder, activate the mod like a normal one and BINGO you will now be informed of any and all updates when you start SS campaign up!
peperoni_playboy
Lieutenant
**
Posts: 57



View Profile
« Reply #316 on: March 19, 2017, 09:40:06 PM »

First of all you might want to run Version Checker and see if any files need updates. And maybe just redownload the full Nexe mod.

Appo, Citadel, Hiigarans, Kadur, NGO, Valks
Yeah... I can see why you could end up with an error. These are VERY low quality mods that are buggy (and OP as all hell) and many times are not cared for by their modders.
I would remove these and see if you can run the game with Exi. If not you might want to add Torn Up Plenty, Mayorate to the list of excluded mods as well. If this fixes it, try finding the mod that creates issues with Exi and tell us here.
While the game might work with these mods without Exi running, they might have scripts or conflicts with Exi.

Another issue that could be causing this error is the using JRE 8.

I've updated all the mods that version checker marked as out of date, and I have tried running it with a full new Nex instead of just an update.

I'm going to start troubleshooting the mods, I'll let you guys know if I find out what the conflict is.
Logged
peperoni_playboy
Lieutenant
**
Posts: 57



View Profile
« Reply #317 on: March 19, 2017, 10:14:46 PM »

After a bit of testing, it would appear that Exigency and Hiigaran Descendants are not compatible with each other. Once I disabled Hiigaran Descendants, I was able to make it into a Nexerelin campaign with Exigency and the rest of my mod list enabled.

Just to clarify; the game itself will boot up with the two incompatible mods active, but if you try to start a Nexerelin campaign your game will crash (or at least mine did).

Thanks to everyone who took the time to help me figure this out.
« Last Edit: March 19, 2017, 10:18:59 PM by peperoni_playboy » Logged
Midnight Kitsune
Admiral
*****
Posts: 2126


Your Friendly Forum Furry!


View Profile
« Reply #318 on: March 19, 2017, 10:40:15 PM »

After a bit of testing, it would appear that Exigency and Hiigaran Descendants are not compatible with each other. Once I disabled Hiigaran Descendants, I was able to make it into a Nexerelin campaign with Exigency and the rest of my mod list enabled.

Just to clarify; the game itself will boot up with the two incompatible mods active, but if you try to start a Nexerelin campaign your game will crash (or at least mine did).

Thanks to everyone who took the time to help me figure this out.
No problem! I would avoid using any of the Defias mods as they are REALLY buggy, like Kadur
Logged

Stop trying to balance the game around a few minmaxers...
Programming is like sex:
One mistake and you have to support it for the rest of your life.

Tired of having your game crash because of out of date mods? Then click here!
Get Version Checker today! Now with 90% less hassle! Simply toss it into your mod folder, activate the mod like a normal one and BINGO you will now be informed of any and all updates when you start SS campaign up!
JDCollie
Commander
***
Posts: 209



View Profile
« Reply #319 on: March 19, 2017, 10:42:55 PM »

Yay! It's been updated!
Logged
Midnight Kitsune
Admiral
*****
Posts: 2126


Your Friendly Forum Furry!


View Profile
« Reply #320 on: March 20, 2017, 12:09:49 AM »

After a bit of testing, it would appear that Exigency and Hiigaran Descendants are not compatible with each other. Once I disabled Hiigaran Descendants, I was able to make it into a Nexerelin campaign with Exigency and the rest of my mod list enabled.

Just to clarify; the game itself will boot up with the two incompatible mods active, but if you try to start a Nexerelin campaign your game will crash (or at least mine did).

Thanks to everyone who took the time to help me figure this out.
Hey, what exactly are you doing to make the game crash?
Logged

Stop trying to balance the game around a few minmaxers...
Programming is like sex:
One mistake and you have to support it for the rest of your life.

Tired of having your game crash because of out of date mods? Then click here!
Get Version Checker today! Now with 90% less hassle! Simply toss it into your mod folder, activate the mod like a normal one and BINGO you will now be informed of any and all updates when you start SS campaign up!
Takion Kasukedo
Captain
****
Posts: 375


The Embodiment of Defilement, TakionKasukedo


View Profile
« Reply #321 on: March 20, 2017, 05:12:49 AM »

An error occured when I selected the Pergon as a sim opponent

(Starsector 0.7.2a)

Fatal; data/shipsystems/scripts/DisruptorAmmoStats : Unsupported major.minor version 52.0

Check starsector.log for more info

I retrieved this from the log
---------------------------
6413500 [Thread-4] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.UnsupportedClassVersionError: data/shipsystems/scripts/DisruptorAmmoStats : Unsupported major.minor version 52.0
java.lang.UnsupportedClassVersionError: data/shipsystems/scripts/DisruptorAmmoStats : Unsupported major.minor version 52.0
   at java.lang.ClassLoader.defineClass1(Native Method)
   at java.lang.ClassLoader.defineClass(Unknown Source)
   at java.security.SecureClassLoader.defineClass(Unknown Source)
   at java.net.URLClassLoader.defineClass(Unknown Source)
   at java.net.URLClassLoader.access$100(Unknown Source)
   at java.net.URLClassLoader$1.run(Unknown Source)
   at java.net.URLClassLoader$1.run(Unknown Source)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.net.URLClassLoader.findClass(Unknown Source)
   at java.lang.ClassLoader.loadClass(Unknown Source)
   at java.lang.ClassLoader.loadClass(Unknown Source)
   at java.lang.ClassLoader.loadClass(Unknown Source)
   at java.lang.Class.forName0(Native Method)
   at java.lang.Class.forName(Unknown Source)
   at com.fs.starfarer.loading.scripts.ScriptStore.Ó00000(Unknown Source)
   at com.fs.starfarer.loading.specs.N.getStatsScript(Unknown Source)
   at com.fs.starfarer.combat.systems.F.<init>(Unknown Source)
   at com.fs.starfarer.combat.systems.P.<init>(Unknown Source)
   at com.fs.starfarer.loading.specs.N.createSystem(Unknown Source)
   at com.fs.starfarer.combat.entities.Ship.<init>(Unknown Source)
   at com.fs.starfarer.loading.specs.forsuper.o00000(Unknown Source)
   at com.fs.starfarer.title.C.OO0O.Ò00000(Unknown Source)
   at com.fs.starfarer.title.C.OO0O.o00000(Unknown Source)
   at com.fs.starfarer.coreui.oOoo.o00000(Unknown Source)
   at com.fs.starfarer.ui.interfacesuper.renderImpl(Unknown Source)
   at com.fs.starfarer.ui.O00OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO.render(Unknown Source)
Logged

The Embodiment of Defilement reigns over his part of the galaxy.

FEAR THE CASCADE.
Histidine
Admiral
*****
Posts: 1652



View Profile WWW Email
« Reply #322 on: March 20, 2017, 05:19:43 AM »

You're using some mod (no idea which one but it's not Exi) that requires JRE 8.
Logged

Takion Kasukedo
Captain
****
Posts: 375


The Embodiment of Defilement, TakionKasukedo


View Profile
« Reply #323 on: March 20, 2017, 06:07:04 AM »

Must be Raccoon's Arms Pack or something, i'll switch to 7.

Edit, grabbed the latest one, will report back if it is indeed RAP or Java.
« Last Edit: March 20, 2017, 06:09:17 AM by Takion Kasukedo » Logged

The Embodiment of Defilement reigns over his part of the galaxy.

FEAR THE CASCADE.
peperoni_playboy
Lieutenant
**
Posts: 57



View Profile
« Reply #324 on: March 20, 2017, 07:30:38 AM »

After a bit of testing, it would appear that Exigency and Hiigaran Descendants are not compatible with each other. Once I disabled Hiigaran Descendants, I was able to make it into a Nexerelin campaign with Exigency and the rest of my mod list enabled.

Just to clarify; the game itself will boot up with the two incompatible mods active, but if you try to start a Nexerelin campaign your game will crash (or at least mine did).

Thanks to everyone who took the time to help me figure this out.
Hey, what exactly are you doing to make the game crash?
With Hiigaran Descendants and Exigency enabled at the same time, the game would crash while generating a sector for a new Nexerelin campaign. If you only use one of these mods, the crash doesn't occur.
Logged
cjusa
Captain
****
Posts: 274


Missiles and Mecha, my boys. Missiles and Mecha


View Profile Email
« Reply #325 on: March 20, 2017, 12:01:33 PM »

Yay! Now I can do this again!
Logged

Very few problems can't be solved with gratuitous violence and epic explosions.

I am pro at Paradox-Billiards-Vostroyan-Roulette-Fourth-Dimensional-Hypercube-Chess-Strip-Poker. Fight me.

I've seen things you people wouldn't believe. Eagles and Falcons on fire off the L5 of Sindria. I watched Tachyon beams glitter in the dark near the Perseus Nebula...
Midnight Kitsune
Admiral
*****
Posts: 2126


Your Friendly Forum Furry!


View Profile
« Reply #326 on: March 20, 2017, 12:49:06 PM »

Yay! Now I can do this again!
Source? That looks much MUCH newer than the Robotech/ Macross that I'm use to!

After a bit of testing, it would appear that Exigency and Hiigaran Descendants are not compatible with each other. Once I disabled Hiigaran Descendants, I was able to make it into a Nexerelin campaign with Exigency and the rest of my mod list enabled.

Just to clarify; the game itself will boot up with the two incompatible mods active, but if you try to start a Nexerelin campaign your game will crash (or at least mine did).

Thanks to everyone who took the time to help me figure this out.
Hey, what exactly are you doing to make the game crash?
With Hiigaran Descendants and Exigency enabled at the same time, the game would crash while generating a sector for a new Nexerelin campaign. If you only use one of these mods, the crash doesn't occur.
I meant more along the lines of what mods you used, what faction you joined, Corvus mode, if Omni and or Prism was enabled? Stuff like that.
« Last Edit: March 20, 2017, 12:50:41 PM by Midnight Kitsune » Logged

Stop trying to balance the game around a few minmaxers...
Programming is like sex:
One mistake and you have to support it for the rest of your life.

Tired of having your game crash because of out of date mods? Then click here!
Get Version Checker today! Now with 90% less hassle! Simply toss it into your mod folder, activate the mod like a normal one and BINGO you will now be informed of any and all updates when you start SS campaign up!
peperoni_playboy
Lieutenant
**
Posts: 57



View Profile
« Reply #327 on: March 20, 2017, 01:05:55 PM »

After a bit of testing, it would appear that Exigency and Hiigaran Descendants are not compatible with each other. Once I disabled Hiigaran Descendants, I was able to make it into a Nexerelin campaign with Exigency and the rest of my mod list enabled.

Just to clarify; the game itself will boot up with the two incompatible mods active, but if you try to start a Nexerelin campaign your game will crash (or at least mine did).

Thanks to everyone who took the time to help me figure this out.
Hey, what exactly are you doing to make the game crash?
With Hiigaran Descendants and Exigency enabled at the same time, the game would crash while generating a sector for a new Nexerelin campaign. If you only use one of these mods, the crash doesn't occur.
I meant more along the lines of what mods you used, what faction you joined, Corvus mode, if Omni and or Prism was enabled? Stuff like that.

I was using the same mods as the list I posted earlier.

I joined the player faction.

I tried both Nexerelin and Corvus mode, they both crashed on sector generation.

I had Omni and Prism enabled, I forget the rest of the settings.
« Last Edit: March 20, 2017, 01:11:20 PM by peperoni_playboy » Logged
cjusa
Captain
****
Posts: 274


Missiles and Mecha, my boys. Missiles and Mecha


View Profile Email
« Reply #328 on: March 20, 2017, 02:39:28 PM »

Yay! Now I can do this again!
Source? That looks much MUCH newer than the Robotech/ Macross that I'm use to!

Macross Delta. I much preferred Macross Frontier, but the link wasn't working right for the first gif I found. This is also why I want a Macross mod:
Logged

Very few problems can't be solved with gratuitous violence and epic explosions.

I am pro at Paradox-Billiards-Vostroyan-Roulette-Fourth-Dimensional-Hypercube-Chess-Strip-Poker. Fight me.

I've seen things you people wouldn't believe. Eagles and Falcons on fire off the L5 of Sindria. I watched Tachyon beams glitter in the dark near the Perseus Nebula...
Absolutecero
Ensign
*
Posts: 30


View Profile Email
« Reply #329 on: March 20, 2017, 06:03:09 PM »

Hey its great that you fixed up this mod but I have noticed the salamander missiles  don't get reflected by the repulsor very well and was wondering if that was intentional.
 
Logged
Pages: 1 ... 20 21 [22] 23 24 25
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2006-2011, Simple Machines
Simple Audio Video Embedder
Valid XHTML 1.0! Valid CSS!