Fractal Softworks Forum

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Temporary loss of all Hullmods  (Read 1163 times)

erynr73

  • Ensign
  • *
  • Posts: 29
    • View Profile
Temporary loss of all Hullmods
« on: November 26, 2012, 03:28:31 PM »

Not sure if this is a bug or it's intended; I was fighting a stack of Pirate fleets and lvl'd up between battles.  I put pts in the tech tree which gave me a couple more OPs which I added to capacitance (only change I made).  The next fight took place right after leaving the refit screen before the refit had time to finish.  However instead of just missing the extra capacitance, I was missing all my hullmods (ITU, Frontal Shield emitter, Aux Thrusters, and many more!).

Admittedly this doesn't happen very often since that minor a refit takes less then a day to complete but thought you should know.  Luckily I was piloting a paragon and it wasn't a big pirate fleet so I still won, just took longer :)
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 17028
    • View Profile
Re: Temporary loss of all Hullmods
« Reply #1 on: November 26, 2012, 03:32:37 PM »

That's intended - hullmods aren't available until the refit is finished. If you look at the ship tooltip, they'll be red and it'll say something like "pending refit completion".
Logged

Cosmitz

  • Admiral
  • *****
  • Posts: 755
    • View Profile
Re: Temporary loss of all Hullmods
« Reply #2 on: November 28, 2012, 01:25:09 AM »

Maybe a confirmation should be added when Refitting in space. "Are you sure you want to commit changes? All hullmods will be disabled until refit finishes. Yes/No"
Logged

Alex

  • Administrator
  • Admiral
  • *****
  • Posts: 17028
    • View Profile
Re: Temporary loss of all Hullmods
« Reply #3 on: November 28, 2012, 08:18:47 AM »

I appreciate the suggestion, but please, as it says in the sticky, let's keep the bug reports forum for bug reports.
Logged